summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--CMakeLists.txt6
-rw-r--r--ChangeLog.md15
-rw-r--r--librabbitmq/amqp.h2
3 files changed, 19 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 58b57c0..c8107ce 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -16,9 +16,9 @@ set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} ${CMAKE_CURRENT_SOURCE_DIR}/cmake)
# 3. If any interfaces have been added since the last public release, then increment age.
# 4. If any interfaces have been removed since the last public release, then set age to 0.
-set(RMQ_SOVERSION_CURRENT 7)
-set(RMQ_SOVERSION_REVISION 1)
-set(RMQ_SOVERSION_AGE 3)
+set(RMQ_SOVERSION_CURRENT 8)
+set(RMQ_SOVERSION_REVISION 0)
+set(RMQ_SOVERSION_AGE 4)
math(EXPR RMQ_SOVERSION_MAJOR "${RMQ_SOVERSION_CURRENT} - ${RMQ_SOVERSION_AGE}")
math(EXPR RMQ_SOVERSION_MINOR "${RMQ_SOVERSION_AGE}")
diff --git a/ChangeLog.md b/ChangeLog.md
index f9d7e40..919f2ce 100644
--- a/ChangeLog.md
+++ b/ChangeLog.md
@@ -1,4 +1,19 @@
# Change Log
+## v0.10.0 - 2019-12-01
+## Added:
+- amqp_ssl_socket_get_context can be used to get the current OpenSSL CTX*
+ associated with a connection.
+
+## Changed:
+- openssl: missing OpenSSL config is ignored as an OpenSSL init error (#523)
+- AMQP_DEFAULT_MAX_CHANNELS is now set to 2047 to follow current default channel
+ limit in the RabbitMQ broker. (#513)
+
+## Fixed:
+- add additional input validation to prevent integer overflow when parsing a
+ frame header. This addresses CVE-2019-18609.
+
+
## v0.9.0 - 2018-05-08
### Added:
- amqp-publish: added support for specifying headers via the -H flag
diff --git a/librabbitmq/amqp.h b/librabbitmq/amqp.h
index 2983b16..487db74 100644
--- a/librabbitmq/amqp.h
+++ b/librabbitmq/amqp.h
@@ -221,7 +221,7 @@ AMQP_BEGIN_DECLS
#define AMQP_VERSION_MAJOR 0
#define AMQP_VERSION_MINOR 10
#define AMQP_VERSION_PATCH 0
-#define AMQP_VERSION_IS_RELEASE 0
+#define AMQP_VERSION_IS_RELEASE 1
/**
* \def AMQP_VERSION_CODE