summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--CMakeLists.txt4
-rw-r--r--ChangeLog.md22
-rw-r--r--configure.ac8
-rw-r--r--librabbitmq/amqp.h6
4 files changed, 31 insertions, 9 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2bca4cc..d89eea6 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -12,9 +12,9 @@ set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} ${CMAKE_CURRENT_SOURCE_DIR}/cmake)
# 3. If any interfaces have been added since the last public release, then increment age.
# 4. If any interfaces have been removed since the last public release, then set age to 0.
-set(RMQ_SOVERSION_CURRENT 4)
+set(RMQ_SOVERSION_CURRENT 5)
set(RMQ_SOVERSION_REVISION 1)
-set(RMQ_SOVERSION_AGE 0)
+set(RMQ_SOVERSION_AGE 1)
math(EXPR RMQ_SOVERSION_MAJOR "${RMQ_SOVERSION_CURRENT} - ${RMQ_SOVERSION_AGE}")
math(EXPR RMQ_SOVERSION_MINOR "${RMQ_SOVERSION_AGE}")
diff --git a/ChangeLog.md b/ChangeLog.md
index 45774d6..5831255 100644
--- a/ChangeLog.md
+++ b/ChangeLog.md
@@ -1,4 +1,26 @@
# Change Log
+## Changes since v0.6.0 (a.k.a., v0.7.0)
+- `3379812` Tools: Add support for heartbeats
+- `d7029db` CI: Add continuous integration on Win32 using Appveyor
+- `a5f7ffb` Tests: only link against static libraries
+- `a16ad45...9cf7a3b` Lib: add support for EXTERNAL SASL method
+- `038a9ed` Lib: fix incorrect parameters to WSAPoll on Win32
+- `a240c69...14ae307` Lib: use non-blocking sockets internally
+- `8d1d5cc`, `5498dc6` Lib: simplify timer/timeout logic
+- `61fc4e1` Lib: add support for heartbeat checks in blocking send calls
+- `f462c0f...3546a70` Lib: Fix warnings on Win32
+- `ba9d8ba...112a54d` Lib: Add support for RabbitMQ auth failure extension
+- `fb8e318` Lib: allow calling functions to override client-properties
+- `3ef3f5f` examples: replace usleep() with nanosleep()
+- `9027a94` Lib: add AMQP_VERSION code
+- `9ee1718` Lib: fix res maybe returned uninitialized in amqp_merge_capbilities
+- `22a36db` Lib: Fix SSL_connection status check
+- `abbefd4` Lib: Fix issues with c89 compatiblity
+- `2bc1f9b...816cbfc` Lib: perf improvements when sending small messages by
+ hinting to the OS message boundaries.
+- `be2e6dd...784a0e9` Lib: add select()-based timeout implementation
+- `91db548...8d77b4c` CI: add ubsan, asan, and tsan CI builds
+
## Changes since v0.5.2 (a.k.a., v0.6.0)
- `e1746f9` Tools: Enable support for SSL in tools.
- `9626dd5` Lib: ABI CHANGE: enable support for auto_delete, internal flags to
diff --git a/configure.ac b/configure.ac
index d1781bd..9965dfd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2,8 +2,8 @@
AC_PREREQ([2.59])
m4_define([major_version], [0])
-m4_define([minor_version], [6])
-m4_define([micro_version], [1])
+m4_define([minor_version], [7])
+m4_define([micro_version], [0])
# Follow all steps below in order to calculate new ABI version when updating the library
# NOTE: THIS IS UNRELATED to the actual project version
@@ -12,9 +12,9 @@ m4_define([micro_version], [1])
# 2. If any interfaces have been added, removed, or changed since the last update, increment current and set revision to 0.
# 3. If any interfaces have been added since the last public release, then increment age.
# 4. If any interfaces have been removed since the last public release, then set age to 0.
-m4_define([soversion_current], [4])
+m4_define([soversion_current], [5])
m4_define([soversion_revision], [1])
-m4_define([soversion_age], [0])
+m4_define([soversion_age], [1])
AC_INIT([rabbitmq-c], [major_version.minor_version.micro_version],
[https://github.com/alanxz/rabbitmq-c/issues], [rabbitmq-c],
diff --git a/librabbitmq/amqp.h b/librabbitmq/amqp.h
index 8528669..5e903e1 100644
--- a/librabbitmq/amqp.h
+++ b/librabbitmq/amqp.h
@@ -223,9 +223,9 @@ AMQP_BEGIN_DECLS
*/
#define AMQP_VERSION_MAJOR 0
-#define AMQP_VERSION_MINOR 6
-#define AMQP_VERSION_PATCH 1
-#define AMQP_VERSION_IS_RELEASE 0
+#define AMQP_VERSION_MINOR 7
+#define AMQP_VERSION_PATCH 0
+#define AMQP_VERSION_IS_RELEASE 1
/**