summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--CMakeLists.txt6
-rw-r--r--ChangeLog.md34
-rw-r--r--librabbitmq/amqp.h6
3 files changed, 40 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index fc07473..b5a9311 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -16,9 +16,9 @@ set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} ${CMAKE_CURRENT_SOURCE_DIR}/cmake)
# 3. If any interfaces have been added since the last public release, then increment age.
# 4. If any interfaces have been removed since the last public release, then set age to 0.
-set(RMQ_SOVERSION_CURRENT 6)
-set(RMQ_SOVERSION_REVISION 1)
-set(RMQ_SOVERSION_AGE 2)
+set(RMQ_SOVERSION_CURRENT 7)
+set(RMQ_SOVERSION_REVISION 0)
+set(RMQ_SOVERSION_AGE 3)
math(EXPR RMQ_SOVERSION_MAJOR "${RMQ_SOVERSION_CURRENT} - ${RMQ_SOVERSION_AGE}")
math(EXPR RMQ_SOVERSION_MINOR "${RMQ_SOVERSION_AGE}")
diff --git a/ChangeLog.md b/ChangeLog.md
index 0350e7e..f9d7e40 100644
--- a/ChangeLog.md
+++ b/ChangeLog.md
@@ -1,4 +1,38 @@
# Change Log
+## v0.9.0 - 2018-05-08
+### Added:
+- amqp-publish: added support for specifying headers via the -H flag
+- Add support for specifying timeout for amqp_login calls via
+ amqp_set_handshake_timeout
+- Add support for specifying timeouts in RPC-style AMQP methods via
+ amqp_set_rpc_timeout
+- Add define for `AMQP_DEFAULT_VHOST`
+- Support for SSL SNI
+- Support for OpenSSL v1.1.0
+
+### Changed:
+- rabbitmq-c now requires Windows Vista or better
+- rabbitmq-c enables TCP keep-alive by default on platforms that support it
+- dropped support for compiling rabbitmq-c without threading support
+- OpenSSL is no longer un-intialized automatically by default. OpenSSL can be
+ explicitly initialized by calling amqp_initialize_ssl_library and
+ uninitialized by calling amqp_uninitialize_ssl_library.
+
+### Fixed:
+- Correct bugs in processing of --url flag in tools (#364).
+- Improve documentation on AMQP_SASL_METHOD_EXTERNAL (#349)
+- Improve support for compiling under mingw-w64
+- Better support for handing SIGPIPE on Linux over SSL (#401)
+- Improve publish performance on Linux by not specifying MSG_MORE on last part
+ of message.
+- Fix connection logic where multiple hostnames won't be tried if connection to
+ doesn't fail immediately (#430)
+
+### Removed:
+- autotools build system has been removed
+- many duplicate amqps_* examples, they did not add a lot of value
+
+
## v0.8.0 - 2016-04-09
### Added:
- SSL: peer certificate and hostname validation can now be controlled separately
diff --git a/librabbitmq/amqp.h b/librabbitmq/amqp.h
index 36b9901..734abb8 100644
--- a/librabbitmq/amqp.h
+++ b/librabbitmq/amqp.h
@@ -219,9 +219,9 @@ AMQP_BEGIN_DECLS
*/
#define AMQP_VERSION_MAJOR 0
-#define AMQP_VERSION_MINOR 8
-#define AMQP_VERSION_PATCH 1
-#define AMQP_VERSION_IS_RELEASE 0
+#define AMQP_VERSION_MINOR 9
+#define AMQP_VERSION_PATCH 0
+#define AMQP_VERSION_IS_RELEASE 1
/**
* \def AMQP_VERSION_CODE