summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--CMakeLists.txt1
-rw-r--r--Makefile.am1
-rw-r--r--cmake/FindPOPT.cmake1
-rw-r--r--cmake/FindXmlTo.cmake1
-rw-r--r--cmake/InstallMacros.cmake1
-rw-r--r--cmake/TestCInline.cmake1
-rw-r--r--cmake/config.h.in1
-rw-r--r--configure.ac1
-rw-r--r--examples/CMakeLists.txt1
-rw-r--r--examples/amqp_bind.c1
-rw-r--r--examples/amqp_consumer.c1
-rw-r--r--examples/amqp_exchange_declare.c1
-rw-r--r--examples/amqp_listen.c1
-rw-r--r--examples/amqp_listenq.c1
-rw-r--r--examples/amqp_producer.c1
-rw-r--r--examples/amqp_rpc_sendstring_client.c1
-rw-r--r--examples/amqp_sendstring.c1
-rw-r--r--examples/amqp_unbind.c1
-rw-r--r--examples/unix/platform_utils.c1
-rw-r--r--examples/utils.c1
-rw-r--r--examples/utils.h1
-rw-r--r--examples/win32/platform_utils.c1
-rw-r--r--librabbitmq/CMakeLists.txt1
-rw-r--r--librabbitmq/amqp.h1
-rw-r--r--librabbitmq/amqp_api.c1
-rw-r--r--librabbitmq/amqp_connection.c1
-rw-r--r--librabbitmq/amqp_mem.c1
-rw-r--r--librabbitmq/amqp_private.h1
-rw-r--r--librabbitmq/amqp_socket.c3
-rw-r--r--librabbitmq/amqp_table.c1
-rw-r--r--librabbitmq/amqp_url.c1
-rw-r--r--librabbitmq/codegen.py1
-rw-r--r--librabbitmq/unix/socket.c1
-rw-r--r--librabbitmq/unix/socket.h1
-rw-r--r--librabbitmq/win32/socket.c1
-rw-r--r--librabbitmq/win32/socket.h1
-rw-r--r--tests/CMakeLists.txt1
-rw-r--r--tests/test_parse_url.c1
-rw-r--r--tests/test_tables.c1
-rw-r--r--tools/CMakeLists.txt1
-rw-r--r--tools/common.c1
-rw-r--r--tools/common.h1
-rw-r--r--tools/consume.c1
-rw-r--r--tools/declare_queue.c1
-rw-r--r--tools/delete_queue.c1
-rw-r--r--tools/get.c1
-rw-r--r--tools/publish.c1
-rw-r--r--tools/unix/process.c1
-rw-r--r--tools/unix/process.h1
-rw-r--r--tools/win32/compat.c1
-rw-r--r--tools/win32/compat.h1
-rw-r--r--tools/win32/process.c1
-rw-r--r--tools/win32/process.h1
53 files changed, 54 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e0bd31f..55d56e1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,3 +1,4 @@
+# vim:set ts=2 sw=2 sts=2 et:
cmake_minimum_required(VERSION 2.6)
project(rabbitmq-c "C")
diff --git a/Makefile.am b/Makefile.am
index 8ed01f9..d7bbe67 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,3 +1,4 @@
+# vim:set ts=2 sw=2 sts=2 noet:
ACLOCAL_AMFLAGS = -I m4
if REGENERATE_AMQP_FRAMING
diff --git a/cmake/FindPOPT.cmake b/cmake/FindPOPT.cmake
index ac11358..de29c7e 100644
--- a/cmake/FindPOPT.cmake
+++ b/cmake/FindPOPT.cmake
@@ -1,3 +1,4 @@
+# vim:set ts=2 sw=2 sts=2 et:
# - Try to find the popt options processing library
# The module will set the following variables
#
diff --git a/cmake/FindXmlTo.cmake b/cmake/FindXmlTo.cmake
index d2d4d63..8082078 100644
--- a/cmake/FindXmlTo.cmake
+++ b/cmake/FindXmlTo.cmake
@@ -1,3 +1,4 @@
+# vim:set ts=2 sw=2 sts=2 et:
# - Convert XML docBook files to various formats
# This will convert XML docBook files to various formats like:
# man html txt dvi ps pdf
diff --git a/cmake/InstallMacros.cmake b/cmake/InstallMacros.cmake
index 30cc47a..53e211e 100644
--- a/cmake/InstallMacros.cmake
+++ b/cmake/InstallMacros.cmake
@@ -1,3 +1,4 @@
+# vim:set ts=2 sw=2 sts=2 et:
#
# This module install PDB files.
#
diff --git a/cmake/TestCInline.cmake b/cmake/TestCInline.cmake
index 6343646..e42a822 100644
--- a/cmake/TestCInline.cmake
+++ b/cmake/TestCInline.cmake
@@ -1,3 +1,4 @@
+# vim:set ts=2 sw=2 sts=2 et:
#Inspired from http://www.cmake.org/Wiki/CMakeTestInline
IF(NOT DEFINED C_INLINE_KEYWORD)
diff --git a/cmake/config.h.in b/cmake/config.h.in
index 35c83ac..9535d66 100644
--- a/cmake/config.h.in
+++ b/cmake/config.h.in
@@ -1,3 +1,4 @@
+/* vim:set ft=c ts=2 sw=2 sts=2 et cindent: */
#ifndef CONFIG_H
#define CONFIG_H
diff --git a/configure.ac b/configure.ac
index 5577275..5bafa6d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,3 +1,4 @@
+# vim:set ts=2 sw=2 sts=2 et:
AC_PREREQ([2.59])
m4_define([major_version], [0])
diff --git a/examples/CMakeLists.txt b/examples/CMakeLists.txt
index b0b453d..5a610cb 100644
--- a/examples/CMakeLists.txt
+++ b/examples/CMakeLists.txt
@@ -1,3 +1,4 @@
+# vim:set ts=2 sw=2 sts=2 et:
include_directories(${LIBRABBITMQ_INCLUDE_DIRS})
if (WIN32)
diff --git a/examples/amqp_bind.c b/examples/amqp_bind.c
index b689617..7864871 100644
--- a/examples/amqp_bind.c
+++ b/examples/amqp_bind.c
@@ -1,3 +1,4 @@
+/* vim:set ft=c ts=2 sw=2 sts=2 et cindent: */
/*
* ***** BEGIN LICENSE BLOCK *****
* Version: MIT
diff --git a/examples/amqp_consumer.c b/examples/amqp_consumer.c
index 4fb4a8f..c1c0873 100644
--- a/examples/amqp_consumer.c
+++ b/examples/amqp_consumer.c
@@ -1,3 +1,4 @@
+/* vim:set ft=c ts=2 sw=2 sts=2 et cindent: */
/*
* ***** BEGIN LICENSE BLOCK *****
* Version: MIT
diff --git a/examples/amqp_exchange_declare.c b/examples/amqp_exchange_declare.c
index 19dc1f9..74f7465 100644
--- a/examples/amqp_exchange_declare.c
+++ b/examples/amqp_exchange_declare.c
@@ -1,3 +1,4 @@
+/* vim:set ft=c ts=2 sw=2 sts=2 et cindent: */
/*
* ***** BEGIN LICENSE BLOCK *****
* Version: MIT
diff --git a/examples/amqp_listen.c b/examples/amqp_listen.c
index ea44973..a589fa5 100644
--- a/examples/amqp_listen.c
+++ b/examples/amqp_listen.c
@@ -1,3 +1,4 @@
+/* vim:set ft=c ts=2 sw=2 sts=2 et cindent: */
/*
* ***** BEGIN LICENSE BLOCK *****
* Version: MIT
diff --git a/examples/amqp_listenq.c b/examples/amqp_listenq.c
index f050087..8af0f08 100644
--- a/examples/amqp_listenq.c
+++ b/examples/amqp_listenq.c
@@ -1,3 +1,4 @@
+/* vim:set ft=c ts=2 sw=2 sts=2 et cindent: */
/*
* ***** BEGIN LICENSE BLOCK *****
* Version: MIT
diff --git a/examples/amqp_producer.c b/examples/amqp_producer.c
index 22ac6fa..d85b944 100644
--- a/examples/amqp_producer.c
+++ b/examples/amqp_producer.c
@@ -1,3 +1,4 @@
+/* vim:set ft=c ts=2 sw=2 sts=2 et cindent: */
/*
* ***** BEGIN LICENSE BLOCK *****
* Version: MIT
diff --git a/examples/amqp_rpc_sendstring_client.c b/examples/amqp_rpc_sendstring_client.c
index b2dcde6..04c073e 100644
--- a/examples/amqp_rpc_sendstring_client.c
+++ b/examples/amqp_rpc_sendstring_client.c
@@ -1,3 +1,4 @@
+/* vim:set ft=c ts=2 sw=2 sts=2 et cindent: */
/*
* ***** BEGIN LICENSE BLOCK *****
* Version: MIT
diff --git a/examples/amqp_sendstring.c b/examples/amqp_sendstring.c
index ea30d95..e108ea7 100644
--- a/examples/amqp_sendstring.c
+++ b/examples/amqp_sendstring.c
@@ -1,3 +1,4 @@
+/* vim:set ft=c ts=2 sw=2 sts=2 et cindent: */
/*
* ***** BEGIN LICENSE BLOCK *****
* Version: MIT
diff --git a/examples/amqp_unbind.c b/examples/amqp_unbind.c
index c26031c..546b356 100644
--- a/examples/amqp_unbind.c
+++ b/examples/amqp_unbind.c
@@ -1,3 +1,4 @@
+/* vim:set ft=c ts=2 sw=2 sts=2 et cindent: */
/*
* ***** BEGIN LICENSE BLOCK *****
* Version: MIT
diff --git a/examples/unix/platform_utils.c b/examples/unix/platform_utils.c
index 8593448..6e356cb 100644
--- a/examples/unix/platform_utils.c
+++ b/examples/unix/platform_utils.c
@@ -1,3 +1,4 @@
+/* vim:set ft=c ts=2 sw=2 sts=2 et cindent: */
/*
* ***** BEGIN LICENSE BLOCK *****
* Version: MIT
diff --git a/examples/utils.c b/examples/utils.c
index b047c8d..691f14a 100644
--- a/examples/utils.c
+++ b/examples/utils.c
@@ -1,3 +1,4 @@
+/* vim:set ft=c ts=2 sw=2 sts=2 et cindent: */
/*
* ***** BEGIN LICENSE BLOCK *****
* Version: MIT
diff --git a/examples/utils.h b/examples/utils.h
index 61a0270..f1d40b3 100644
--- a/examples/utils.h
+++ b/examples/utils.h
@@ -1,3 +1,4 @@
+/* vim:set ft=c ts=2 sw=2 sts=2 et cindent: */
#ifndef librabbitmq_examples_utils_h
#define librabbitmq_examples_utils_h
diff --git a/examples/win32/platform_utils.c b/examples/win32/platform_utils.c
index ee97238..c7807f9 100644
--- a/examples/win32/platform_utils.c
+++ b/examples/win32/platform_utils.c
@@ -1,3 +1,4 @@
+/* vim:set ft=c ts=2 sw=2 sts=2 et cindent: */
/*
* ***** BEGIN LICENSE BLOCK *****
* Version: MIT
diff --git a/librabbitmq/CMakeLists.txt b/librabbitmq/CMakeLists.txt
index 345d772..a9996cf 100644
--- a/librabbitmq/CMakeLists.txt
+++ b/librabbitmq/CMakeLists.txt
@@ -1,3 +1,4 @@
+# vim:set ts=2 sw=2 sts=2 et:
project(librabbitmq "C")
if (REGENERATE_AMQP_FRAMING)
diff --git a/librabbitmq/amqp.h b/librabbitmq/amqp.h
index c8d0127..5de39d5 100644
--- a/librabbitmq/amqp.h
+++ b/librabbitmq/amqp.h
@@ -1,3 +1,4 @@
+/* vim:set ft=c ts=2 sw=2 sts=2 et cindent: */
/*
* ***** BEGIN LICENSE BLOCK *****
* Version: MIT
diff --git a/librabbitmq/amqp_api.c b/librabbitmq/amqp_api.c
index f011354..6faabbb 100644
--- a/librabbitmq/amqp_api.c
+++ b/librabbitmq/amqp_api.c
@@ -1,3 +1,4 @@
+/* vim:set ft=c ts=2 sw=2 sts=2 et cindent: */
/*
* ***** BEGIN LICENSE BLOCK *****
* Version: MIT
diff --git a/librabbitmq/amqp_connection.c b/librabbitmq/amqp_connection.c
index 4639b68..421c745 100644
--- a/librabbitmq/amqp_connection.c
+++ b/librabbitmq/amqp_connection.c
@@ -1,3 +1,4 @@
+/* vim:set ft=c ts=2 sw=2 sts=2 et cindent: */
/*
* ***** BEGIN LICENSE BLOCK *****
* Version: MIT
diff --git a/librabbitmq/amqp_mem.c b/librabbitmq/amqp_mem.c
index d1cf2ad..6915763 100644
--- a/librabbitmq/amqp_mem.c
+++ b/librabbitmq/amqp_mem.c
@@ -1,3 +1,4 @@
+/* vim:set ft=c ts=2 sw=2 sts=2 et cindent: */
/*
* ***** BEGIN LICENSE BLOCK *****
* Version: MIT
diff --git a/librabbitmq/amqp_private.h b/librabbitmq/amqp_private.h
index fb01d12..725e3c5 100644
--- a/librabbitmq/amqp_private.h
+++ b/librabbitmq/amqp_private.h
@@ -1,3 +1,4 @@
+/* vim:set ft=c ts=2 sw=2 sts=2 et cindent: */
#ifndef librabbitmq_amqp_private_h
#define librabbitmq_amqp_private_h
diff --git a/librabbitmq/amqp_socket.c b/librabbitmq/amqp_socket.c
index 4391947..c323792 100644
--- a/librabbitmq/amqp_socket.c
+++ b/librabbitmq/amqp_socket.c
@@ -1,3 +1,4 @@
+/* vim:set ft=c ts=2 sw=2 sts=2 et cindent: */
/*
* ***** BEGIN LICENSE BLOCK *****
* Version: MIT
@@ -109,7 +110,7 @@ int amqp_open_socket(char const *hostname,
{
return last_error;
}
-
+
return sockfd;
}
diff --git a/librabbitmq/amqp_table.c b/librabbitmq/amqp_table.c
index 4e0de12..d82c946 100644
--- a/librabbitmq/amqp_table.c
+++ b/librabbitmq/amqp_table.c
@@ -1,3 +1,4 @@
+/* vim:set ft=c ts=2 sw=2 sts=2 et cindent: */
/*
* ***** BEGIN LICENSE BLOCK *****
* Version: MIT
diff --git a/librabbitmq/amqp_url.c b/librabbitmq/amqp_url.c
index eb29ca8..367376d 100644
--- a/librabbitmq/amqp_url.c
+++ b/librabbitmq/amqp_url.c
@@ -1,3 +1,4 @@
+/* vim:set ft=c ts=2 sw=2 sts=2 et cindent: */
/*
* ***** BEGIN LICENSE BLOCK *****
* Version: MIT
diff --git a/librabbitmq/codegen.py b/librabbitmq/codegen.py
index 1a2928d..5ae5a8f 100644
--- a/librabbitmq/codegen.py
+++ b/librabbitmq/codegen.py
@@ -1,3 +1,4 @@
+# vim:set ts=2 sw=2 sts=2 et
# ***** BEGIN LICENSE BLOCK *****
# Version: MIT
#
diff --git a/librabbitmq/unix/socket.c b/librabbitmq/unix/socket.c
index 5e5ba91..69bb036 100644
--- a/librabbitmq/unix/socket.c
+++ b/librabbitmq/unix/socket.c
@@ -1,3 +1,4 @@
+/* vim:set ft=c ts=2 sw=2 sts=2 et cindent: */
/*
* ***** BEGIN LICENSE BLOCK *****
* Version: MIT
diff --git a/librabbitmq/unix/socket.h b/librabbitmq/unix/socket.h
index 4d92d68..dd69e7b 100644
--- a/librabbitmq/unix/socket.h
+++ b/librabbitmq/unix/socket.h
@@ -1,3 +1,4 @@
+/* vim:set ft=c ts=2 sw=2 sts=2 et cindent: */
#ifndef librabbitmq_unix_socket_h
#define librabbitmq_unix_socket_h
diff --git a/librabbitmq/win32/socket.c b/librabbitmq/win32/socket.c
index c0089a3..9919b6b 100644
--- a/librabbitmq/win32/socket.c
+++ b/librabbitmq/win32/socket.c
@@ -1,3 +1,4 @@
+/* vim:set ft=c ts=2 sw=2 sts=2 et cindent: */
/*
* ***** BEGIN LICENSE BLOCK *****
* Version: MIT
diff --git a/librabbitmq/win32/socket.h b/librabbitmq/win32/socket.h
index bfd717c..9351b1f 100644
--- a/librabbitmq/win32/socket.h
+++ b/librabbitmq/win32/socket.h
@@ -1,3 +1,4 @@
+/* vim:set ft=c ts=2 sw=2 sts=2 et cindent: */
#ifndef librabbitmq_windows_socket_h
#define librabbitmq_windows_socket_h
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 4b54003..7ebf545 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -1,3 +1,4 @@
+# vim:set ts=2 sw=2 sts=2 et:
include_directories(${LIBRABBITMQ_INCLUDE_DIRS})
if (MSVC)
diff --git a/tests/test_parse_url.c b/tests/test_parse_url.c
index a4c5f09..2e7d1c7 100644
--- a/tests/test_parse_url.c
+++ b/tests/test_parse_url.c
@@ -1,3 +1,4 @@
+/* vim:set ft=c ts=2 sw=2 sts=2 et cindent: */
/*
* ***** BEGIN LICENSE BLOCK *****
* Version: MIT
diff --git a/tests/test_tables.c b/tests/test_tables.c
index 659db53..404a6d8 100644
--- a/tests/test_tables.c
+++ b/tests/test_tables.c
@@ -1,3 +1,4 @@
+/* vim:set ft=c ts=2 sw=2 sts=2 et cindent: */
/*
* ***** BEGIN LICENSE BLOCK *****
* Version: MIT
diff --git a/tools/CMakeLists.txt b/tools/CMakeLists.txt
index 739f0ec..9b352fb 100644
--- a/tools/CMakeLists.txt
+++ b/tools/CMakeLists.txt
@@ -1,3 +1,4 @@
+# vim:set ts=2 sw=2 sts=2 et:
include_directories(${CMAKE_CURRENT_SOURCE_DIR} ${LIBRABBITMQ_INCLUDE_DIRS} ${POPT_INCLUDE_DIRS})
if (WIN32)
diff --git a/tools/common.c b/tools/common.c
index 70f3bca..c5b2a77 100644
--- a/tools/common.c
+++ b/tools/common.c
@@ -1,3 +1,4 @@
+/* vim:set ft=c ts=2 sw=2 sts=2 et cindent: */
/*
* ***** BEGIN LICENSE BLOCK *****
* Version: MIT
diff --git a/tools/common.h b/tools/common.h
index c88c6bc..0a9af9d 100644
--- a/tools/common.h
+++ b/tools/common.h
@@ -1,3 +1,4 @@
+/* vim:set ft=c ts=2 sw=2 sts=2 et cindent: */
/*
* ***** BEGIN LICENSE BLOCK *****
* Version: MIT
diff --git a/tools/consume.c b/tools/consume.c
index 4f79889..d6ddfa8 100644
--- a/tools/consume.c
+++ b/tools/consume.c
@@ -1,3 +1,4 @@
+/* vim:set ft=c ts=2 sw=2 sts=2 et cindent: */
/*
* ***** BEGIN LICENSE BLOCK *****
* Version: MIT
diff --git a/tools/declare_queue.c b/tools/declare_queue.c
index fc9524c..26c3a68 100644
--- a/tools/declare_queue.c
+++ b/tools/declare_queue.c
@@ -1,3 +1,4 @@
+/* vim:set ft=c ts=2 sw=2 sts=2 et cindent: */
/*
* ***** BEGIN LICENSE BLOCK *****
* Version: MIT
diff --git a/tools/delete_queue.c b/tools/delete_queue.c
index 4577d74..cb92f7b 100644
--- a/tools/delete_queue.c
+++ b/tools/delete_queue.c
@@ -1,3 +1,4 @@
+/* vim:set ft=c ts=2 sw=2 sts=2 et cindent: */
/*
* ***** BEGIN LICENSE BLOCK *****
* Version: MIT
diff --git a/tools/get.c b/tools/get.c
index 3e536c7..888e069 100644
--- a/tools/get.c
+++ b/tools/get.c
@@ -1,3 +1,4 @@
+/* vim:set ft=c ts=2 sw=2 sts=2 et cindent: */
/*
* ***** BEGIN LICENSE BLOCK *****
* Version: MIT
diff --git a/tools/publish.c b/tools/publish.c
index f7e7e77..5ebc191 100644
--- a/tools/publish.c
+++ b/tools/publish.c
@@ -1,3 +1,4 @@
+/* vim:set ft=c ts=2 sw=2 sts=2 et cindent: */
/*
* ***** BEGIN LICENSE BLOCK *****
* Version: MIT
diff --git a/tools/unix/process.c b/tools/unix/process.c
index 624f016..a714928 100644
--- a/tools/unix/process.c
+++ b/tools/unix/process.c
@@ -1,3 +1,4 @@
+/* vim:set ft=c ts=2 sw=2 sts=2 et cindent: */
/*
* ***** BEGIN LICENSE BLOCK *****
* Version: MIT
diff --git a/tools/unix/process.h b/tools/unix/process.h
index 6b6d93d..0aad292 100644
--- a/tools/unix/process.h
+++ b/tools/unix/process.h
@@ -1,3 +1,4 @@
+/* vim:set ft=c ts=2 sw=2 sts=2 et cindent: */
/*
* ***** BEGIN LICENSE BLOCK *****
* Version: MIT
diff --git a/tools/win32/compat.c b/tools/win32/compat.c
index 07afa9a..cbac8e6 100644
--- a/tools/win32/compat.c
+++ b/tools/win32/compat.c
@@ -1,3 +1,4 @@
+/* vim:set ft=c ts=2 sw=2 sts=2 et cindent: */
/*
* ***** BEGIN LICENSE BLOCK *****
* Version: MIT
diff --git a/tools/win32/compat.h b/tools/win32/compat.h
index 9b9c96a..74cacbe 100644
--- a/tools/win32/compat.h
+++ b/tools/win32/compat.h
@@ -1,3 +1,4 @@
+/* vim:set ft=c ts=2 sw=2 sts=2 et cindent: */
/*
* ***** BEGIN LICENSE BLOCK *****
* Version: MIT
diff --git a/tools/win32/process.c b/tools/win32/process.c
index 8bc9337..699f60f 100644
--- a/tools/win32/process.c
+++ b/tools/win32/process.c
@@ -1,3 +1,4 @@
+/* vim:set ft=c ts=2 sw=2 sts=2 et cindent: */
/*
* ***** BEGIN LICENSE BLOCK *****
* Version: MIT
diff --git a/tools/win32/process.h b/tools/win32/process.h
index c2a8a0d..1429ad2 100644
--- a/tools/win32/process.h
+++ b/tools/win32/process.h
@@ -1,3 +1,4 @@
+/* vim:set ft=c ts=2 sw=2 sts=2 et cindent: */
/*
* ***** BEGIN LICENSE BLOCK *****
* Version: MIT