summaryrefslogtreecommitdiff
path: root/docs/0.8.0/index.html
diff options
context:
space:
mode:
Diffstat (limited to 'docs/0.8.0/index.html')
-rw-r--r--docs/0.8.0/index.html166
1 files changed, 166 insertions, 0 deletions
diff --git a/docs/0.8.0/index.html b/docs/0.8.0/index.html
new file mode 100644
index 0000000..209d77f
--- /dev/null
+++ b/docs/0.8.0/index.html
@@ -0,0 +1,166 @@
+<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
+<html xmlns="http://www.w3.org/1999/xhtml">
+<head>
+<meta http-equiv="Content-Type" content="text/xhtml;charset=UTF-8"/>
+<meta http-equiv="X-UA-Compatible" content="IE=9"/>
+<meta name="generator" content="Doxygen 1.8.6"/>
+<title>rabbitmq-c: Main Page</title>
+<link href="tabs.css" rel="stylesheet" type="text/css"/>
+<script type="text/javascript" src="jquery.js"></script>
+<script type="text/javascript" src="dynsections.js"></script>
+<link href="search/search.css" rel="stylesheet" type="text/css"/>
+<script type="text/javascript" src="search/search.js"></script>
+<script type="text/javascript">
+ $(document).ready(function() { searchBox.OnSelectItem(0); });
+</script>
+<link href="doxygen.css" rel="stylesheet" type="text/css" />
+</head>
+<body>
+<div id="top"><!-- do not remove this div, it is closed by doxygen! -->
+<div id="titlearea">
+<table cellspacing="0" cellpadding="0">
+ <tbody>
+ <tr style="height: 56px;">
+ <td style="padding-left: 0.5em;">
+ <div id="projectname">rabbitmq-c
+ &#160;<span id="projectnumber">0.8.0</span>
+ </div>
+ <div id="projectbrief">C AMQP Client library for RabbitMQ</div>
+ </td>
+ </tr>
+ </tbody>
+</table>
+</div>
+<!-- end header part -->
+<!-- Generated by Doxygen 1.8.6 -->
+<script type="text/javascript">
+var searchBox = new SearchBox("searchBox", "search",false,'Search');
+</script>
+ <div id="navrow1" class="tabs">
+ <ul class="tablist">
+ <li class="current"><a href="index.html"><span>Main&#160;Page</span></a></li>
+ <li><a href="pages.html"><span>Related&#160;Pages</span></a></li>
+ <li><a href="annotated.html"><span>Data&#160;Structures</span></a></li>
+ <li><a href="files.html"><span>Files</span></a></li>
+ <li>
+ <div id="MSearchBox" class="MSearchBoxInactive">
+ <span class="left">
+ <img id="MSearchSelect" src="search/mag_sel.png"
+ onmouseover="return searchBox.OnSearchSelectShow()"
+ onmouseout="return searchBox.OnSearchSelectHide()"
+ alt=""/>
+ <input type="text" id="MSearchField" value="Search" accesskey="S"
+ onfocus="searchBox.OnSearchFieldFocus(true)"
+ onblur="searchBox.OnSearchFieldFocus(false)"
+ onkeyup="searchBox.OnSearchFieldChange(event)"/>
+ </span><span class="right">
+ <a id="MSearchClose" href="javascript:searchBox.CloseResultsWindow()"><img id="MSearchCloseImg" border="0" src="search/close.png" alt=""/></a>
+ </span>
+ </div>
+ </li>
+ </ul>
+ </div>
+</div><!-- top -->
+<!-- window showing the filter options -->
+<div id="MSearchSelectWindow"
+ onmouseover="return searchBox.OnSearchSelectShow()"
+ onmouseout="return searchBox.OnSearchSelectHide()"
+ onkeydown="return searchBox.OnSearchSelectKey(event)">
+<a class="SelectItem" href="javascript:void(0)" onclick="searchBox.OnSelectItem(0)"><span class="SelectionMark">&#160;</span>All</a><a class="SelectItem" href="javascript:void(0)" onclick="searchBox.OnSelectItem(1)"><span class="SelectionMark">&#160;</span>Data Structures</a><a class="SelectItem" href="javascript:void(0)" onclick="searchBox.OnSelectItem(2)"><span class="SelectionMark">&#160;</span>Files</a><a class="SelectItem" href="javascript:void(0)" onclick="searchBox.OnSelectItem(3)"><span class="SelectionMark">&#160;</span>Functions</a><a class="SelectItem" href="javascript:void(0)" onclick="searchBox.OnSelectItem(4)"><span class="SelectionMark">&#160;</span>Variables</a><a class="SelectItem" href="javascript:void(0)" onclick="searchBox.OnSelectItem(5)"><span class="SelectionMark">&#160;</span>Typedefs</a><a class="SelectItem" href="javascript:void(0)" onclick="searchBox.OnSelectItem(6)"><span class="SelectionMark">&#160;</span>Enumerations</a><a class="SelectItem" href="javascript:void(0)" onclick="searchBox.OnSelectItem(7)"><span class="SelectionMark">&#160;</span>Enumerator</a><a class="SelectItem" href="javascript:void(0)" onclick="searchBox.OnSelectItem(8)"><span class="SelectionMark">&#160;</span>Macros</a><a class="SelectItem" href="javascript:void(0)" onclick="searchBox.OnSelectItem(9)"><span class="SelectionMark">&#160;</span>Pages</a></div>
+
+<!-- iframe showing the search results (closed by default) -->
+<div id="MSearchResultsWindow">
+<iframe src="javascript:void(0)" frameborder="0"
+ name="MSearchResults" id="MSearchResults">
+</iframe>
+</div>
+
+<div class="header">
+ <div class="headertitle">
+<div class="title">rabbitmq-c Documentation</div> </div>
+</div><!--header-->
+<div class="contents">
+<div class="textblock"><p><a href="http://travis-ci.org/alanxz/rabbitmq-c">![Build Status](https://secure.travis-ci.org/alanxz/rabbitmq-c.png?branch=master)</a></p>
+<h2>Introduction</h2>
+<p>This is a C-language AMQP client library for use with v2.0+ of the <a href="http://www.rabbitmq.com/">RabbitMQ</a> broker.</p>
+<ul>
+<li><a href="http://github.com/alanxz/rabbitmq-c">http://github.com/alanxz/rabbitmq-c</a></li>
+</ul>
+<p>Announcements regarding the library are periodically made on the rabbitmq-users mailing list:</p>
+<ul>
+<li><a href="https://groups.google.com/forum/#!forum/rabbitmq-users">https://groups.google.com/forum/#!forum/rabbitmq-users</a></li>
+</ul>
+<h2>Latest Stable Version</h2>
+<p>The latest stable release of rabbitmq-c can be found at:</p>
+<ul>
+<li><a href="https://github.com/alanxz/rabbitmq-c/releases/latest">https://github.com/alanxz/rabbitmq-c/releases/latest</a></li>
+</ul>
+<h2>Documentation</h2>
+<p>API documentation for v0.5.0+ can viewed from:</p>
+<p><a href="http://alanxz.github.io/rabbitmq-c/docs/0.5.0/">http://alanxz.github.io/rabbitmq-c/docs/0.5.0/</a></p>
+<h2>Getting started</h2>
+<h3>Building and installing</h3>
+<h4>Prereqs:</h4>
+<ul>
+<li><a href="http://www.cmake.org/">CMake v2.6 or better</a></li>
+<li>A C compiler (GCC 4.4+, clang, and MSVC are test. Other compilers may also work)</li>
+<li><em>Optionally</em> <a href="http://www.openssl.org/">OpenSSL</a> v0.9.8+ to enable support for connecting to RabbitMQ over SSL/TLS</li>
+<li><em>Optionally</em> <a href="http://freecode.com/projects/popt">POpt</a> to build some handy command-line tools.</li>
+<li><em>Optionally</em> <a href="https://fedorahosted.org/xmlto/">XmlTo</a> to build man pages for the handy command-line tools</li>
+<li><em>Optionally</em> <a href="http://www.stack.nl/~dimitri/doxygen/">Doxygen</a> to build developer API documentation.</li>
+</ul>
+<p>After downloading and extracting the source from a tarball to a directory. ([see above][Latest Stable Version]), the commands to build rabbitmq-c on most systems are: </p>
+<pre class="fragment">mkdir build &amp;&amp; cd build
+cmake ..
+cmake --build [--config Release] .
+</pre><p>The &ndash;config Release flag should be used in multi-configuration generators e.g., Visual Studio or XCode.</p>
+<p>It is also possible to point the CMake GUI tool at the CMakeLists.txt in the root of the source tree and generate build projects or IDE workspace</p>
+<p>Installing the library and optionally specifying a prefix can be done with: </p>
+<pre class="fragment">cmake -DCMAKE_INSTALL_PREFIX=/usr/local ..
+cmake --build . [--config Release] --target install
+</pre><p>More information on CMake can be found on its FAQ (<a href="http://www.cmake.org/Wiki/CMake_FAQ">http://www.cmake.org/Wiki/CMake_FAQ</a>)</p>
+<p>Other interesting flags that can be passed to CMake:</p>
+<ul>
+<li><code>BUILD_EXAMPLES=ON/OFF</code> toggles building the examples. ON by default.</li>
+<li><code>BUILD_SHARED_LIBS=ON/OFF</code> toggles building rabbitmq-c as a shared library. ON by default.</li>
+<li><code>BUILD_STATIC_LIBS=ON/OFF</code> toggles building rabbitmq-c as a static library. OFF by default.</li>
+<li><code>BUILD_TESTS=ON/OFF</code> toggles building test code. ON by default.</li>
+<li><code>BUILD_TOOLS=ON/OFF</code> toggles building the command line tools. By default this is ON if the build system can find the POpt header and library.</li>
+<li><code>BUILD_TOOLS_DOCS=ON/OFF</code> toggles building the man pages for the command line tools. By default this is ON if BUILD_TOOLS is ON and the build system can find the XmlTo utility.</li>
+<li><code>ENABLE_SSL_SUPPORT=ON/OFF</code> toggles building rabbitmq-c with SSL support. By default this is ON if the OpenSSL headers and library can be found.</li>
+<li><code>ENABLE_THREAD_SAFETY=ON/OFF</code> toggles OpenSSL thread-safety. By default this is ON</li>
+<li><code>BUILD_API_DOCS=ON/OFF</code> - toggles building the Doxygen API documentation, by default this is OFF</li>
+</ul>
+<h4>autotools</h4>
+<p>For legacy purposes, a GNU autotools based build system is also maintained. The required utilities you need are autoconf v2.59+, automake v1.9+, libtool v2.2+, and pkg-config.</p>
+<p>Then the standard autotools build procedure will build rabbitmq-c: </p>
+<pre class="fragment">autoreconf -i
+./configure
+make
+make install
+</pre><h2>Running the examples</h2>
+<p>Arrange for a RabbitMQ or other AMQP server to be running on <code>localhost</code> at TCP port number 5672.</p>
+<p>In one terminal, run </p>
+<pre class="fragment">./examples/amqp_listen localhost 5672 amq.direct test
+</pre><p>In another terminal, </p>
+<pre class="fragment">./examples/amqp_sendstring localhost 5672 amq.direct test "hello world"
+</pre><p>You should see output similar to the following in the listener's terminal window: </p>
+<pre class="fragment">Delivery 1, exchange amq.direct routingkey test
+Content-type: text/plain
+----
+00000000: 68 65 6C 6C 6F 20 77 6F : 72 6C 64 hello world
+0000000B:
+</pre><h2>Writing applications using <code>librabbitmq</code></h2>
+<p>Please see the <code>examples</code> directory for short examples of the use of the <code>librabbitmq</code> library.</p>
+<h3>Threading</h3>
+<p>You cannot share a socket, an <code>amqp_connection_state_t</code>, or a channel between threads using <code>librabbitmq</code>. The <code>librabbitmq</code> library is built with event-driven, single-threaded applications in mind, and does not yet cater to any of the requirements of <code>pthread</code>ed applications.</p>
+<p>Your applications instead should open an AMQP connection (and an associated socket, of course) per thread. If your program needs to access an AMQP connection or any of its channels from more than one thread, it is entirely responsible for designing and implementing an appropriate locking scheme. It will generally be much simpler to have a connection exclusive to each thread that needs AMQP service. </p>
+</div></div><!-- contents -->
+<!-- start footer part -->
+<hr class="footer"/><address class="footer"><small>
+Generated on Sat Apr 9 2016 21:59:28 for rabbitmq-c by &#160;<a href="http://www.doxygen.org/index.html">
+<img class="footer" src="doxygen.png" alt="doxygen"/>
+</a> 1.8.6
+</small></address>
+</body>
+</html>