summaryrefslogtreecommitdiff
path: root/examples/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/CMakeLists.txt')
-rw-r--r--examples/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/examples/CMakeLists.txt b/examples/CMakeLists.txt
index f49bc7a..4ea8e93 100644
--- a/examples/CMakeLists.txt
+++ b/examples/CMakeLists.txt
@@ -1,3 +1,7 @@
+if (NOT BUILD_SHARED_LIBS)
+ add_definitions(-DAMQP_STATIC)
+endif()
+
include_directories(${LIBRABBITMQ_INCLUDE_DIRS})
if (WIN32)