summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Unterwaditzer <markus@unterwaditzer.net>2019-05-29 17:12:14 +0200
committerMarkus Unterwaditzer <markus@unterwaditzer.net>2019-05-29 17:12:14 +0200
commit1765c7a9f2b3ebe440dfa64c79dd04931798999d (patch)
treed61836b033a4d8f349064a878dab213de8fbde66
parent2043b1e93fadfb053e05c48280adb20237d9ca12 (diff)
parentd173bb5894a0e940aacf922ba71f67d89eb9084a (diff)
downloadraven-fix/encoding-exc.tar.gz
Merge remote-tracking branch 'origin/master' into fix/encoding-excfix/encoding-exc
-rw-r--r--.travis.yml4
-rw-r--r--raven/__init__.py2
-rw-r--r--tests/contrib/flask/tests.py4
-rw-r--r--tox.ini5
4 files changed, 4 insertions, 11 deletions
diff --git a/.travis.yml b/.travis.yml
index b50b3df..4c6a646 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -10,10 +10,10 @@ matrix:
include:
- python: "3.7"
dist: xenial
- sudo: true
- name: Flake8
- python: "3.6"
+ dist: xenial
+ python: "3.7"
install:
- pip install tox
script: tox -e flake8
diff --git a/raven/__init__.py b/raven/__init__.py
index 9a62064..d6d9347 100644
--- a/raven/__init__.py
+++ b/raven/__init__.py
@@ -10,7 +10,7 @@ from __future__ import absolute_import
import os
import os.path
-__all__ = ('VERSION', 'Client', 'get_version')
+__all__ = ('VERSION', 'Client', 'get_version') # noqa
VERSION = '6.10.0'
diff --git a/tests/contrib/flask/tests.py b/tests/contrib/flask/tests.py
index 593876c..e7a46f2 100644
--- a/tests/contrib/flask/tests.py
+++ b/tests/contrib/flask/tests.py
@@ -148,10 +148,6 @@ class FlaskTest(BaseTest):
self.assertEquals(http['data'], {})
self.assertTrue('headers' in http)
headers = http['headers']
- self.assertTrue('Content-Length' in headers, headers.keys())
- self.assertEquals(headers['Content-Length'], '0')
- self.assertTrue('Content-Type' in headers, headers.keys())
- self.assertEquals(headers['Content-Type'], '')
self.assertTrue('Host' in headers, headers.keys())
self.assertEquals(headers['Host'], 'localhost')
env = http['env']
diff --git a/tox.ini b/tox.ini
index 6bcee83..1358c87 100644
--- a/tox.ini
+++ b/tox.ini
@@ -10,7 +10,6 @@ envlist =
pypy
flake8
# contrib
- {py35,py36,py37}-django-dev
{py35,py36,py37}-django-{200}
{py27,py35}-django-111
{py27,py34,py35,py36}-django-{18,19,110}
@@ -37,7 +36,6 @@ deps =
django-110: Django>=1.10,<1.11
django-111: Django>=1.11,<1.12
django-200: Django>=2.0,<2.1
- django-dev: git+https://github.com/django/django.git#egg=Django
flask-10: Flask>=0.10,<0.11
flask-11: Flask>=0.11,<0.12
flask-12: Flask>=0.12,<0.13
@@ -80,11 +78,10 @@ commands:
[testenv:flake8]
-basepython = python3.6
+basepython = python3.7
skip_install = true
deps =
flake8
- flake8-docstrings>=0.2.7
flake8-import-order>=0.9
commands =
flake8 raven/ setup.py