summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorDavid Cramer <dcramer@gmail.com>2013-09-14 09:27:50 +0900
committerDavid Cramer <dcramer@gmail.com>2013-09-14 09:28:04 +0900
commit6636eb700f555be515442b35e4af7155e17b4c96 (patch)
tree8c37b563a418bf4b24dd0f6be2d74282bbfed053 /Makefile
parentc0362c6025f54312acc9cc0954e7dfed0852a189 (diff)
downloadraven-6636eb700f555be515442b35e4af7155e17b4c96.tar.gz
Force rebase and precommit flake8
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 80823f6..79dfaa0 100644
--- a/Makefile
+++ b/Makefile
@@ -2,6 +2,7 @@ bootstrap:
pip install -e . --use-mirrors
pip install "file://`pwd`#egg=raven[dev]" --use-mirrors
pip install "file://`pwd`#egg=raven[tests]" --use-mirrors
+ make setup-git
test: bootstrap lint
@echo "Running Python tests"
@@ -16,3 +17,7 @@ lint:
coverage:
coverage run runtests.py --include=raven/* && \
coverage html --omit=*/migrations/* -d cover
+
+setup-git:
+ git config branch.autosetuprebase always
+ cd .git/hooks && ln -sf ../../hooks/* ./