summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorDavid Cramer <dcramer@gmail.com>2018-02-02 15:23:28 -0800
committerAshley Camba <ashwoods@gmail.com>2018-02-03 04:44:39 +0100
commit91fc04639fe4b4b892cb6e8703491e4daa031ce8 (patch)
treec431d5a8cde054bf55063e208fac18a9ca2dc344 /setup.py
parentefb9e4adad6328e1cc47f50aeebbdc9e8d20854a (diff)
downloadraven-91fc04639fe4b4b892cb6e8703491e4daa031ce8.tar.gz
fix(breadcrumbs): Ensure maximum lengths on several attributes
- Trim message, category, and level attributes - Update pytest support to work in other environments
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py3
1 files changed, 3 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 3911020..c3f774c 100755
--- a/setup.py
+++ b/setup.py
@@ -59,6 +59,7 @@ if sys.version_info[0] == 3:
tests_require = [
'bottle',
'celery>=2.5',
+ 'coverage<4',
'exam>=0.5.2',
'flake8==3.5.0',
'logbook',
@@ -75,8 +76,10 @@ tests_require = [
'pytest-flake8==0.9.1',
'requests',
'tornado>=4.1',
+ 'tox',
'webob',
'webtest',
+ 'wheel',
'anyjson',
'ZConfig',
] + (