summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 80823f6..79dfaa0 100644
--- a/Makefile
+++ b/Makefile
@@ -2,6 +2,7 @@ bootstrap:
pip install -e . --use-mirrors
pip install "file://`pwd`#egg=raven[dev]" --use-mirrors
pip install "file://`pwd`#egg=raven[tests]" --use-mirrors
+ make setup-git
test: bootstrap lint
@echo "Running Python tests"
@@ -16,3 +17,7 @@ lint:
coverage:
coverage run runtests.py --include=raven/* && \
coverage html --omit=*/migrations/* -d cover
+
+setup-git:
+ git config branch.autosetuprebase always
+ cd .git/hooks && ln -sf ../../hooks/* ./