summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAshley Sommer <ashleysommer@gmail.com>2021-06-09 16:40:31 +1000
committerAshley Sommer <ashleysommer@gmail.com>2021-06-10 12:53:34 +1000
commitd07adcba6ac2e6f753e7ccf8d210a805f12ff17f (patch)
tree22e1ce1f5ae5b19b82aeb96249ec96f3116946f3
parent06df8b6e3efc916144082360167fbf78a1bd398f (diff)
downloadrdflib-drone_coverage.tar.gz
attempt at adding coveralls support to drone runsdrone_coverage
-rw-r--r--.drone.yml22
1 files changed, 17 insertions, 5 deletions
diff --git a/.drone.yml b/.drone.yml
index e40f9358..d6d839db 100644
--- a/.drone.yml
+++ b/.drone.yml
@@ -17,8 +17,8 @@ steps:
- pip install --default-timeout 60 coveralls && export HAS_COVERALLS=1
- python setup.py install
- flake8 --exit-zero rdflib
- - PYTHONWARNINGS=default nosetests --with-timer --timer-top-n 42 --with-coverage --cover-tests --cover-package=rdflib
- - coverage report
+ - PYTHONWARNINGS=default nosetests --with-timer --timer-top-n 42
+
---
kind: pipeline
@@ -31,7 +31,18 @@ platform:
steps:
- name: test
image: python:3.7
+ environment:
+ COVERALLS_SERVICE_NAME: RDFLib-Drone
+ COVERALLS_REPO_TOKEN:
+ from_secret: coveralls_token
commands:
+ - export COVERALLS_SERVICE_NUMBER="$DRONE_BUILD_NUMBER"
+ - export COVERALLS_SERVICE_JOB_ID="$DRONE_STAGE_NAME"
+ - export COVERALLS_SERVICE_JOB_NUMBER="$DRONE_BUILD_NUMBER"
+ - export COVERALLS_FLAG_NAME="$DRONE_STAGE_KIND"
+ - export COVERALLS_GIT_REPO="$DRONE_REPO_NAME"
+ - export COVERALLS_GIT_BRANCH="$DRONE_SOURCE_BRANCH"
+ - export CI_BRANCH="$DRONE_SOURCE_BRANCH"
- bash .travis.fuseki_install_optional.sh
- pip install --default-timeout 60 -r requirements.txt
- pip install --default-timeout 60 -r requirements.dev.txt
@@ -39,7 +50,8 @@ steps:
- python setup.py install
- flake8 --exit-zero rdflib
- PYTHONWARNINGS=default nosetests --with-timer --timer-top-n 42 --with-coverage --cover-tests --cover-package=rdflib
- - coverage report
+ - coverage report --skip-covered
+ - coveralls
---
kind: pipeline
@@ -59,5 +71,5 @@ steps:
- pip install --default-timeout 60 coveralls && export HAS_COVERALLS=1
- python setup.py install
- flake8 --exit-zero rdflib
- - PYTHONWARNINGS=default nosetests --with-timer --timer-top-n 42 --with-coverage --cover-tests --cover-package=rdflib
- - coverage report
+ - PYTHONWARNINGS=default nosetests --with-timer --timer-top-n 42
+