summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authoreikeon <devnull@localhost>2007-03-12 14:09:24 +0000
committereikeon <devnull@localhost>2007-03-12 14:09:24 +0000
commit284cd5517ab4d746b7866c03b70f8d02c4eed290 (patch)
treecd52f18b2013f164ec53f442e8cecbe57a38a137
parentcaca4d45146d8fbfa115f034d8e5e1b4e1e87252 (diff)
downloadrdflib-284cd5517ab4d746b7866c03b70f8d02c4eed290.tar.gz
added bit to configure 'setup.py nosetests' to run doc tests
-rw-r--r--setup.cfg6
-rw-r--r--setup.py2
-rw-r--r--test/util.py3
3 files changed, 10 insertions, 1 deletions
diff --git a/setup.cfg b/setup.cfg
index 0c3455bc..f4f4743f 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -1,3 +1,9 @@
[egg_info]
tag_build = .dev
tag_svn_revision = 1
+
+[nosetests]
+verbosity = 2
+with-doctest = 1
+
+
diff --git a/setup.py b/setup.py
index bfdb348c..d24d16ea 100644
--- a/setup.py
+++ b/setup.py
@@ -22,7 +22,7 @@ setup(
platforms = ["any"],
classifiers = ["Programming Language :: Python"],
long_description = "RDF library containing an RDF triple store and RDF/XML parser/serializer",
- download_url = "http://rdflib.net/rdflib-%s.tar.gz" % __version__,
+ #download_url = "http://rdflib.net/rdflib-%s.tar.gz" % __version__,
packages = find_packages(),
diff --git a/test/util.py b/test/util.py
index 2eb9e70b..711fa0be 100644
--- a/test/util.py
+++ b/test/util.py
@@ -15,5 +15,8 @@ class UtilTestCase(unittest.TestCase):
self.assertEquals(a, b)
+def testMe():
+ unittest.main(defaultTest='test_suite')
+
if __name__ == '__main__':
unittest.main(defaultTest='test_suite')