summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIwan Aucamp <aucampia@gmail.com>2023-03-16 23:26:37 +0100
committerGitHub <noreply@github.com>2023-03-16 23:26:37 +0100
commit309848bda0098e8d5dc3dcec179d9ca0e2196455 (patch)
tree9ae262811d2e4ebeccbd7de579599f14826e507c
parent1c256765ac7d5e7327695a44269be09e51bd88b1 (diff)
downloadrdflib-309848bda0098e8d5dc3dcec179d9ca0e2196455.tar.gz
chore: prepare for release 6.3.0 (#2276)6.3.0
Update the changelog and other parts to prepare for the 6.3.0 release. This will be tagged to 6.3.0.
-rw-r--r--CHANGELOG.md542
-rw-r--r--LICENSE2
-rw-r--r--README.md4
-rw-r--r--docs/conf.py2
-rw-r--r--pyproject.toml2
-rw-r--r--rdflib/__init__.py2
6 files changed, 292 insertions, 262 deletions
diff --git a/CHANGELOG.md b/CHANGELOG.md
index ec476ea3..798dabfd 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -1,65 +1,27 @@
-# 2022-10-16 RELEASE MAJOR.MINOR.PATCH
+# 2023-03-16 RELEASE 6.3.0
-## User facing changes
-
-This section lists changes that have a potential impact on users of RDFLib,
-changes with no user impact are not included in this section.
-
-<!--
-Please add an entry for user facing changes in this section.
-
-New changes should go at the bottom of the list but the placeholder should
-remain.
+This is a minor release that includes bug fixes and features.
-Non user-facing changes does not have to be recorded in the changelog. This
-includes changes to CI, testing, etc. These changes will show up in the "PRs
-merged since last release" section but they are somewhat irrelevant to users.
--->
+## Important Information
-<!--
-CHANGE BARRIER is intended to reduce the potential for merge conflicts
-and will be removed for release.
--->
+- RDFLib will drop support for Python 3.7 when it becomes EOL on 2023-06-27,
+ this will not be considered a breaking change, and RDFLib's major version
+ number will not be changed solely on the basis of Python 3.7 support being
+ dropped.
+## User facing changes
-<!-- -->
-<!-- -->
-<!-- CHANGE BARRIER: START -->
-<!-- -->
-<!-- -->
+This section lists changes that have a potential impact on users of RDFLib,
+changes with no user impact are not included in this section.
- Add chunk serializer that facilitates the encoding of a graph into multiple
N-Triples encoded chunks.
[PR #1968](https://github.com/RDFLib/rdflib/pull/1968).
-<!-- -->
-<!-- -->
-<!-- CHANGE BARRIER: END -->
-<!-- -->
-<!-- -->
-
- <!-- -->
- <!-- -->
- <!-- CHANGE BARRIER: START -->
- <!-- -->
- <!-- -->
-
- Fixes passing `NamespaceManager` in `ConjunctiveGraph`'s method `get_context()`.
- The `get_context()` method will now pass the `NamespaceManager` of `ConjunctiveGraph` to the `namespace_manager` attribute of the newly created context graph, instead of the `ConjunctiveGraph` object itself. This cleans up an old FIXME commment.
+ The `get_context()` method will now pass the `NamespaceManager` of `ConjunctiveGraph` to the `namespace_manager` attribute of the newly created context graph, instead of the `ConjunctiveGraph` object itself. This cleans up an old `FIXME` comment.
[PR #2073](https://github.com/RDFLib/rdflib/pull/2073).
-<!-- -->
-<!-- -->
-<!-- CHANGE BARRIER: END -->
-<!-- -->
-<!-- -->
-
-<!-- -->
-<!-- -->
-<!-- CHANGE BARRIER: START -->
-<!-- -->
-<!-- -->
-
- InfixOWL fixes and cleanup.
Closed [issue #2030](https://github.com/RDFLib/rdflib/issues/2030).
[PR #2024](https://github.com/RDFLib/rdflib/pull/2024),
@@ -79,67 +41,18 @@ and will be removed for release.
major version.
- Eliminated the use of mutable data structures in some argument defaults.
-<!-- -->
-<!-- -->
-<!-- CHANGE BARRIER: END -->
-<!-- -->
-<!-- -->
-
-<!-- -->
-<!-- -->
-<!-- CHANGE BARRIER: START -->
-<!-- -->
-<!-- -->
-
- Fixed some cross-referencing issues in RDFLib documentation.
Closed [issue #1878](https://github.com/RDFLib/rdflib/issues/1878).
[PR #2036](https://github.com/RDFLib/rdflib/pull/2036).
-<!-- -->
-<!-- -->
-<!-- CHANGE BARRIER: END -->
-<!-- -->
-<!-- -->
-
-<!-- -->
-<!-- -->
-<!-- CHANGE BARRIER: START -->
-<!-- -->
-<!-- -->
-
- Fixed import of `xml.sax.handler` in `rdflib.plugins.parsers.trix` so that it
no longer tries to import it from `xml.sax.saxutils`.
[PR #2041](https://github.com/RDFLib/rdflib/pull/2041).
-<!-- -->
-<!-- -->
-<!-- CHANGE BARRIER: END -->
-<!-- -->
-<!-- -->
-
-<!-- -->
-<!-- -->
-<!-- CHANGE BARRIER: START -->
-<!-- -->
-<!-- -->
-
- Removed a pre python 3.5 regex related workaround in the REPLACE SPARQL
function.
[PR #2042](https://github.com/RDFLib/rdflib/pull/2042).
-<!-- -->
-<!-- -->
-<!-- CHANGE BARRIER: END -->
-<!-- -->
-<!-- -->
-
-
-<!-- -->
-<!-- -->
-<!-- CHANGE BARRIER: START PR #2044 -->
-<!-- -->
-<!-- -->
-
- Fixed some issues with SPARQL XML result parsing that caused problems with
[`lxml`](https://lxml.de/). Closed [issue #2035](https://github.com/RDFLib/rdflib/issues/2035),
[issue #1847](https://github.com/RDFLib/rdflib/issues/1847).
@@ -152,173 +65,70 @@ and will be removed for release.
- Elements inside `<result>` that are not `<binding>` are now ignored.
- Also added type hints to `rdflib.plugins.sparql.results.xmlresults`.
-<!-- -->
-<!-- -->
-<!-- CHANGE BARRIER: END -->
-<!-- -->
-<!-- -->
-
-
-<!-- -->
-<!-- -->
-<!-- CHANGE BARRIER: START PR #2057 -->
-<!-- -->
-<!-- -->
-
-- Added type hints.
- - `rdflib.store` and builtin stores have mostly complete type hints.
- [PR #2057](https://github.com/RDFLib/rdflib/pull/2057).
- - `rdflib.graph` have mostly complete type hints.
+- Added type hints to the following modules:
+ - `rdflib.store`.
+ [PR #2057](https://github.com/RDFLib/rdflib/pull/2057).
+ - `rdflib.graph`.
[PR #2080](https://github.com/RDFLib/rdflib/pull/2080).
- - `rdflib.plugins.sparql.algebra` and `rdflib.plugins.sparql.operators` have
- mostly complete type hints.
- [PR #2094](https://github.com/RDFLib/rdflib/pull/2094).
- - `rdflib.query` and `rdflib.plugins.sparql.results.*` have mostly complete
- type hints.
- [PR #2097](https://github.com/RDFLib/rdflib/pull/2097).
-
-
-<!-- -->
-<!-- -->
-<!-- CHANGE BARRIER: END PR #2057 -->
-<!-- -->
-<!-- -->
-
-<!-- -->
-<!-- -->
-<!-- CHANGE BARRIER: START PR #2066 -->
-<!-- -->
-<!-- -->
-
+ - `rdflib.plugins.sparql.*`.
+ [PR #2094](https://github.com/RDFLib/rdflib/pull/2094),
+ [PR #2133](https://github.com/RDFLib/rdflib/pull/2133),
+ [PR #2265](https://github.com/RDFLib/rdflib/pull/2265),
+ [PR #2097](https://github.com/RDFLib/rdflib/pull/2097),
+ [PR #2268](https://github.com/RDFLib/rdflib/pull/2268).
+ - `rdflib.query`.
+ [PR #2265](https://github.com/RDFLib/rdflib/pull/2265).
+ - `rdflib.parser` and `rdflib.plugins.parsers.*`.
+ [PR #2232](https://github.com/RDFLib/rdflib/pull/2232).
+ - `rdflib.exceptions`.
+ [PR #2232](https://github.com/RDFLib/rdflib/pull/2232)
+ - `rdflib.shared.jsonld.*`.
+ [PR #2232](https://github.com/RDFLib/rdflib/pull/2232).
+ - `rdflib.collection`.
+ [PR #2263](https://github.com/RDFLib/rdflib/pull/2263).
+ - `rdflib.util`.
+ [PR #2262](https://github.com/RDFLib/rdflib/pull/2262).
+ - `rdflib.path`.
+ [PR #2261](https://github.com/RDFLib/rdflib/pull/2261).
+
- Removed pre python 3.7 compatibility code.
[PR #2066](https://github.com/RDFLib/rdflib/pull/2066).
- Removed fallback in case the `shutil` module does not have the `move`
function.
-<!-- -->
-<!-- -->
-<!-- CHANGE BARRIER: END PR #2066 -->
-<!-- -->
-<!-- -->
-
-
-<!-- -->
-<!-- -->
-<!-- CHANGE BARRIER: START #2068 -->
-<!-- -->
-<!-- -->
-
- Improve file-URI and path handling in `Graph.serialize` and `Result.serialize` to
address problems with windows path handling in `Result.serialize` and to make
the behavior between `Graph.serialize` and `Result.serialie` more consistent.
Closed [issue #2067](https://github.com/RDFLib/rdflib/issues/2067).
- [PR #2068](https://github.com/RDFLib/rdflib/pull/2068).
+ [PR #2065](https://github.com/RDFLib/rdflib/pull/2065).
- String values for the `destination` argument will now only be treated as
file URIs if `urllib.parse.urlparse` returns their schema as `file`.
- Simplified file writing to avoid a temporary file.
-<!-- -->
-<!-- -->
-<!-- CHANGE BARRIER: END #2068 -->
-<!-- -->
-<!-- -->
-
-
-<!-- -->
-<!-- -->
-<!-- CHANGE BARRIER: START PR #2069 -->
-<!-- -->
-<!-- -->
-
- Narrow the type of context-identifiers/graph-names from `rdflib.term.Node` to
`rdflib.term.IdentifiedNode` as no supported abstract syntax allows for other
types of context-identifiers.
[PR #2069](https://github.com/RDFLib/rdflib/pull/2069).
-<!-- -->
-<!-- -->
-<!-- CHANGE BARRIER: END PR #2069 -->
-<!-- -->
-<!-- -->
-
-
-<!-- -->
-<!-- -->
-<!-- CHANGE BARRIER: START PR #2070 -->
-<!-- -->
-<!-- -->
-
- Always parse HexTuple files as utf-8.
[PR #2070](https://github.com/RDFLib/rdflib/pull/2070).
-<!-- -->
-<!-- -->
-<!-- CHANGE BARRIER: END PR #2070 -->
-<!-- -->
-<!-- -->
-
-
-<!-- -->
-<!-- -->
-<!-- CHANGE BARRIER: START PR #2076 -->
-<!-- -->
-<!-- -->
-
- Fixed handling of `Literal` `datatype` to correctly differentiate between
blank string values and undefined values, also changed the datatype of
`rdflib.term.Literal.datatype` from `Optional[str]` to `Optional[URIRef]` now
that all non-`URIRef` `str` values will be converted to `URIRef`.
[PR #2076](https://github.com/RDFLib/rdflib/pull/2076).
-<!-- -->
-<!-- -->
-<!-- CHANGE BARRIER: END PR #2076 -->
-<!-- -->
-<!-- -->
-
-
-<!-- -->
-<!-- -->
-<!-- CHANGE BARRIER: START PR #2079 -->
-<!-- -->
-<!-- -->
-
- Fixed the generation of VALUES block for federated queries.
The values block was including non-variable values like BNodes which resulted
- in invalid queries.
- [PR #2079](https://github.com/RDFLib/rdflib/pull/2079).
-
-<!-- -->
-<!-- -->
-<!-- CHANGE BARRIER: END PR #2079 -->
-<!-- -->
-<!-- -->
-
-
-<!-- -->
-<!-- -->
-<!-- CHANGE BARRIER: START -->
-<!-- -->
-<!-- -->
+ in invalid queries. Closed [issue #2079](https://github.com/RDFLib/rdflib/issues/2079).
+ [PR #2084](https://github.com/RDFLib/rdflib/pull/2084).
- Only register the `rdflib.plugins.stores.berkeleydb.BerkeleyDB` as a store
plugin if the `berkeleydb` module is present.
Closed [issue #1816](https://github.com/RDFLib/rdflib/issues/1816).
[PR #2096](https://github.com/RDFLib/rdflib/pull/2096).
-<!-- -->
-<!-- -->
-<!-- CHANGE BARRIER: END -->
-<!-- -->
-<!-- -->
-
-
-<!-- -->
-<!-- -->
-<!-- CHANGE BARRIER: START PR #2085 -->
-<!-- -->
-<!-- -->
-
- Fixed serialization of BNodes in TriG.
The TriG serializer was only considering BNode references inside a single
graph and not counting the BNodes subjects as references when considering if a
@@ -327,38 +137,258 @@ and will be removed for release.
BNodes in other graphs.
[PR #2085](https://github.com/RDFLib/rdflib/pull/2085).
-<!-- -->
-<!-- -->
-<!-- CHANGE BARRIER: END PR #2085 -->
-<!-- -->
-<!-- -->
-
-<!-- -->
-<!-- -->
-<!-- CHANGE BARRIER: START -->
-<!-- -->
-<!-- -->
-
-- PLACEHOLDER.
- Description of changes.
- Closed [issue #....](https://github.com/RDFLib/rdflib/issues/).
- [PR #....](https://ichard26.github.io/next-pr-number/?owner=RDFLib&name=rdflib).
-
-<!-- -->
-<!-- -->
-<!-- CHANGE BARRIER: END -->
-<!-- -->
-<!-- -->
+- Deprecated `rdflib.path.evalPath` in favor of `rdflib.path.eval_path` which is
+ PEP-8 compliant. [PR #2046](https://github.com/RDFLib/rdflib/pull/2046)
-## PRs merged since last release
+- Added `charset=UTF-8` to the `Content-Type` header sent when doing an update
+ with `SPARQLConnector`. Closed [issue
+ #2095](https://github.com/RDFLib/rdflib/issues/2095). [PR
+ #2112](https://github.com/RDFLib/rdflib/pull/2112).
+
+- Removed the `rdflib.plugins.sparql.parserutils.plist` class as it served no
+ discernible purpose. [PR #2143](https://github.com/RDFLib/rdflib/pull/2143)
+
+- Changed the TriG serializer to not generate prefixes for empty graph IDs.
+ Closed [issue #2154](https://github.com/RDFLib/rdflib/issues/2154).
+ [PR #2160](https://github.com/RDFLib/rdflib/pull/2160).
+
+- Fixed handling of relative context files in the JSON-LD parser.
+ Closed [issue #2164](https://github.com/RDFLib/rdflib/issues/2164).
+ [PR #2165](https://github.com/RDFLib/rdflib/pull/2165).
-<!-- This will be auto generated with:
+- Improved failure handling in when computing QName for an unbound namespace.
+ [PR #2169](https://github.com/RDFLib/rdflib/pull/2169).
-gh search prs --repo RDFLib/rdflib --merged --base main --json assignees,author,authorAssociation,body,closedAt,commentsCount,createdAt,id,isLocked,isPullRequest,labels,number,repository,state,title,updatedAt,url --limit 1000 --jq '[.[] | select(.closedAt >= "2022-07-17T00:00:00Z")]' | jq '(. |= sort_by(.closedAt)) | reverse' | tee /var/tmp/merged-prs.json
+- Fixed a typo in the default bound namespace for `DCTERMS`.
+ [PR #2173](https://github.com/RDFLib/rdflib/pull/2173).
+
+- Add support for supplying a custom namespace manager to `n3()` methods.
+ [PR #2174](https://github.com/RDFLib/rdflib/pull/2174).
+
+- Fixed the query string parameters for `SPARQLConnector` when using POST method.
+ [PR #2180](https://github.com/RDFLib/rdflib/pull/2180).
+
+- Fixed extra keyword argument and header handling in `SPARQLConnector` that
+ resulted in headers from `SPARQLConnector.update` polluting headers from
+ `SPARQLConnector.query` vice versa.
+ [PR #2183](https://github.com/RDFLib/rdflib/pull/2183)
+
+- Added version restrictions for dependencies.
+ [PR #2187](https://github.com/RDFLib/rdflib/pull/2187)
+
+- Switch to using `importlib` for getting the version of RDFLib instead of
+ hard-coding it in `__version__`.
+ [PR #2187](https://github.com/RDFLib/rdflib/pull/2187).
+
+- Removed non-runtime extras, for building documentation, running tests and
+ other development operations the versions and dependencies are now
+ managed with Poetry.
+ [PR #2187](https://github.com/RDFLib/rdflib/pull/2187).
+
+- Fixed a bug that occurred when `VALUES` was used outside a `GROUP BY` clause.
+ [PR #2188](https://github.com/RDFLib/rdflib/pull/2188).
+
+- Fixed a bug that occurred when using `SELECT *` inside another `SELECT *`.
+ Closed [issue #1722](https://github.com/RDFLib/rdflib/issues/1722).
+ [PR #2190](https://github.com/RDFLib/rdflib/pull/2190).
+
+- Added SPARQL DESCRIBE query implementation.
+ Closes [issue #479](https://github.com/RDFLib/rdflib/issues/479).
+ [PR #2221](https://github.com/RDFLib/rdflib/pull/2221).
+
+- Fixed a bug in `rdflib.tools.defined_namespace_creator` that occurred when
+ multiple `rdfs:comment` were present on one resource.
+ [PR #2254](https://github.com/RDFLib/rdflib/pull/2254).
+
+- Fixed `rdflib.util._iri2uri()` to not quote the `netloc` parameter.
+ [PR #2255](https://github.com/RDFLib/rdflib/pull/2255).
+
+- Fixed the HexTuple parser's handling of input sources to works for more input sources.
+ [PR #2255](https://github.com/RDFLib/rdflib/pull/2255).
+
+- Fixed the creation of input source objects from IO stream sources.
+ [PR #2255](https://github.com/RDFLib/rdflib/pull/2255).
+
+- Eliminated the use of the deprecated `rdflib.path.evalPath` function.
+ [PR #2266](https://github.com/RDFLib/rdflib/pull/2266)
+
+- Added documentation for security considerations and available mitigations.
+ Closed [issue #1844](https://github.com/RDFLib/rdflib/issues/1844).
+ [PR #2267](https://github.com/RDFLib/rdflib/pull/2270).
+
+## PRs merged since last release
-jq -r '.[] | [ .url, .title ] | @tsv' /var/tmp/merged-prs.json | sort -r | awk -F$'\t' '(match($1, "^.*/([^/]+)$", matches)){printf("* %s\n [PR #%s](%s)\n", $2, matches[1], $1)}'
+* fix: validation issues with examples
+ [PR #2269](https://github.com/RDFLib/rdflib/pull/2269)
+* feat: more type hints for `rdflib.plugins.sparql`
+ [PR #2268](https://github.com/RDFLib/rdflib/pull/2268)
+* fix: eliminate use of deprecated `rdflib.path.evalPath`
+ [PR #2266](https://github.com/RDFLib/rdflib/pull/2266)
+* more type-hinting for SPARQL plugin
+ [PR #2265](https://github.com/RDFLib/rdflib/pull/2265)
+* feat: add diverse type hints
+ [PR #2264](https://github.com/RDFLib/rdflib/pull/2264)
+* feat: add type hints to `rdflib.collection`
+ [PR #2263](https://github.com/RDFLib/rdflib/pull/2263)
+* feat: add type hints to `rdflib.util`
+ [PR #2262](https://github.com/RDFLib/rdflib/pull/2262)
+* feat: add type hints to `rdflib.path`
+ [PR #2261](https://github.com/RDFLib/rdflib/pull/2261)
+* test: fix deprecation warnings
+ [PR #2260](https://github.com/RDFLib/rdflib/pull/2260)
+* docs: update test reports
+ [PR #2259](https://github.com/RDFLib/rdflib/pull/2259)
+* fix: small InputSource related issues
+ [PR #2255](https://github.com/RDFLib/rdflib/pull/2255)
+* defined_namespace_creator: concatenate several rdfs:comments
+ [PR #2254](https://github.com/RDFLib/rdflib/pull/2254)
+* feat: add parser type hints
+ [PR #2232](https://github.com/RDFLib/rdflib/pull/2232)
+* build: bump versions
+ [PR #2231](https://github.com/RDFLib/rdflib/pull/2231)
+* Add SPARQL DESCRIBE query implementation
+ [PR #2221](https://github.com/RDFLib/rdflib/pull/2221)
+* build: rename minimum constraints file to evade dependabot
+ [PR #2209](https://github.com/RDFLib/rdflib/pull/2209)
+* Fix for `SELECT *` inside `SELECT *` bug
+ [PR #2190](https://github.com/RDFLib/rdflib/pull/2190)
+* Fixing bug applying VALUES outside of a GROUP BY
+ [PR #2188](https://github.com/RDFLib/rdflib/pull/2188)
+* move to poetry for dependency management; consolidate more settings into pyproject.toml
+ [PR #2187](https://github.com/RDFLib/rdflib/pull/2187)
+* build: update black to 22.12.0
+ [PR #2186](https://github.com/RDFLib/rdflib/pull/2186)
+* Issue2179 incorrect headers
+ [PR #2183](https://github.com/RDFLib/rdflib/pull/2183)
+* Fix missing query string params in sparqlconnector when using POST method
+ [PR #2180](https://github.com/RDFLib/rdflib/pull/2180)
+* [pre-commit.ci] pre-commit autoupdate
+ [PR #2178](https://github.com/RDFLib/rdflib/pull/2178)
+* Add namespace_manager argument for n3 method on Paths
+ [PR #2174](https://github.com/RDFLib/rdflib/pull/2174)
+* fix DCTERMS prefix typo
+ [PR #2173](https://github.com/RDFLib/rdflib/pull/2173)
+* compute_qname handle case where name could be unbound
+ [PR #2169](https://github.com/RDFLib/rdflib/pull/2169)
+* Issue 2164
+ [PR #2165](https://github.com/RDFLib/rdflib/pull/2165)
+* build: update black to 22.10.0
+ [PR #2163](https://github.com/RDFLib/rdflib/pull/2163)
+* ci: switch to python 3.11 release
+ [PR #2162](https://github.com/RDFLib/rdflib/pull/2162)
+* fix: type errors resulting from new mypy
+ [PR #2161](https://github.com/RDFLib/rdflib/pull/2161)
+* do not write prefix for empty graph id, fix #2154
+ [PR #2160](https://github.com/RDFLib/rdflib/pull/2160)
+* Remove redundant class
+ [PR #2143](https://github.com/RDFLib/rdflib/pull/2143)
+* Pass `service_query` to `_buildQueryStringForServiceCall` instead of a `Match`
+ [PR #2134](https://github.com/RDFLib/rdflib/pull/2134)
+* Add type hint to part in evalServiceQuery
+ [PR #2133](https://github.com/RDFLib/rdflib/pull/2133)
+* Remove outdated comment
+ [PR #2129](https://github.com/RDFLib/rdflib/pull/2129)
+* fix: type ignore compatibility with latest mypy
+ [PR #2127](https://github.com/RDFLib/rdflib/pull/2127)
+* Remove redundant PR template
+ [PR #2126](https://github.com/RDFLib/rdflib/pull/2126)
+* build: use 3.11.0-rc.2
+ [PR #2119](https://github.com/RDFLib/rdflib/pull/2119)
+* build: docker images for latest release and main branch
+ [PR #2116](https://github.com/RDFLib/rdflib/pull/2116)
+* add charset encoding to SPARQLConnector.update() request.
+ [PR #2112](https://github.com/RDFLib/rdflib/pull/2112)
+* Add test for issue #2011
+ [PR #2107](https://github.com/RDFLib/rdflib/pull/2107)
+* chore: rename default branch to `main`
+ [PR #2101](https://github.com/RDFLib/rdflib/pull/2101)
+* Correct a typo in test_roundtrip.py
+ [PR #2100](https://github.com/RDFLib/rdflib/pull/2100)
+* feat: add type hints to `rdflib.query` and related
+ [PR #2097](https://github.com/RDFLib/rdflib/pull/2097)
+* fix: Don't register berkelydb as a store if it is not available on the system
+ [PR #2096](https://github.com/RDFLib/rdflib/pull/2096)
+* feat: add type hints to `rdflib.plugins.sparql.{algebra,operators}`
+ [PR #2094](https://github.com/RDFLib/rdflib/pull/2094)
+* test: Fix `exclude_lines` for coverage
+ [PR #2093](https://github.com/RDFLib/rdflib/pull/2093)
+* test: content-type handling with SPARQLStore + CONSTRUCT queries
+ [PR #2092](https://github.com/RDFLib/rdflib/pull/2092)
+* ci: publish test reports for mypy and pytest
+ [PR #2091](https://github.com/RDFLib/rdflib/pull/2091)
+* test: convert more test from unittest to pytest
+ [PR #2089](https://github.com/RDFLib/rdflib/pull/2089)
+* ci: switch from 3.11.0-beta.4 to 3.11.0-rc.1
+ [PR #2087](https://github.com/RDFLib/rdflib/pull/2087)
+* fix: issue with trig reference counting across graphs
+ [PR #2085](https://github.com/RDFLib/rdflib/pull/2085)
+* Generate VALUES block for federated queries with variables only
+ [PR #2084](https://github.com/RDFLib/rdflib/pull/2084)
+* docs: Add a contributing guide
+ [PR #2082](https://github.com/RDFLib/rdflib/pull/2082)
+* feat: Add type hints to rdflib.graph
+ [PR #2080](https://github.com/RDFLib/rdflib/pull/2080)
+* fix: handling of Literal datatype
+ [PR #2076](https://github.com/RDFLib/rdflib/pull/2076)
+* test: convert some `unittest` based tests to `pytest`
+ [PR #2075](https://github.com/RDFLib/rdflib/pull/2075)
+* test: honour lax cardinality from test manifests
+ [PR #2074](https://github.com/RDFLib/rdflib/pull/2074)
+* Fix passing ConjunctiveGraph as namespace_manager
+ [PR #2073](https://github.com/RDFLib/rdflib/pull/2073)
+* fix: always parse HexTuple files as utf-8
+ [PR #2070](https://github.com/RDFLib/rdflib/pull/2070)
+* fix: narrow the context identifier type from `Node` to `IdentifiedNode`
+ [PR #2069](https://github.com/RDFLib/rdflib/pull/2069)
+* build: set a minimum version for flakeheaven
+ [PR #2068](https://github.com/RDFLib/rdflib/pull/2068)
+* chore: remove pre Python 3.7 compatibility code for shutil
+ [PR #2066](https://github.com/RDFLib/rdflib/pull/2066)
+* fix: issues with string destination handling in `{Graph,Result}.serialize`
+ [PR #2065](https://github.com/RDFLib/rdflib/pull/2065)
+* build: fix Taskfile.yml for Windows
+ [PR #2064](https://github.com/RDFLib/rdflib/pull/2064)
+* test: convert `test/test_sparql/test_sparql_parser.py` to pytest
+ [PR #2063](https://github.com/RDFLib/rdflib/pull/2063)
+* test: convert `test/test_sparql/test_construct_bindings.py` to pytest
+ [PR #2062](https://github.com/RDFLib/rdflib/pull/2062)
+* test: convert `test/test_parsers/test_nquads.py` to pytest
+ [PR #2061](https://github.com/RDFLib/rdflib/pull/2061)
+* test: convert `test/test_namespace/test_namespace.py` to pytest
+ [PR #2060](https://github.com/RDFLib/rdflib/pull/2060)
+* docs: add DOI for RDFLib
+ [PR #2058](https://github.com/RDFLib/rdflib/pull/2058)
+* feat: add type hints for `rdflib.store` and `rdflib.plugins.stores`
+ [PR #2057](https://github.com/RDFLib/rdflib/pull/2057)
+* Toplevel n80x
+ [PR #2046](https://github.com/RDFLib/rdflib/pull/2046)
+* docs: add some additional badges
+ [PR #2045](https://github.com/RDFLib/rdflib/pull/2045)
+* fix: SPARQL XML result parsing
+ [PR #2044](https://github.com/RDFLib/rdflib/pull/2044)
+* chore: remove pre python 3.5 regex related workaround
+ [PR #2042](https://github.com/RDFLib/rdflib/pull/2042)
+* fix: import xml.sax.handler from the right place
+ [PR #2041](https://github.com/RDFLib/rdflib/pull/2041)
+* test: remove python 2.4 specific behaviour in test
+ [PR #2040](https://github.com/RDFLib/rdflib/pull/2040)
+* build: remove drone config
+ [PR #2037](https://github.com/RDFLib/rdflib/pull/2037)
+* docs: fix sphinx nitpicky issues
+ [PR #2036](https://github.com/RDFLib/rdflib/pull/2036)
+* build: Gitpod integration and Google Cloud Shell Button
+ [PR #2034](https://github.com/RDFLib/rdflib/pull/2034)
+* Infixowl cleanup iii
+ [PR #2033](https://github.com/RDFLib/rdflib/pull/2033)
+* build: Taskfile improvements
+ [PR #2032](https://github.com/RDFLib/rdflib/pull/2032)
+* docs: removed "Other changes" from CHANGELOG.md
+ [PR #2031](https://github.com/RDFLib/rdflib/pull/2031)
+* Infixowl coverage ii
+ [PR #2024](https://github.com/RDFLib/rdflib/pull/2024)
+* add chunk serializer & tests
+ [PR #1968](https://github.com/RDFLib/rdflib/pull/1968)
--->
# 2022-07-16 RELEASE 6.2.0
diff --git a/LICENSE b/LICENSE
index 06c82bb3..26039b46 100644
--- a/LICENSE
+++ b/LICENSE
@@ -1,6 +1,6 @@
BSD 3-Clause License
-Copyright (c) 2002-2022, RDFLib Team
+Copyright (c) 2002-2023, RDFLib Team
All rights reserved.
Redistribution and use in source and binary forms, with or without
diff --git a/README.md b/README.md
index 60599831..49c63ac8 100644
--- a/README.md
+++ b/README.md
@@ -43,7 +43,7 @@ Help with maintenance of all of the RDFLib family of packages is always welcome
## Versions & Releases
-* `6.3.0a0` current `main` branch
+* `6.4.0a0` current `main` branch
* `6.x.y` current release and support Python 3.7+ only. Many improvements over 5.0.0
* see [Releases](https://github.com/RDFLib/rdflib/releases)
* `5.x.y` supports Python 2.7 and 3.4+ and is [mostly backwards compatible with 4.2.2](https://rdflib.readthedocs.io/en/stable/upgrade4to5.html).
@@ -61,7 +61,7 @@ The stable release of RDFLib may be installed with Python's package management t
Alternatively manually download the package from the Python Package
Index (PyPI) at https://pypi.python.org/pypi/rdflib
-The current version of RDFLib is 6.2.0, see the ``CHANGELOG.md`` file for what's new in this release.
+The current version of RDFLib is 6.3.0, see the ``CHANGELOG.md`` file for what's new in this release.
### Installation of the current main branch (for developers)
diff --git a/docs/conf.py b/docs/conf.py
index 3068cc12..40ef87a1 100644
--- a/docs/conf.py
+++ b/docs/conf.py
@@ -79,7 +79,7 @@ master_doc = "index"
# General information about the project.
project = "rdflib"
-copyright = "2009 - 2022, RDFLib Team"
+copyright = "2009 - 2023, RDFLib Team"
# The version info for the project you're documenting, acts as replacement for
# |version| and |release|, also used in various other places throughout the
diff --git a/pyproject.toml b/pyproject.toml
index 24be1293..11f76e5e 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -1,6 +1,6 @@
[tool.poetry]
name = "rdflib"
-version = "6.3.0a0"
+version = "6.3.0"
description = """RDFLib is a Python library for working with RDF, \
a simple yet powerful language for representing information."""
authors = ["Daniel 'eikeon' Krech <eikeon@eikeon.com>"]
diff --git a/rdflib/__init__.py b/rdflib/__init__.py
index 45648456..ebf1344c 100644
--- a/rdflib/__init__.py
+++ b/rdflib/__init__.py
@@ -56,7 +56,7 @@ _DISTRIBUTION_METADATA = metadata.metadata("rdflib")
__docformat__ = "restructuredtext en"
__version__: str = _DISTRIBUTION_METADATA["Version"]
-__date__ = "2022-12-20"
+__date__ = "2023-03-16"
__all__ = [
"URIRef",