summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIwan Aucamp <aucampia@gmail.com>2023-04-09 15:25:43 +0200
committerGitHub <noreply@github.com>2023-04-09 15:25:43 +0200
commit950e60a6635a00039628b08a4c66b0b2af95525f (patch)
tree783e1d0a3390adb8d982ba41b4af2a3ff756ef40
parent89982f836780650389fb893d7d94e57a0d512cf5 (diff)
downloadrdflib-950e60a6635a00039628b08a4c66b0b2af95525f.tar.gz
build: unify poetry version source (#2334)
Change the GitHub actions workflows to use the Poetry version specified in `devtools/requirements-poetry.in` so that it becomes simpler to upgrade Poetry. Also upgrade the version of Poetry from 1.4.0 to 1.4.2
-rw-r--r--.github/workflows/docker-images.yaml14
-rw-r--r--.github/workflows/validate.yaml18
-rw-r--r--.pre-commit-config.yaml2
-rw-r--r--devtools/requirements-poetry.in2
4 files changed, 16 insertions, 20 deletions
diff --git a/.github/workflows/docker-images.yaml b/.github/workflows/docker-images.yaml
index 7d755b3f..81c73673 100644
--- a/.github/workflows/docker-images.yaml
+++ b/.github/workflows/docker-images.yaml
@@ -44,10 +44,9 @@ jobs:
uses: arduino/setup-task@v1
with:
repo-token: ${{ secrets.GITHUB_TOKEN }}
- - name: Python Poetry Action
- uses: abatilo/actions-poetry@v2.3.0
- with:
- poetry-version: 1.4.0
+ - name: Install poetry
+ run: |
+ pip install -r devtools/requirements-poetry.in
- name: Build images
shell: bash
run: |
@@ -70,10 +69,9 @@ jobs:
uses: arduino/setup-task@v1
with:
repo-token: ${{ secrets.GITHUB_TOKEN }}
- - name: Python Poetry Action
- uses: abatilo/actions-poetry@v2.3.0
- with:
- poetry-version: 1.4.0
+ - name: Install poetry
+ run: |
+ pip install -r devtools/requirements-poetry.in
- name: Login to GitHub Container Registry
uses: docker/login-action@v2
with:
diff --git a/.github/workflows/validate.yaml b/.github/workflows/validate.yaml
index 9f65e91a..dc95a79b 100644
--- a/.github/workflows/validate.yaml
+++ b/.github/workflows/validate.yaml
@@ -65,7 +65,7 @@ jobs:
uses: actions/cache@v3
with:
path: ${{ env.XDG_CACHE_HOME }}
- key: ${{ github.job }}-xdg-v1-${{ matrix.os }}-${{ matrix.python-version }}-${{ hashFiles('**/pyproject.toml', '**/poetry.lock', '**/with-fuseki.sh', '**/*requirements*.txt') }}
+ key: ${{ github.job }}-xdg-v1-${{ matrix.os }}-${{ matrix.python-version }}-${{ hashFiles('**/pyproject.toml', '**/poetry.lock', '**/with-fuseki.sh', '**/*requirements*.txt', '**/*requirements*.in') }}
restore-keys: |
${{ github.job }}-xdg-v1-${{ matrix.os }}-${{ matrix.python-version }}-
${{ github.job }}-xdg-v1-${{ matrix.os }}-
@@ -73,10 +73,9 @@ jobs:
uses: actions/setup-python@v4
with:
python-version: ${{ matrix.python-version }}
- - name: Python Poetry Action
- uses: abatilo/actions-poetry@v2.3.0
- with:
- poetry-version: 1.4.0
+ - name: Install poetry
+ run: |
+ pip install -r devtools/requirements-poetry.in
- uses: actions/setup-java@v3
if: ${{ matrix.extensive-tests }}
with:
@@ -133,7 +132,7 @@ jobs:
uses: actions/cache@v3
with:
path: ${{ env.XDG_CACHE_HOME }}
- key: ${{ github.job }}-xdg-v1-${{ matrix.os }}-${{ matrix.python-version }}-${{ hashFiles('**/pyproject.toml', '**/poetry.lock', '**/with-fuseki.sh', '**/*requirements*.txt') }}
+ key: ${{ github.job }}-xdg-v1-${{ matrix.os }}-${{ matrix.python-version }}-${{ hashFiles('**/pyproject.toml', '**/poetry.lock', '**/with-fuseki.sh', '**/*requirements*.txt', '**/*requirements*.in') }}
restore-keys: |
${{ github.job }}-xdg-v1-${{ matrix.os }}-${{ matrix.python-version }}-
${{ github.job }}-xdg-v1-${{ matrix.os }}-
@@ -141,10 +140,9 @@ jobs:
uses: actions/setup-python@v4
with:
python-version: ${{ matrix.python-version }}
- - name: Python Poetry Action
- uses: abatilo/actions-poetry@v2.3.0
- with:
- poetry-version: 1.4.0
+ - name: Install poetry
+ run: |
+ pip install -r devtools/requirements-poetry.in
- name: Install Task
uses: arduino/setup-task@v1
with:
diff --git a/.pre-commit-config.yaml b/.pre-commit-config.yaml
index 6e05165b..b4dfbddc 100644
--- a/.pre-commit-config.yaml
+++ b/.pre-commit-config.yaml
@@ -25,7 +25,7 @@ repos:
require_serial: true
args: ["."]
- repo: https://github.com/python-poetry/poetry
- rev: 1.4.0
+ rev: 1.4.2
hooks:
- id: poetry-check
- id: poetry-lock
diff --git a/devtools/requirements-poetry.in b/devtools/requirements-poetry.in
index 55e389c8..b01ce00a 100644
--- a/devtools/requirements-poetry.in
+++ b/devtools/requirements-poetry.in
@@ -1,3 +1,3 @@
# Fixing this here as readthedocs can't use the compiled requirements-poetry.txt
# due to conflicts.
-poetry==1.4.0
+poetry==1.4.2