summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIwan Aucamp <aucampia@gmail.com>2022-09-04 22:00:41 +0200
committerGitHub <noreply@github.com>2022-09-04 22:00:41 +0200
commitbe13b3af51b69c6eaf6c88d6811b0573af8edffb (patch)
tree16211fb63a88d05dfc4bc222787db17af4f5559d
parent6d215160fcd2d4eed20da72d2de20fc362e7314a (diff)
downloadrdflib-be13b3af51b69c6eaf6c88d6811b0573af8edffb.tar.gz
chore: rename default branch to `main` (#2101)
We are still using a somewhat outmoded name for our default branch, this PR captures the decision to change it as a decision record and prepares the rest of the repo for this change. Once merged, the main branch of RDFLib will be renamed using the procedure documented [here](https://github.com/github/renaming). Other changes: - Add area for decision records (this may be merged in another PR before this one). - Remove duplicated sections from `docs/upgrade4to5.rst` as they cause problems when using `sphinx.ext.autosectionlabel` and serve no purpose.
-rw-r--r--.github/PULL_REQUEST_TEMPLATE.md2
-rw-r--r--.github/workflows/validate.yaml2
-rw-r--r--CHANGELOG.md2
-rw-r--r--README.md14
-rwxr-xr-xdevtools/diffrtpy.py2
-rw-r--r--docs/CONTRIBUTING.md2
-rw-r--r--docs/conf.py3
-rw-r--r--docs/decisions/20220826-default_branch.rst42
-rw-r--r--docs/decisions/index.rst69
-rw-r--r--docs/developers.rst2
-rw-r--r--docs/gettingstarted.rst4
-rw-r--r--docs/index.rst21
-rw-r--r--docs/upgrade4to5.rst53
-rw-r--r--test/data/suites/rdflib/sparql/manifest.ttl2
-rw-r--r--test/test_w3c_spec/test_sparql_rdflib.py2
-rw-r--r--test_reports/rdflib_sparql-HEAD.ttl58
16 files changed, 174 insertions, 106 deletions
diff --git a/.github/PULL_REQUEST_TEMPLATE.md b/.github/PULL_REQUEST_TEMPLATE.md
index 8d36c022..f426017b 100644
--- a/.github/PULL_REQUEST_TEMPLATE.md
+++ b/.github/PULL_REQUEST_TEMPLATE.md
@@ -13,7 +13,7 @@ If you have any questions regarding our guidelines, submit the PR as is
and ask.
More detailed guidelines for pull requests are provided in our [developers
-guide](https://github.com/RDFLib/rdflib/blob/master/docs/developers.rst).
+guide](https://github.com/RDFLib/rdflib/blob/main/docs/developers.rst).
As a reminder, PRs that are smaller in size and scope will be reviewed and
merged quicker, so please consider if your PR could be split up into more than
diff --git a/.github/workflows/validate.yaml b/.github/workflows/validate.yaml
index 15ab02c9..1173a577 100644
--- a/.github/workflows/validate.yaml
+++ b/.github/workflows/validate.yaml
@@ -2,7 +2,7 @@ name: Validate
on:
push:
- branches: ["master"]
+ branches: ["main"]
pull_request:
workflow_dispatch:
diff --git a/CHANGELOG.md b/CHANGELOG.md
index a0a4d428..ec476ea3 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -354,7 +354,7 @@ and will be removed for release.
<!-- This will be auto generated with:
-gh search prs --repo RDFLib/rdflib --merged --base master --json assignees,author,authorAssociation,body,closedAt,commentsCount,createdAt,id,isLocked,isPullRequest,labels,number,repository,state,title,updatedAt,url --limit 1000 --jq '[.[] | select(.closedAt >= "2022-07-17T00:00:00Z")]' | jq '(. |= sort_by(.closedAt)) | reverse' | tee /var/tmp/merged-prs.json
+gh search prs --repo RDFLib/rdflib --merged --base main --json assignees,author,authorAssociation,body,closedAt,commentsCount,createdAt,id,isLocked,isPullRequest,labels,number,repository,state,title,updatedAt,url --limit 1000 --jq '[.[] | select(.closedAt >= "2022-07-17T00:00:00Z")]' | jq '(. |= sort_by(.closedAt)) | reverse' | tee /var/tmp/merged-prs.json
jq -r '.[] | [ .url, .title ] | @tsv' /var/tmp/merged-prs.json | sort -r | awk -F$'\t' '(match($1, "^.*/([^/]+)$", matches)){printf("* %s\n [PR #%s](%s)\n", $2, matches[1], $1)}'
diff --git a/README.md b/README.md
index c76e7fe7..72d385df 100644
--- a/README.md
+++ b/README.md
@@ -2,9 +2,9 @@
RDFLib
======
-[![Build Status](https://github.com/RDFLib/rdflib/actions/workflows/validate.yaml/badge.svg?branch=master)](https://github.com/RDFLib/rdflib/actions?query=branch%3Amaster)
+[![Build Status](https://github.com/RDFLib/rdflib/actions/workflows/validate.yaml/badge.svg?branch=main)](https://github.com/RDFLib/rdflib/actions?query=branch%3Amain)
[![Documentation Status](https://readthedocs.org/projects/rdflib/badge/?version=latest)](https://rdflib.readthedocs.io/en/latest/?badge=latest)
-[![Coveralls branch](https://img.shields.io/coveralls/RDFLib/rdflib/master.svg)](https://coveralls.io/r/RDFLib/rdflib?branch=master)
+[![Coveralls branch](https://img.shields.io/coveralls/RDFLib/rdflib/main.svg)](https://coveralls.io/r/RDFLib/rdflib?branch=main)
[![GitHub stars](https://img.shields.io/github/stars/RDFLib/rdflib.svg)](https://github.com/RDFLib/rdflib/stargazers)
[![Downloads](https://pepy.tech/badge/rdflib/week)](https://pepy.tech/project/rdflib)
@@ -43,7 +43,7 @@ Help with maintenance of all of the RDFLib family of packages is always welcome
## Versions & Releases
-* `6.3.0a0` current `master` branch
+* `6.3.0a0` current `main` branch
* `6.x.y` current release and support Python 3.7+ only. Many improvements over 5.0.0
* see [Releases](https://github.com/RDFLib/rdflib/releases)
* `5.x.y` supports Python 2.7 and 3.4+ and is [mostly backwards compatible with 4.2.2](https://rdflib.readthedocs.io/en/stable/upgrade4to5.html).
@@ -63,15 +63,15 @@ Index (PyPI) at https://pypi.python.org/pypi/rdflib
The current version of RDFLib is 6.2.0, see the ``CHANGELOG.md`` file for what's new in this release.
-### Installation of the current master branch (for developers)
+### Installation of the current main branch (for developers)
With *pip* you can also install rdflib from the git repository with one of the following options:
- $ pip install git+https://github.com/rdflib/rdflib@master
+ $ pip install git+https://github.com/rdflib/rdflib@main
or
- $ pip install -e git+https://github.com/rdflib/rdflib@master#egg=rdflib
+ $ pip install -e git+https://github.com/rdflib/rdflib@main#egg=rdflib
or from your locally cloned repository you can install it with one of the following options:
@@ -211,7 +211,7 @@ Please consider lodging Pull Requests here:
To get a development environment consider using Gitpod or Google Cloud Shell.
[![Open in Gitpod](https://gitpod.io/button/open-in-gitpod.svg)](https://gitpod.io/#https://github.com/RDFLib/rdflib)
-[![Open in Cloud Shell](https://gstatic.com/cloudssh/images/open-btn.svg)](https://shell.cloud.google.com/cloudshell/editor?cloudshell_git_repo=https%3A%2F%2Fgithub.com%2FRDFLib%2Frdflib&cloudshell_git_branch=master&cloudshell_open_in_editor=README.md)
+[![Open in Cloud Shell](https://gstatic.com/cloudssh/images/open-btn.svg)](https://shell.cloud.google.com/cloudshell/editor?cloudshell_git_repo=https%3A%2F%2Fgithub.com%2FRDFLib%2Frdflib&cloudshell_git_branch=main&cloudshell_open_in_editor=README.md)
You can also raise issues here:
diff --git a/devtools/diffrtpy.py b/devtools/diffrtpy.py
index d8873aa5..6da8bc37 100755
--- a/devtools/diffrtpy.py
+++ b/devtools/diffrtpy.py
@@ -12,7 +12,7 @@ To use this script
.. code-block:: bash
task run -- python -m pip install --upgrade strip-hints black python-minifier
- PYLOGGING_LEVEL=INFO task run -- git difftool -y -x $(readlink -f devtools/diffrtpy.py) upstream/master | tee /var/tmp/compact.diff
+ PYLOGGING_LEVEL=INFO task run -- git difftool -y -x $(readlink -f devtools/diffrtpy.py) upstream/main | tee /var/tmp/compact.diff
Then attach ``/var/tmp/compact.diff`` to the PR.
"""
diff --git a/docs/CONTRIBUTING.md b/docs/CONTRIBUTING.md
index 236b5c9f..f900dcb4 100644
--- a/docs/CONTRIBUTING.md
+++ b/docs/CONTRIBUTING.md
@@ -18,7 +18,7 @@ Some ways in which you can contribute to RDFLib are:
tests for open issues:
[![GitHub issues](https://img.shields.io/github/issues/RDFLib/rdflib)](https://github.com/RDFLib/rdflib/issues)
- Add tests for untested code:
- [![Coveralls branch](https://img.shields.io/coveralls/RDFLib/rdflib/master.svg)](https://coveralls.io/r/RDFLib/rdflib?branch=master)
+ [![Coveralls branch](https://img.shields.io/coveralls/RDFLib/rdflib/main.svg)](https://coveralls.io/r/RDFLib/rdflib?branch=main)
- Review pull requests marked with the
[![review wanted](https://img.shields.io/badge/-review%20wanted-28ead2)](https://github.com/RDFLib/rdflib/labels/review%20wanted)
label.
diff --git a/docs/conf.py b/docs/conf.py
index 802e8cb4..13bc511f 100644
--- a/docs/conf.py
+++ b/docs/conf.py
@@ -39,6 +39,7 @@ extensions = [
"sphinx.ext.viewcode",
"myst_parser",
"sphinxcontrib.kroki",
+ "sphinx.ext.autosectionlabel",
]
apidoc_module_dir = "../rdflib"
@@ -52,6 +53,8 @@ always_document_param_types = True
autosummary_generate = True
+autosectionlabel_prefix_document = True
+
# Add any paths that contain templates here, relative to this directory.
templates_path = ["_templates"]
diff --git a/docs/decisions/20220826-default_branch.rst b/docs/decisions/20220826-default_branch.rst
new file mode 100644
index 00000000..dfa4189f
--- /dev/null
+++ b/docs/decisions/20220826-default_branch.rst
@@ -0,0 +1,42 @@
+Default Branch Name
+===========================
+
+.. admonition:: Status
+
+ Accepted
+
+Context
+-------
+
+In recent years usage of the word ``master`` has become somewhat controversial
+[SFC-BNAMING]_ and consequently default branch name of Git repos has become
+``main``, both in Git itself [SFC-BNAMING]_ and in Git hosting solutions such as
+GitHub [GH-BRANCHES]_.
+
+Decision
+--------
+
+RDFLib's
+default branch will be renamed from ``master`` to ``main``. This is primarily to stay in line with modern conventions and to adhere to the principle of least surprise.
+
+Consequences
+------------
+
+Anticipated negative consequences:
+
+* Some links to old code will be broken.
+* Some people's workflow may break unexpectedly and need adjusting.
+* Any code and systems reliant on the old default branch name will fail.
+
+Anticipated positive consequences:
+
+* It will become a bit easier to work with RDFLib for developers that are used
+ to ``main`` as the default branch.
+
+References
+----------
+
+.. [GH-BRANCHES] `GitHub: About the default branch
+ <https://docs.github.com/en/pull-requests/collaborating-with-pull-requests/proposing-changes-to-your-work-with-pull-requests/about-branches#about-the-default-branch>`_
+.. [SFC-BNAMING] `Regarding Git and Branch Naming
+ <https://sfconservancy.org/news/2020/jun/23/gitbranchname/>`_
diff --git a/docs/decisions/index.rst b/docs/decisions/index.rst
new file mode 100644
index 00000000..39d02ccc
--- /dev/null
+++ b/docs/decisions/index.rst
@@ -0,0 +1,69 @@
+.. _decision_records: Decision Records
+
+Decision Records
+================
+
+To ensure that significant changes to RDFLib are made with sufficient consultation,
+consideration and planning they should be preceded by a decision record that
+captures the particulars of the decision that lead to the change.
+
+Decision records present the users and maintainers of RDFLib with an opportunity
+to review decisions before effort is expended to implement the decision in code,
+and it also makes it possible to review decisions without having to reconstruct
+them from the code changes that implement them.
+
+Whether a change is significant is hard to measure objectively, but some
+characteristics that may indicate that a change is significant include:
+
+* It will require changes to code that use RDFLib.
+* It cannot be reversed without requiring changes to code that use
+ RDFLib.
+* It is onerous to reverse later.
+* It increases the maintenance burden of RDFLib.
+* It is very large.
+
+Some of these characteristics are not binary but measured in degrees, so some
+discretion is required when determining if an architectural decision record is
+appropriate.
+
+Decision records may also be used for changes that do not have any of the listed
+characteristics if a decision record would be otherwise helpful, for example to
+capture a decision to change the maintenance process of RDFLib.
+
+Changes not preceded by decision records won't be rejected solely on this basis
+even if they are deemed significant, and decision records may also be created
+retrospectively for changes.
+
+Decision records as described here are similar to the concept of `Architectural
+Decision Records <https://adr.github.io/>`_, though it is slightly broader as it
+could include decisions which are not classified as architectural.
+
+Creating a decision record
+--------------------------
+
+Decision records should be added to the RDFLib repository in the
+``./docs/decisions/`` directory with a name ``{YYYYmmdd}-{title}.rst``.
+
+The content of the decision record should succinctly describe the context of the
+decision, the decision itself, and the status of the decision.
+
+Decision records should preferably follow `Michael Nygard decision record
+template
+<https://github.com/joelparkerhenderson/architecture-decision-record/blob/main/templates/decision-record-template-by-michael-nygard/index.md>`_
+that he described in a `2011 article
+<https://cognitect.com/blog/2011/11/15/documenting-architecture-decisions.html>`_
+on documenting architecture decisions.
+
+For questions about decision records please reach out to the RDFLib maintainers
+and community using the options given in :ref:`further_help_and_contact`.
+
+
+Decision list
+-------------
+
+.. toctree::
+ :glob:
+
+ 20*-*
+
+ \ No newline at end of file
diff --git a/docs/developers.rst b/docs/developers.rst
index 0ed3c3b8..08cd627b 100644
--- a/docs/developers.rst
+++ b/docs/developers.rst
@@ -54,7 +54,7 @@ PRs if possible. No PR is too small.
For PRs that introduce breaking changes, it is even more critical that they are
limited in size and scope, as they will likely have to be kept up to date with
-the master branch of this project for some time before they are merged.
+the ``main`` branch of this project for some time before they are merged.
It is also critical that your PR is understandable both in what it does and why
it does it, and how the change will impact the users of this project, for this
diff --git a/docs/gettingstarted.rst b/docs/gettingstarted.rst
index b8541ef3..ec657376 100644
--- a/docs/gettingstarted.rst
+++ b/docs/gettingstarted.rst
@@ -17,12 +17,12 @@ The best way to install RDFLib is to use ``pip`` (sudo as required):
$ pip install rdflib
-If you want the latest code to run, clone the master branch of the GitHub repo and use that or you can ``pip install``
+If you want the latest code to run, clone the ``main`` branch of the GitHub repo and use that or you can ``pip install``
directly from GitHub:
.. code-block :: bash
- $ pip install git+https://github.com/RDFLib/rdflib.git@master#egg=rdflib
+ $ pip install git+https://github.com/RDFLib/rdflib.git@main#egg=rdflib
Support
diff --git a/docs/index.rst b/docs/index.rst
index 4e1f3468..6a265dd2 100644
--- a/docs/index.rst
+++ b/docs/index.rst
@@ -1,4 +1,4 @@
-.. rdflib documentation documentation master file
+.. rdflib documentation documentation main file
================
rdflib |release|
@@ -89,6 +89,7 @@ For developers
persisting_n3_terms
type_hints
CONTRIBUTING
+ decisions/index
Source Code
-----------
@@ -99,14 +100,20 @@ The RDFlib organisation on GitHub at `<https://github.com/RDFLib>`__ maintains t
and RDFlib-related packaged that you might also find useful.
+.. _further_help_and_contact:
+
Further help & Contact
----------------------
-If you would like more help with using rdflib, rather than developing it, please post a question on StackOverflow using
-the tag ``[rdflib]``. A list of existing ``[rdflib]`` tagged questions is kept there at:
-
-* `<https://stackoverflow.com/questions/tagged/rdflib>`__
+If you would like help with using RDFlib, rather than developing it, please post
+a question on StackOverflow using the tag ``[rdflib]``. A list of existing
+``[rdflib]`` tagged questions can be found
+`here <https://stackoverflow.com/questions/tagged/rdflib>`_.
-You might also like to join rdflib's dev mailing list: `<https://groups.google.com/group/rdflib-dev>`__
+You might also like to join RDFlib's `dev mailing list
+<https://groups.google.com/group/rdflib-dev>`_ or use RDFLib's `GitHub
+discussions section <https://github.com/RDFLib/rdflib/discussions>`_.
-The chat is available at `gitter <https://gitter.im/RDFLib/rdflib>`_ or via matrix `#RDFLib_rdflib:gitter.im <https://matrix.to/#/#RDFLib_rdflib:gitter.im>`_.
+The chat is available at `gitter <https://gitter.im/RDFLib/rdflib>`_ or via
+matrix `#RDFLib_rdflib:gitter.im
+<https://matrix.to/#/#RDFLib_rdflib:gitter.im>`_.
diff --git a/docs/upgrade4to5.rst b/docs/upgrade4to5.rst
index 1859ff1a..f6ae19a1 100644
--- a/docs/upgrade4to5.rst
+++ b/docs/upgrade4to5.rst
@@ -211,56 +211,3 @@ Documentation Fixes:
`PR #417 <https://github.com/RDFLib/rdflib/pull/417>`_
* Custom FILTER function for SPARQL engine
`ISSUE #274 <https://github.com/RDFLib/rdflib/issues/274>`_
-
-Code Quality and Cleanups:
-^^^^^^^^^^^^^^^^^^^^^^^^^^
-* a slightly opinionated autopep8 run
- `PR #870 <https://github.com/RDFLib/rdflib/pull/870>`_
-* remove rdfa and microdata parsers from core RDFLib
- `PR #828 <https://github.com/RDFLib/rdflib/pull/828>`_
-* ClosedNamespace KeyError -> AttributeError
- `PR #827 <https://github.com/RDFLib/rdflib/pull/827>`_
-* typo in rdflib/plugins/sparql/update.py
- `ISSUE #760 <https://github.com/RDFLib/rdflib/issues/760>`_
-* Fix logging in interactive mode
- `PR #731 <https://github.com/RDFLib/rdflib/pull/731>`_
-* make namespace module flake8-compliant, change exceptions in that mod…
- `PR #711 <https://github.com/RDFLib/rdflib/pull/711>`_
-* delete ez_setup.py?
- `ISSUE #669 <https://github.com/RDFLib/rdflib/issues/669>`_
-* code duplication issue between rdflib and pymicrodata
- `ISSUE #582 <https://github.com/RDFLib/rdflib/issues/582>`_
-* Transition from 2to3 to use of six.py to be merged in 5.0.0-dev
- `PR #519 <https://github.com/RDFLib/rdflib/pull/519>`_
-* sparqlstore drop deprecated methods and args
- `PR #516 <https://github.com/RDFLib/rdflib/pull/516>`_
-* python3 code seems shockingly inefficient
- `ISSUE #440 <https://github.com/RDFLib/rdflib/issues/440>`_
-* removed md5_term_hash, fixes #240
- `PR #439 <https://github.com/RDFLib/rdflib/pull/439>`_
- `ISSUE #240 <https://github.com/RDFLib/rdflib/issues/240>`_
-
-Testing:
-^^^^^^^^
-* 3.7 for travis
- `PR #864 <https://github.com/RDFLib/rdflib/pull/864>`_
-* Added trig unit tests to highlight some current parsing/serializing issues
- `PR #431 <https://github.com/RDFLib/rdflib/pull/431>`_
-
-Documentation Fixes:
-^^^^^^^^^^^^^^^^^^^^
-* Fix a doc string in the query module
- `PR #976 <https://github.com/RDFLib/rdflib/pull/976>`_
-* setup.py: Make the license field use an SPDX identifier
- `PR #789 <https://github.com/RDFLib/rdflib/pull/789>`_
-* Update README.md
- `PR #764 <https://github.com/RDFLib/rdflib/pull/764>`_
-* Update namespaces_and_bindings.rst
- `PR #757 <https://github.com/RDFLib/rdflib/pull/757>`_
-* DOC: README.md: rdflib-jsonld, https uris
- `PR #712 <https://github.com/RDFLib/rdflib/pull/712>`_
-* make doctest support py2/py3
- `ISSUE #707 <https://github.com/RDFLib/rdflib/issues/707>`_
-* ``pip install rdflib`` (as per README.md) gets OSError on Mint 18.1
- `ISSUE #704 <https://github.com/RDFLib/rdflib/issues/704>`_
-
diff --git a/test/data/suites/rdflib/sparql/manifest.ttl b/test/data/suites/rdflib/sparql/manifest.ttl
index bb8e2b8a..d217a886 100644
--- a/test/data/suites/rdflib/sparql/manifest.ttl
+++ b/test/data/suites/rdflib/sparql/manifest.ttl
@@ -5,7 +5,7 @@
@prefix dawgt: <http://www.w3.org/2001/sw/DataAccess/tests/test-dawg#> .
-@prefix : <http://raw.github.com/RDFLib/rdflib/master/test/data/suites/rdflib/sparql/manifest.ttl#> .
+@prefix : <http://raw.github.com/RDFLib/rdflib/main/test/data/suites/rdflib/sparql/manifest.ttl#> .
<> a mf:Manifest ;
rdfs:label "RDFLib Extra SPARQL tests" ;
diff --git a/test/test_w3c_spec/test_sparql_rdflib.py b/test/test_w3c_spec/test_sparql_rdflib.py
index 496d5eda..2a278461 100644
--- a/test/test_w3c_spec/test_sparql_rdflib.py
+++ b/test/test_w3c_spec/test_sparql_rdflib.py
@@ -17,7 +17,7 @@ import pytest
from pytest import MonkeyPatch
REMOTE_BASE_IRI = (
- "http://raw.github.com/RDFLib/rdflib/master/test/data/suites/rdflib/sparql/"
+ "http://raw.github.com/RDFLib/rdflib/main/test/data/suites/rdflib/sparql/"
)
LOCAL_BASE_DIR = TEST_DATA_DIR / "suites/rdflib/sparql/"
MAPPER = URIMapper.from_mappings(
diff --git a/test_reports/rdflib_sparql-HEAD.ttl b/test_reports/rdflib_sparql-HEAD.ttl
index f030a100..ee34f3c8 100644
--- a/test_reports/rdflib_sparql-HEAD.ttl
+++ b/test_reports/rdflib_sparql-HEAD.ttl
@@ -13,7 +13,7 @@
earl:result [ a earl:TestResult ;
earl:outcome earl:passed ] ;
earl:subject <https://github.com/RDFLib/rdflib> ;
- earl:test <http://raw.github.com/RDFLib/rdflib/master/test/data/suites/rdflib/sparql/manifest.ttl#bindscope> .
+ earl:test <http://raw.github.com/RDFLib/rdflib/main/test/data/suites/rdflib/sparql/manifest.ttl#bindscope> .
[] a earl:Assertion ;
earl:assertedBy <https://github.com/RDFLib/rdflib> ;
@@ -21,7 +21,7 @@
earl:result [ a earl:TestResult ;
earl:outcome earl:passed ] ;
earl:subject <https://github.com/RDFLib/rdflib> ;
- earl:test <http://raw.github.com/RDFLib/rdflib/master/test/data/suites/rdflib/sparql/manifest.ttl#bindscope2> .
+ earl:test <http://raw.github.com/RDFLib/rdflib/main/test/data/suites/rdflib/sparql/manifest.ttl#bindscope2> .
[] a earl:Assertion ;
earl:assertedBy <https://github.com/RDFLib/rdflib> ;
@@ -29,7 +29,7 @@
earl:result [ a earl:TestResult ;
earl:outcome earl:passed ] ;
earl:subject <https://github.com/RDFLib/rdflib> ;
- earl:test <http://raw.github.com/RDFLib/rdflib/master/test/data/suites/rdflib/sparql/manifest.ttl#bnode-ppath-mix-a> .
+ earl:test <http://raw.github.com/RDFLib/rdflib/main/test/data/suites/rdflib/sparql/manifest.ttl#bnode-ppath-mix-a> .
[] a earl:Assertion ;
earl:assertedBy <https://github.com/RDFLib/rdflib> ;
@@ -37,7 +37,7 @@
earl:result [ a earl:TestResult ;
earl:outcome earl:passed ] ;
earl:subject <https://github.com/RDFLib/rdflib> ;
- earl:test <http://raw.github.com/RDFLib/rdflib/master/test/data/suites/rdflib/sparql/manifest.ttl#bnode-ppath-mix-b> .
+ earl:test <http://raw.github.com/RDFLib/rdflib/main/test/data/suites/rdflib/sparql/manifest.ttl#bnode-ppath-mix-b> .
[] a earl:Assertion ;
earl:assertedBy <https://github.com/RDFLib/rdflib> ;
@@ -45,7 +45,7 @@
earl:result [ a earl:TestResult ;
earl:outcome earl:passed ] ;
earl:subject <https://github.com/RDFLib/rdflib> ;
- earl:test <http://raw.github.com/RDFLib/rdflib/master/test/data/suites/rdflib/sparql/manifest.ttl#bnode-ppath-mix-c> .
+ earl:test <http://raw.github.com/RDFLib/rdflib/main/test/data/suites/rdflib/sparql/manifest.ttl#bnode-ppath-mix-c> .
[] a earl:Assertion ;
earl:assertedBy <https://github.com/RDFLib/rdflib> ;
@@ -53,7 +53,7 @@
earl:result [ a earl:TestResult ;
earl:outcome earl:passed ] ;
earl:subject <https://github.com/RDFLib/rdflib> ;
- earl:test <http://raw.github.com/RDFLib/rdflib/master/test/data/suites/rdflib/sparql/manifest.ttl#bnode-ppath-mix-d> .
+ earl:test <http://raw.github.com/RDFLib/rdflib/main/test/data/suites/rdflib/sparql/manifest.ttl#bnode-ppath-mix-d> .
[] a earl:Assertion ;
earl:assertedBy <https://github.com/RDFLib/rdflib> ;
@@ -61,7 +61,7 @@
earl:result [ a earl:TestResult ;
earl:outcome earl:passed ] ;
earl:subject <https://github.com/RDFLib/rdflib> ;
- earl:test <http://raw.github.com/RDFLib/rdflib/master/test/data/suites/rdflib/sparql/manifest.ttl#bnode-ppath-mix-e> .
+ earl:test <http://raw.github.com/RDFLib/rdflib/main/test/data/suites/rdflib/sparql/manifest.ttl#bnode-ppath-mix-e> .
[] a earl:Assertion ;
earl:assertedBy <https://github.com/RDFLib/rdflib> ;
@@ -69,7 +69,7 @@
earl:result [ a earl:TestResult ;
earl:outcome earl:passed ] ;
earl:subject <https://github.com/RDFLib/rdflib> ;
- earl:test <http://raw.github.com/RDFLib/rdflib/master/test/data/suites/rdflib/sparql/manifest.ttl#bnode-ppath-mix-f> .
+ earl:test <http://raw.github.com/RDFLib/rdflib/main/test/data/suites/rdflib/sparql/manifest.ttl#bnode-ppath-mix-f> .
[] a earl:Assertion ;
earl:assertedBy <https://github.com/RDFLib/rdflib> ;
@@ -77,7 +77,7 @@
earl:result [ a earl:TestResult ;
earl:outcome earl:passed ] ;
earl:subject <https://github.com/RDFLib/rdflib> ;
- earl:test <http://raw.github.com/RDFLib/rdflib/master/test/data/suites/rdflib/sparql/manifest.ttl#bnode-ppath-mix-g> .
+ earl:test <http://raw.github.com/RDFLib/rdflib/main/test/data/suites/rdflib/sparql/manifest.ttl#bnode-ppath-mix-g> .
[] a earl:Assertion ;
earl:assertedBy <https://github.com/RDFLib/rdflib> ;
@@ -85,7 +85,7 @@
earl:result [ a earl:TestResult ;
earl:outcome earl:passed ] ;
earl:subject <https://github.com/RDFLib/rdflib> ;
- earl:test <http://raw.github.com/RDFLib/rdflib/master/test/data/suites/rdflib/sparql/manifest.ttl#bnode-ppath-mix-h> .
+ earl:test <http://raw.github.com/RDFLib/rdflib/main/test/data/suites/rdflib/sparql/manifest.ttl#bnode-ppath-mix-h> .
[] a earl:Assertion ;
earl:assertedBy <https://github.com/RDFLib/rdflib> ;
@@ -93,7 +93,7 @@
earl:result [ a earl:TestResult ;
earl:outcome earl:passed ] ;
earl:subject <https://github.com/RDFLib/rdflib> ;
- earl:test <http://raw.github.com/RDFLib/rdflib/master/test/data/suites/rdflib/sparql/manifest.ttl#filteroptional> .
+ earl:test <http://raw.github.com/RDFLib/rdflib/main/test/data/suites/rdflib/sparql/manifest.ttl#filteroptional> .
[] a earl:Assertion ;
earl:assertedBy <https://github.com/RDFLib/rdflib> ;
@@ -101,7 +101,7 @@
earl:result [ a earl:TestResult ;
earl:outcome earl:passed ] ;
earl:subject <https://github.com/RDFLib/rdflib> ;
- earl:test <http://raw.github.com/RDFLib/rdflib/master/test/data/suites/rdflib/sparql/manifest.ttl#filtersubquery1> .
+ earl:test <http://raw.github.com/RDFLib/rdflib/main/test/data/suites/rdflib/sparql/manifest.ttl#filtersubquery1> .
[] a earl:Assertion ;
earl:assertedBy <https://github.com/RDFLib/rdflib> ;
@@ -109,7 +109,7 @@
earl:result [ a earl:TestResult ;
earl:outcome earl:passed ] ;
earl:subject <https://github.com/RDFLib/rdflib> ;
- earl:test <http://raw.github.com/RDFLib/rdflib/master/test/data/suites/rdflib/sparql/manifest.ttl#filtersubquery2> .
+ earl:test <http://raw.github.com/RDFLib/rdflib/main/test/data/suites/rdflib/sparql/manifest.ttl#filtersubquery2> .
[] a earl:Assertion ;
earl:assertedBy <https://github.com/RDFLib/rdflib> ;
@@ -117,7 +117,7 @@
earl:result [ a earl:TestResult ;
earl:outcome earl:passed ] ;
earl:subject <https://github.com/RDFLib/rdflib> ;
- earl:test <http://raw.github.com/RDFLib/rdflib/master/test/data/suites/rdflib/sparql/manifest.ttl#filtersubquery3> .
+ earl:test <http://raw.github.com/RDFLib/rdflib/main/test/data/suites/rdflib/sparql/manifest.ttl#filtersubquery3> .
[] a earl:Assertion ;
earl:assertedBy <https://github.com/RDFLib/rdflib> ;
@@ -125,7 +125,7 @@
earl:result [ a earl:TestResult ;
earl:outcome earl:passed ] ;
earl:subject <https://github.com/RDFLib/rdflib> ;
- earl:test <http://raw.github.com/RDFLib/rdflib/master/test/data/suites/rdflib/sparql/manifest.ttl#minusfilter> .
+ earl:test <http://raw.github.com/RDFLib/rdflib/main/test/data/suites/rdflib/sparql/manifest.ttl#minusfilter> .
[] a earl:Assertion ;
earl:assertedBy <https://github.com/RDFLib/rdflib> ;
@@ -133,7 +133,7 @@
earl:result [ a earl:TestResult ;
earl:outcome earl:passed ] ;
earl:subject <https://github.com/RDFLib/rdflib> ;
- earl:test <http://raw.github.com/RDFLib/rdflib/master/test/data/suites/rdflib/sparql/manifest.ttl#nestedbnode> .
+ earl:test <http://raw.github.com/RDFLib/rdflib/main/test/data/suites/rdflib/sparql/manifest.ttl#nestedbnode> .
[] a earl:Assertion ;
earl:assertedBy <https://github.com/RDFLib/rdflib> ;
@@ -141,7 +141,7 @@
earl:result [ a earl:TestResult ;
earl:outcome earl:passed ] ;
earl:subject <https://github.com/RDFLib/rdflib> ;
- earl:test <http://raw.github.com/RDFLib/rdflib/master/test/data/suites/rdflib/sparql/manifest.ttl#notexistsfilter> .
+ earl:test <http://raw.github.com/RDFLib/rdflib/main/test/data/suites/rdflib/sparql/manifest.ttl#notexistsfilter> .
[] a earl:Assertion ;
earl:assertedBy <https://github.com/RDFLib/rdflib> ;
@@ -149,7 +149,7 @@
earl:result [ a earl:TestResult ;
earl:outcome earl:passed ] ;
earl:subject <https://github.com/RDFLib/rdflib> ;
- earl:test <http://raw.github.com/RDFLib/rdflib/master/test/data/suites/rdflib/sparql/manifest.ttl#subquery1> .
+ earl:test <http://raw.github.com/RDFLib/rdflib/main/test/data/suites/rdflib/sparql/manifest.ttl#subquery1> .
[] a earl:Assertion ;
earl:assertedBy <https://github.com/RDFLib/rdflib> ;
@@ -157,7 +157,7 @@
earl:result [ a earl:TestResult ;
earl:outcome earl:passed ] ;
earl:subject <https://github.com/RDFLib/rdflib> ;
- earl:test <http://raw.github.com/RDFLib/rdflib/master/test/data/suites/rdflib/sparql/manifest.ttl#subquery2> .
+ earl:test <http://raw.github.com/RDFLib/rdflib/main/test/data/suites/rdflib/sparql/manifest.ttl#subquery2> .
[] a earl:Assertion ;
earl:assertedBy <https://github.com/RDFLib/rdflib> ;
@@ -165,7 +165,7 @@
earl:result [ a earl:TestResult ;
earl:outcome earl:passed ] ;
earl:subject <https://github.com/RDFLib/rdflib> ;
- earl:test <http://raw.github.com/RDFLib/rdflib/master/test/data/suites/rdflib/sparql/manifest.ttl#subquery3> .
+ earl:test <http://raw.github.com/RDFLib/rdflib/main/test/data/suites/rdflib/sparql/manifest.ttl#subquery3> .
[] a earl:Assertion ;
earl:assertedBy <https://github.com/RDFLib/rdflib> ;
@@ -173,7 +173,7 @@
earl:result [ a earl:TestResult ;
earl:outcome earl:passed ] ;
earl:subject <https://github.com/RDFLib/rdflib> ;
- earl:test <http://raw.github.com/RDFLib/rdflib/master/test/data/suites/rdflib/sparql/manifest.ttl#subqueryagg1> .
+ earl:test <http://raw.github.com/RDFLib/rdflib/main/test/data/suites/rdflib/sparql/manifest.ttl#subqueryagg1> .
[] a earl:Assertion ;
earl:assertedBy <https://github.com/RDFLib/rdflib> ;
@@ -181,7 +181,7 @@
earl:result [ a earl:TestResult ;
earl:outcome earl:passed ] ;
earl:subject <https://github.com/RDFLib/rdflib> ;
- earl:test <http://raw.github.com/RDFLib/rdflib/master/test/data/suites/rdflib/sparql/manifest.ttl#subqueryagg2> .
+ earl:test <http://raw.github.com/RDFLib/rdflib/main/test/data/suites/rdflib/sparql/manifest.ttl#subqueryagg2> .
[] a earl:Assertion ;
earl:assertedBy <https://github.com/RDFLib/rdflib> ;
@@ -189,7 +189,7 @@
earl:result [ a earl:TestResult ;
earl:outcome earl:passed ] ;
earl:subject <https://github.com/RDFLib/rdflib> ;
- earl:test <http://raw.github.com/RDFLib/rdflib/master/test/data/suites/rdflib/sparql/manifest.ttl#test-codepoint-escape-01> .
+ earl:test <http://raw.github.com/RDFLib/rdflib/main/test/data/suites/rdflib/sparql/manifest.ttl#test-codepoint-escape-01> .
[] a earl:Assertion ;
earl:assertedBy <https://github.com/RDFLib/rdflib> ;
@@ -197,7 +197,7 @@
earl:result [ a earl:TestResult ;
earl:outcome earl:failed ] ;
earl:subject <https://github.com/RDFLib/rdflib> ;
- earl:test <http://raw.github.com/RDFLib/rdflib/master/test/data/suites/rdflib/sparql/manifest.ttl#test-codepoint-escape-02> .
+ earl:test <http://raw.github.com/RDFLib/rdflib/main/test/data/suites/rdflib/sparql/manifest.ttl#test-codepoint-escape-02> .
[] a earl:Assertion ;
earl:assertedBy <https://github.com/RDFLib/rdflib> ;
@@ -205,7 +205,7 @@
earl:result [ a earl:TestResult ;
earl:outcome earl:failed ] ;
earl:subject <https://github.com/RDFLib/rdflib> ;
- earl:test <http://raw.github.com/RDFLib/rdflib/master/test/data/suites/rdflib/sparql/manifest.ttl#test-codepoint-escape-03> .
+ earl:test <http://raw.github.com/RDFLib/rdflib/main/test/data/suites/rdflib/sparql/manifest.ttl#test-codepoint-escape-03> .
[] a earl:Assertion ;
earl:assertedBy <https://github.com/RDFLib/rdflib> ;
@@ -213,7 +213,7 @@
earl:result [ a earl:TestResult ;
earl:outcome earl:failed ] ;
earl:subject <https://github.com/RDFLib/rdflib> ;
- earl:test <http://raw.github.com/RDFLib/rdflib/master/test/data/suites/rdflib/sparql/manifest.ttl#test-codepoint-escape-04> .
+ earl:test <http://raw.github.com/RDFLib/rdflib/main/test/data/suites/rdflib/sparql/manifest.ttl#test-codepoint-escape-04> .
[] a earl:Assertion ;
earl:assertedBy <https://github.com/RDFLib/rdflib> ;
@@ -221,7 +221,7 @@
earl:result [ a earl:TestResult ;
earl:outcome earl:failed ] ;
earl:subject <https://github.com/RDFLib/rdflib> ;
- earl:test <http://raw.github.com/RDFLib/rdflib/master/test/data/suites/rdflib/sparql/manifest.ttl#test-codepoint-escape-bad> .
+ earl:test <http://raw.github.com/RDFLib/rdflib/main/test/data/suites/rdflib/sparql/manifest.ttl#test-codepoint-escape-bad> .
[] a earl:Assertion ;
earl:assertedBy <https://github.com/RDFLib/rdflib> ;
@@ -229,7 +229,7 @@
earl:result [ a earl:TestResult ;
earl:outcome earl:passed ] ;
earl:subject <https://github.com/RDFLib/rdflib> ;
- earl:test <http://raw.github.com/RDFLib/rdflib/master/test/data/suites/rdflib/sparql/manifest.ttl#unicode> .
+ earl:test <http://raw.github.com/RDFLib/rdflib/main/test/data/suites/rdflib/sparql/manifest.ttl#unicode> .
[] a earl:Assertion ;
earl:assertedBy <https://github.com/RDFLib/rdflib> ;
@@ -237,5 +237,5 @@
earl:result [ a earl:TestResult ;
earl:outcome earl:passed ] ;
earl:subject <https://github.com/RDFLib/rdflib> ;
- earl:test <http://raw.github.com/RDFLib/rdflib/master/test/data/suites/rdflib/sparql/manifest.ttl#whitespacedot> .
+ earl:test <http://raw.github.com/RDFLib/rdflib/main/test/data/suites/rdflib/sparql/manifest.ttl#whitespacedot> .