summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorIwan Aucamp <aucampia@gmail.com>2022-05-15 15:03:38 +0200
committerGitHub <noreply@github.com>2022-05-15 15:03:38 +0200
commitd5d354f765151589cadeb723b4a946cc405fdc9f (patch)
tree20f9abff5d4fae562c7cb71dd297bb32158e3e89 /pyproject.toml
parent70abb7d56a06e42828f6c235490415e349169f30 (diff)
downloadrdflib-d5d354f765151589cadeb723b4a946cc405fdc9f.tar.gz
feat: add typing for `rdflib/plugins/sparql` (#1926)
This patch adds typing to two files and changes imports so that they are more specific to the module in which classes are defined. This patch contains no runtime changes. I'm adding this to make it easier to spot bugs in new PRs to SPARQL code. Also: * Disable some pep8-naming errors for `rdflib/plugins/sparql/*`
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml11
1 files changed, 10 insertions, 1 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 5ee2a25b..3d400e56 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -14,7 +14,16 @@ pyflakes = [
"+*",
]
pep8-naming = ["+*"]
-"flake8-*" = ["+*"]
+
+[tool.flakeheaven.exceptions."rdflib/plugins/sparql/*"]
+pep8-naming = [
+ "-N802",
+ "-N803",
+ "-N806",
+ "-N812",
+ "-N816",
+ "-N801",
+]
[tool.black]