summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorbescoto <bescoto@2b77aa54-bcbc-44c9-a7ec-4f6cf2b41109>2003-08-08 21:52:55 +0000
committerbescoto <bescoto@2b77aa54-bcbc-44c9-a7ec-4f6cf2b41109>2003-08-08 21:52:55 +0000
commitf7a9124f2a4c50d872941da83768b988ae419669 (patch)
tree2175dbfe125adfb9382bbc0c2de2b097da69a650
parent2b45f542a5fa4145674b9380bfacd284e8d03d8e (diff)
downloadrdiff-backup-f7a9124f2a4c50d872941da83768b988ae419669.tar.gz
Changes for librsync 0.9.6
git-svn-id: http://svn.savannah.nongnu.org/svn/rdiff-backup/trunk@384 2b77aa54-bcbc-44c9-a7ec-4f6cf2b41109
-rw-r--r--rdiff-backup/CHANGELOG11
-rwxr-xr-xrdiff-backup/dist/makerpm10
-rw-r--r--rdiff-backup/dist/rdiff-backup.spec.template11
-rw-r--r--rdiff-backup/rdiff_backup/_librsyncmodule.c2
4 files changed, 20 insertions, 14 deletions
diff --git a/rdiff-backup/CHANGELOG b/rdiff-backup/CHANGELOG
index 460c05f..23d3d34 100644
--- a/rdiff-backup/CHANGELOG
+++ b/rdiff-backup/CHANGELOG
@@ -1,8 +1,6 @@
New in v0.13.1 (2003/08/??)
---------------------------
-Patch by Arkadiusz Patyk fixes building with Python 2.3c1.
-
Restore of archives made by 0.10.x and earlier fixed, although hard
link information is not restored unless it is current in the mirror.
(Bug reported by Jeff Lessem.)
@@ -16,8 +14,13 @@ Patch by Jeffrey Marshall fixes socket/fifo recognition on Mac OS X
Patch by Jeffrey Marshall fixes --calculate-average mode, which seems
to have broken recently.
-rdiff-backup should now work with python 2.3. Thanks to Arkadiusz
-Miskiewicz for bug reports.
+rdiff-backup should now work and build with python 2.3. Thanks to
+Arkadiusz Miskiewicz and Arkadiusz Patyk for bug reports and a patch.
+
+rdiff-backup now builds and requires librsync 0.9.6. This version
+should be much better than the old one and everyone should probably
+upgrade. Much thanks to Donovan Baarda for all the work that went
+into this release.
New in v0.13.0 (2003/07/22)
diff --git a/rdiff-backup/dist/makerpm b/rdiff-backup/dist/makerpm
index 129cbed..a09aec8 100755
--- a/rdiff-backup/dist/makerpm
+++ b/rdiff-backup/dist/makerpm
@@ -1,20 +1,20 @@
#!/usr/bin/env python
-import os, sys, re
+import os, sys
-rpmroot = "/home/ben/rpm"
+rpmroot = os.path.join(os.environ['HOME'], 'rpm')
if len(sys.argv) == 2:
- version = sys.argv[1]
+ Version = sys.argv[1]
specfile = "rdiff-backup.spec"
print "Using specfile %s" % specfile
else:
print "Syntax: %s version_number" % sys.argv[0]
sys.exit(1)
-base = "rdiff-backup-%s" % (version,)
+base = "rdiff-backup-%s" % (Version,)
tarfile = base + ".tar.gz"
-rpmbase = base + "-0.fdr.1" # Fedora suffix, with release number 1
+rpmbase = base + "-0.fdr.3" # Fedora suffix, with release number 1
i386_rpm = rpmbase + ".i386.rpm"
source_rpm = rpmbase + ".src.rpm"
diff --git a/rdiff-backup/dist/rdiff-backup.spec.template b/rdiff-backup/dist/rdiff-backup.spec.template
index 0249336..28cbf51 100644
--- a/rdiff-backup/dist/rdiff-backup.spec.template
+++ b/rdiff-backup/dist/rdiff-backup.spec.template
@@ -3,15 +3,15 @@
Version: $version
Summary: Convenient and transparent local/remote incremental mirror/backup
Name: rdiff-backup
-Release: 0.fdr.1
+Release: 0.fdr.3
Epoch: 0
URL: http://rdiff-backup.stanford.edu/
-Source: http://rdiff-backup.stanford.edu/%{name}-%{version}.tar.gz
+Source: http://rdiff-backup.stanford.edu/OLD/%{version}/%{name}-%{version}.tar.gz
License: GPL
Group: Applications/Archiving
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
-Requires: librsync >= 0.9.5.1, %{PYTHON_NAME} >= 2.2
-BuildPrereq: %{PYTHON_NAME}-devel >= 2.2, librsync-devel >= 0.9.5.1
+Requires: librsync >= 0.9.6, %{PYTHON_NAME} >= 2.2
+BuildPrereq: %{PYTHON_NAME}-devel >= 2.2, librsync-devel >= 0.9.6
%description
rdiff-backup is a script, written in Python, that backs up one
@@ -45,6 +45,9 @@ differences from the previous backup will be transmitted.
%doc CHANGELOG COPYING FAQ.html README
%changelog
+* Thu Aug 8 2003 Ben Escoto <bescoto@stanford.edu>
+- Set librsync >= 0.9.6, because rsync.h renamed to librsync.h
+
* Sun Jul 20 2003 Ben Escoto <bescoto@stanford.edu>
- Minor changes to comply with Fedora standards.
diff --git a/rdiff-backup/rdiff_backup/_librsyncmodule.c b/rdiff-backup/rdiff_backup/_librsyncmodule.c
index 92a31f0..d3aaf5c 100644
--- a/rdiff-backup/rdiff_backup/_librsyncmodule.c
+++ b/rdiff-backup/rdiff_backup/_librsyncmodule.c
@@ -22,7 +22,7 @@
* ----------------------------------------------------------------------- */
#include <Python.h>
-#include <rsync.h>
+#include <librsync.h>
#define RS_JOB_BLOCKSIZE 65536
static PyObject *librsyncError;