summaryrefslogtreecommitdiff
path: root/rdiff-backup/dist/rdiff-backup.spec.template
diff options
context:
space:
mode:
Diffstat (limited to 'rdiff-backup/dist/rdiff-backup.spec.template')
-rw-r--r--rdiff-backup/dist/rdiff-backup.spec.template23
1 files changed, 14 insertions, 9 deletions
diff --git a/rdiff-backup/dist/rdiff-backup.spec.template b/rdiff-backup/dist/rdiff-backup.spec.template
index 28cbf51..c0c2d96 100644
--- a/rdiff-backup/dist/rdiff-backup.spec.template
+++ b/rdiff-backup/dist/rdiff-backup.spec.template
@@ -1,17 +1,18 @@
-%define PYTHON_NAME %((rpm -q --quiet python2 && echo python2) || echo python)
+%define PYTHON_VERSION %(python -c 'import sys; sys.stdout.write(".".join(map(str,sys.version_info[:2])))')
+%define NEXT_PYTHON_VERSION %(python -c 'import sys; sys.stdout.write(str(sys.version_info[0])); sys.stdout.write("."); sys.stdout.write(str(sys.version_info[1]+1))')
Version: $version
Summary: Convenient and transparent local/remote incremental mirror/backup
Name: rdiff-backup
-Release: 0.fdr.3
+Release: 1
Epoch: 0
URL: http://rdiff-backup.stanford.edu/
Source: http://rdiff-backup.stanford.edu/OLD/%{version}/%{name}-%{version}.tar.gz
License: GPL
Group: Applications/Archiving
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
-Requires: librsync >= 0.9.6, %{PYTHON_NAME} >= 2.2
-BuildPrereq: %{PYTHON_NAME}-devel >= 2.2, librsync-devel >= 0.9.6
+Requires: python >= %{PYTHON_VERSION}, python < %{NEXT_PYTHON_VERSION}
+BuildPrereq: python-devel >= 2.2, librsync-devel >= 0.9.6
%description
rdiff-backup is a script, written in Python, that backs up one
@@ -29,22 +30,26 @@ differences from the previous backup will be transmitted.
%setup -q
%build
-%{PYTHON_NAME} setup.py build
+python setup.py build
%install
-%{PYTHON_NAME} setup.py install --prefix=$RPM_BUILD_ROOT/usr
+python setup.py install --root $RPM_BUILD_ROOT
%clean
-[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
+rm -rf $RPM_BUILD_ROOT
%files
%defattr(-,root,root)
%{_bindir}/rdiff-backup
%{_mandir}/man1/rdiff-backup*
-%{_libdir}/
-%doc CHANGELOG COPYING FAQ.html README
+%{_libdir}/python%{PYTHON_VERSION}/site-packages/rdiff_backup
+%doc CHANGELOG COPYING FAQ.html examples.html README
%changelog
+* Thu Sep 11 2003 Ben Escoto <bescoto@stanford.edu> - 0.12.4-1
+- Removed code that selected between python2 and python; I think
+ everyone calls it python now.
+
* Thu Aug 8 2003 Ben Escoto <bescoto@stanford.edu>
- Set librsync >= 0.9.6, because rsync.h renamed to librsync.h