summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChayim I. Kirshen <c@kirshen.com>2021-11-04 13:39:46 +0200
committerChayim I. Kirshen <c@kirshen.com>2021-11-04 13:39:46 +0200
commit9938cc0622c4d63962097b2aed6fdd714623e7d8 (patch)
tree0f3a67f4281d8ecb0807ae0229bd16cc38feaf03
parent3e9e2f27b74396793d37f87ce34612fbb6e00f14 (diff)
downloadredis-py-ck-publish-from-release.tar.gz
adding wheel supportck-publish-from-release
-rw-r--r--.github/workflows/pypi-publish.yaml8
1 files changed, 4 insertions, 4 deletions
diff --git a/.github/workflows/pypi-publish.yaml b/.github/workflows/pypi-publish.yaml
index 3b6e208..b842c36 100644
--- a/.github/workflows/pypi-publish.yaml
+++ b/.github/workflows/pypi-publish.yaml
@@ -1,6 +1,6 @@
name: Publish tag to Pypi
-on:
+on:
release:
types: [published]
@@ -17,15 +17,15 @@ jobs:
- name: Install dev tools
run: |
pip install -r dev_requirements.txt
- pip install twine
+ pip install twine wheel
- name: Build package
run: |
python setup.py build
- python setup.py dist
+ python setup.py dist bdist_wheel
- name: Publish to Pypi
uses: pypa/gh-action-pypi-publish@release/v1
with:
user: __token__
- password: ${{ secrets.PYPI_API_TOKEN }} \ No newline at end of file
+ password: ${{ secrets.PYPI_API_TOKEN }}