summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorandy <andy@whiskeymedia.com>2013-06-08 13:16:11 -0700
committerandy <andy@whiskeymedia.com>2013-06-08 13:16:11 -0700
commitfb61631253644a8b3394748bb9f4ade9cbdbf08e (patch)
tree43a3bb453fa25a5a1363a66e94a7cc59266b300b
parent7c69f35a83b30cc394bc019b71838dc909c39635 (diff)
downloadredis-py-pytest.tar.gz
updated tox config for pytestpytest
-rw-r--r--tox.ini39
1 files changed, 30 insertions, 9 deletions
diff --git a/tox.ini b/tox.ini
index e3602fd..2f1b1c6 100644
--- a/tox.ini
+++ b/tox.ini
@@ -2,23 +2,44 @@
envlist = py25, py26, py27, py32, py33, hi26, hi27, hi32, hi33, pep8
[testenv]
-commands = python setup.py test
+deps=pytest
+commands = py.test []
+downloadcache = {toxworkdir}/cache
+
+[testenv:py25]
+downloadcache = {toxworkdir}/cache
+setenv =
+ PIP_INSECURE=1
+deps =
+ pytest
[testenv:hi26]
-deps = hiredis
-commands = python setup.py test
+downloadcache = {toxworkdir}/cache
+deps =
+ hiredis
+ pytest
+commands = py.test []
[testenv:hi27]
-deps = hiredis
-commands = python setup.py test
+downloadcache = {toxworkdir}/cache
+deps =
+ hiredis
+ pytest
+commands = py.test []
[testenv:hi32]
-deps = hiredis
-commands = python setup.py test
+downloadcache = {toxworkdir}/cache
+deps =
+ hiredis
+ pytest
+commands = py.test []
[testenv:hi33]
-deps = hiredis
-commands = python setup.py test
+downloadcache = {toxworkdir}/cache
+deps =
+ hiredis
+ pytest
+commands = py.test []
[testenv:pep8]
deps = pep8