summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Dufresne <jon.dufresne@gmail.com>2020-04-04 09:05:54 -0700
committerJon Dufresne <jon.dufresne@gmail.com>2020-04-04 09:07:30 -0700
commit0f4ed59120221df99d916d13d52903a2c6b84ffa (patch)
tree324c48658949ffa02bad9d8ae324e1d7f2205ee7
parentd1279291d68c77709d69fe13aa7ff6d912d98ce4 (diff)
downloadredis-py-0f4ed59120221df99d916d13d52903a2c6b84ffa.tar.gz
Add testing and support for PyPy
-rw-r--r--.travis.yml8
-rw-r--r--CHANGES1
-rw-r--r--setup.py2
-rw-r--r--tox.ini2
4 files changed, 12 insertions, 1 deletions
diff --git a/.travis.yml b/.travis.yml
index 64351b9..702082e 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -23,6 +23,14 @@ matrix:
env: TOXENV=py38-plain
- python: 3.8
env: TOXENV=py38-hiredis
+ - python: pypy
+ env: TOXENV=pypy-plain
+ - python: pypy
+ env: TOXENV=pypy-hiredis
+ - python: pypy3
+ env: TOXENV=pypy3-plain
+ - python: pypy3
+ env: TOXENV=pypy3-hiredis
before_install:
- wget https://github.com/antirez/redis/archive/6.0-rc1.tar.gz && mkdir redis_install && tar -xvzf 6.0-rc1.tar.gz -C redis_install && cd redis_install/redis-6.0-rc1 && make && src/redis-server --daemonize yes && cd ../..
- redis-cli info
diff --git a/CHANGES b/CHANGES
index 3670f6f..4453ff2 100644
--- a/CHANGES
+++ b/CHANGES
@@ -26,6 +26,7 @@
default), Lock.extend() adds the `additional_time` to the lock's existing
TTL. When replace_ttl=True, the lock's existing TTL is replaced with
the value of `additional_time`.
+ * Add testing and support for PyPy.
* 3.4.1
* Move the username argument in the Redis and Connection classes to the
end of the argument list. This helps those poor souls that specify all
diff --git a/setup.py b/setup.py
index 4a435a4..d1f4e44 100644
--- a/setup.py
+++ b/setup.py
@@ -43,5 +43,7 @@ setup(
'Programming Language :: Python :: 3.6',
'Programming Language :: Python :: 3.7',
'Programming Language :: Python :: 3.8',
+ 'Programming Language :: Python :: Implementation :: CPython',
+ 'Programming Language :: Python :: Implementation :: PyPy',
]
)
diff --git a/tox.ini b/tox.ini
index 2d6e60a..6ead282 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,6 +1,6 @@
[tox]
minversion = 2.4
-envlist = {py27,py35,py36,py37,py38}-{plain,hiredis}, pycodestyle
+envlist = {py27,py35,py36,py37,py38,py,py3}-{plain,hiredis}, pycodestyle
[testenv]
deps =