summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoey Prat <roey.prat@redislabs.com>2018-10-03 17:20:51 +0300
committerRoey Prat <roey.prat@redislabs.com>2018-10-28 12:12:53 +0200
commitb5ffff6d151e83688bc6a49051cccd2fd5517407 (patch)
tree80f9a465d6f3bf3175a85c736884f88e6b4bf92c
parent9c90388944478aec4450a4ff4c5db5af77c08f54 (diff)
downloadredis-py-b5ffff6d151e83688bc6a49051cccd2fd5517407.tar.gz
pep8 was renamed to pycodestyle
-rw-r--r--.travis.yml8
-rw-r--r--setup.cfg2
-rw-r--r--tox.ini8
3 files changed, 9 insertions, 9 deletions
diff --git a/.travis.yml b/.travis.yml
index fcbdbb9..31c24f3 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -14,12 +14,12 @@ env:
- TEST_HIREDIS=1
install:
- pip install -e .
- - "if [[ $TEST_PEP8 == '1' ]]; then pip install pep8; fi"
+ - "if [[ $TEST_PYCODESTYLE == '1' ]]; then pip install pycodestyle; fi"
- "if [[ $TEST_HIREDIS == '1' ]]; then pip install hiredis; fi"
-script: "if [[ $TEST_PEP8 == '1' ]]; then pep8 --repeat --show-source --exclude=.venv,.tox,dist,docs,build,*.egg .; else python setup.py test; fi"
+script: "if [[ $TEST_PYCODESTYLE == '1' ]]; then pycodestyle --repeat --show-source --exclude=.venv,.tox,dist,docs,build,*.egg .; else python setup.py test; fi"
matrix:
include:
- python: "2.7"
- env: TEST_PEP8=1
+ env: TEST_PYCODESTYLE=1
- python: "3.6"
- env: TEST_PEP8=1
+ env: TEST_PYCODESTYLE=1
diff --git a/setup.cfg b/setup.cfg
index cdae7c4..089b37c 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -1,4 +1,4 @@
-[pep8]
+[pycodestyle]
show-source = 1
exclude = .venv,.tox,dist,docs,build,*.egg
diff --git a/tox.ini b/tox.ini
index a0945d2..16b7a50 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,6 +1,6 @@
[tox]
minversion = 1.8
-envlist = {py26,py27,py32,py33,py34,py35,py36}-{plain,hiredis}, pep8
+envlist = {py26,py27,py32,py33,py34,py35,py36}-{plain,hiredis}, pycodestyle
[testenv]
deps =
@@ -9,9 +9,9 @@ deps =
hiredis: hiredis >= 0.1.3
commands = py.test {posargs}
-[testenv:pep8]
+[testenv:pycodestyle]
basepython = python2.6
-deps = pep8
-commands = pep8
+deps = pycodestyle
+commands = pycodestyle
skipsdist = true
skip_install = true