summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorandymccurdy <sedrik@gmail.com>2010-02-15 13:08:56 -0800
committerandymccurdy <sedrik@gmail.com>2010-02-15 13:08:56 -0800
commit61c106e5fe5b9ab0380b29f60e245d4a318a2a06 (patch)
treeaff75b8e5c009412e77b344f5b008de5a43bdb9f /setup.py
parent33521a7d6cca8447fd885a61ffd812f634cf222c (diff)
downloadredis-py-61c106e5fe5b9ab0380b29f60e245d4a318a2a06.tar.gz
new client passes all command tests, still need tests for connection pool and pipelining.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py27
1 files changed, 10 insertions, 17 deletions
diff --git a/setup.py b/setup.py
index 4ecc27a..7ecf4ae 100644
--- a/setup.py
+++ b/setup.py
@@ -2,8 +2,8 @@
"""
@file setup.py
-@author Paul Hubbard
-@date 10/2/09
+@author Andy McCurdy
+@date 2/12/2010
@brief Setuptools configuration for redis client
"""
@@ -13,13 +13,17 @@ sdict = {
'name' : 'redis',
'version' : version,
'description' : 'Python client for Redis key-value store',
+ 'long_description' : 'Python client for Redis key-value store',
'url': 'http://github.com/andymccurdy/redis-py',
'download_url' : 'http://cloud.github.com/downloads/andymccurdy/redis-py/redis-%s.tar.gz' % version,
'author' : 'Andy McCurdy',
'author_email' : 'sedrik@gmail.com',
'maintainer' : 'Andy McCurdy',
'maintainer_email' : 'sedrik@gmail.com',
- 'keywords': ['Redis', 'key-value store'],
+ 'keywords' : ['Redis', 'key-value store'],
+ 'license' : 'MIT',
+ 'py_modules' : ['redis'],
+ 'test_suite' : 'tests.all_tests',
'classifiers' : [
'Development Status :: 4 - Beta',
'Environment :: Console',
@@ -33,17 +37,6 @@ try:
from setuptools import setup
except ImportError:
from distutils.core import setup
-#setup(**setupdict)
-setup(name=sdict['name'],
- version=sdict['version'],
- author=sdict['author'],
- author_email=sdict['author_email'],
- maintainer=sdict['maintainer'],
- maintainer_email=sdict['maintainer_email'],
- url=sdict['url'],
- classifiers=sdict['classifiers'],
- description=sdict['description'],
- long_description=sdict['description'],
- download_url=sdict['download_url'],
- license='MIT',
- py_modules = ['redis'])
+
+setup(**sdict)
+