summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--MANIFEST.in3
-rw-r--r--RELEASE9
-rw-r--r--docs/conf.py5
-rw-r--r--redis/__init__.py4
4 files changed, 7 insertions, 14 deletions
diff --git a/MANIFEST.in b/MANIFEST.in
index 7aaee12..97fa305 100644
--- a/MANIFEST.in
+++ b/MANIFEST.in
@@ -1,7 +1,6 @@
-include CHANGES
include INSTALL
include LICENSE
-include README.rst
+include README.md
exclude __pycache__
recursive-include tests *
recursive-exclude tests *.pyc
diff --git a/RELEASE b/RELEASE
deleted file mode 100644
index f45b0bf..0000000
--- a/RELEASE
+++ /dev/null
@@ -1,9 +0,0 @@
-Release Process
-===============
-
-1. Make sure all tests pass.
-2. Make sure CHANGES is up to date.
-3. Update redis.__init__.__version__ and commit
-4. git tag <version-number>
-5. git push --tag
-6. rm dist/* && python setup.py sdist bdist_wheel && twine upload dist/*
diff --git a/docs/conf.py b/docs/conf.py
index ff37119..f497e3d 100644
--- a/docs/conf.py
+++ b/docs/conf.py
@@ -46,14 +46,15 @@ master_doc = "index"
# General information about the project.
project = "redis-py"
-copyright = "2021, Redis Inc."
+copyright = "2021, Redis Inc"
# The version info for the project you're documenting, acts as replacement for
# |version| and |release|, also used in various other places throughout the
# built documents.
#
# The short X.Y version.
-version = "4.0.9"
+version = "4.0"
+
# The full version, including alpha/beta/rc tags.
release = "4.0.0"
diff --git a/redis/__init__.py b/redis/__init__.py
index c0dd690..5d63543 100644
--- a/redis/__init__.py
+++ b/redis/__init__.py
@@ -37,7 +37,9 @@ def int_or_str(value):
return value
-__version__ = '4.0.0rc2'
+__version__ = "4.0.0"
+
+
VERSION = tuple(map(int_or_str, __version__.split('.')))
__all__ = [