summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTres Seaver <tseaver@palladion.com>2017-09-07 00:50:29 -0400
committerTres Seaver <tseaver@palladion.com>2017-09-07 00:53:22 -0400
commit0ca02dad9b4adfba94a94f48527d642e35a0bf23 (patch)
tree9420e6672641cce23c5f42707c69942439895105
parent59a2ea179c83a22f92e78324a79f3fd43de2cb99 (diff)
downloadrepoze-lru-0ca02dad9b4adfba94a94f48527d642e35a0bf23.tar.gz
Drop support for Python 3.3; add support for 3.6.
Closes #26.
-rw-r--r--CHANGES.txt2
-rw-r--r--README.txt3
-rw-r--r--setup.py2
-rw-r--r--tox.ini2
4 files changed, 4 insertions, 5 deletions
diff --git a/CHANGES.txt b/CHANGES.txt
index 3a29f9a..8fe21d3 100644
--- a/CHANGES.txt
+++ b/CHANGES.txt
@@ -17,7 +17,7 @@ Changelog
- Avoid crash when memoizing a ``functools.partial`` instance (PR #21).
-- Add explicit support for Python 3.3, 3.4, and 3.5.
+- Add explicit support for Python3.4, 3.5, and 3.6.
- Drop support for Python 2.6 and 3.2.
diff --git a/README.txt b/README.txt
index 306d36c..aaa6be1 100644
--- a/README.txt
+++ b/README.txt
@@ -3,8 +3,7 @@ repoze.lru
``repoze.lru`` is a LRU (least recently used) cache implementation. Keys and
values that are not used frequently will be evicted from the cache faster
-than keys and values that are used frequently. It works under Python 2.5,
-Python 2.6, Python 2.7, and Python 3.2.
+than keys and values that are used frequently. It works under Python 2.7 and Python 3.4+.
Please see ``docs/index.rst`` for detailed documentation, or view them
online at http://docs.repoze.org/lru/.
diff --git a/setup.py b/setup.py
index c6a1f71..5d8f862 100644
--- a/setup.py
+++ b/setup.py
@@ -36,9 +36,9 @@ setup(name='repoze.lru',
"Programming Language :: Python :: 2",
"Programming Language :: Python :: 2.7",
"Programming Language :: Python :: 3",
- "Programming Language :: Python :: 3.3",
"Programming Language :: Python :: 3.4",
"Programming Language :: Python :: 3.5",
+ "Programming Language :: Python :: 3.6",
"Programming Language :: Python :: Implementation :: CPython",
"Programming Language :: Python :: Implementation :: PyPy",
"License :: Repoze Public License",
diff --git a/tox.ini b/tox.ini
index 5e04dc0..3e289f0 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,6 +1,6 @@
[tox]
envlist =
- py27,py33,py34,py35,pypy,pypy3,cover,docs
+ py27,py34,py35,py36,pypy,pypy3,cover,docs
[testenv]
commands =