summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJordan Cook <jordan.cook@pioneer.com>2022-06-29 17:34:25 -0500
committerJordan Cook <jordan.cook@pioneer.com>2022-06-29 17:53:57 -0500
commit79778c6abf950b42c560bf807ade7bacb346ebd1 (patch)
treebc00f58556226eea87e62a6e610a8f6990f81176
parenta6bebc3b88f5920af8c95ea860c7d47b733d3651 (diff)
downloadrequests-cache-79778c6abf950b42c560bf807ade7bacb346ebd1.tar.gz
Remove catching/logging ImportErrors in top-level package
-rw-r--r--HISTORY.md11
-rw-r--r--requests_cache/__init__.py19
2 files changed, 14 insertions, 16 deletions
diff --git a/HISTORY.md b/HISTORY.md
index 5f9f398..042645c 100644
--- a/HISTORY.md
+++ b/HISTORY.md
@@ -76,6 +76,11 @@
* `OriginalResponse.cache_key` and `expires` will be populated for any new response that was written to the cache
* Add request wrapper methods with return type hints for all HTTP methods (`CachedSession.get()`, `head()`, etc.)
+**Bugfixes:**
+* Fix usage of memory backend with `install_cache()`
+* Add `CachedRequest.path_url` property for compatibility with `RequestEncodingMixin`
+* Add compatibility with cattrs 22.1+
+
**Dependencies:**
* Replace `appdirs` with `platformdirs`
@@ -110,10 +115,8 @@ If you encounter a problem not listed here after updating to 1.0, please create
* Internal utility module changes:
* The `cache_control` module (added in `0.7`) has been split up into multiple modules in a new `policy` subpackage
-### 0.9.5 (Unreleased)
-* Fix usage of memory backend with `install_cache()`
-* Add `CachedRequest.path_url` property
-* Add compatibility with cattrs 22.1
+### 0.9.5 (2022-06-29)
+* Backport bugfixes from 1.0
### 0.9.4 (2022-04-22)
* Fix forwarding connection parameters passed to `RedisCache` for redis-py 4.2 and python <=3.8
diff --git a/requests_cache/__init__.py b/requests_cache/__init__.py
index e8bafb7..96f751b 100644
--- a/requests_cache/__init__.py
+++ b/requests_cache/__init__.py
@@ -1,18 +1,13 @@
# flake8: noqa: E402,F401
-from logging import getLogger
# Version is defined in pyproject.toml.
# It's copied here to make it easier for client code to check the installed version.
__version__ = '1.0.0'
-try:
- from .backends import *
- from .cache_keys import *
- from .models import *
- from .patcher import *
- from .policy import *
- from .serializers import *
- from .session import *
-# Log and ignore ImportErrors, if imported outside a virtualenv (e.g., just to check __version__)
-except ImportError as e:
- getLogger('requests_cache').warning(e, exc_info=True)
+from .backends import *
+from .cache_keys import *
+from .models import *
+from .patcher import *
+from .policy import *
+from .serializers import *
+from .session import *