summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJordan Cook <jordan.cook@pioneer.com>2022-04-19 22:04:05 -0500
committerJordan Cook <jordan.cook@pioneer.com>2022-04-19 22:06:51 -0500
commitbb6446d6a975f1771cdb06a97e8b576330a63b0d (patch)
tree388898aa871f1eec90bd3b8fcc7bf0caf19dd403
parent7b91dfb9dd8b500ef15d0c48a818b51717303307 (diff)
downloadrequests-cache-bb6446d6a975f1771cdb06a97e8b576330a63b0d.tar.gz
Major bump!
-rw-r--r--HISTORY.md11
-rw-r--r--pyproject.toml4
-rw-r--r--requests_cache/__init__.py2
3 files changed, 9 insertions, 8 deletions
diff --git a/HISTORY.md b/HISTORY.md
index ef5e4db..f174881 100644
--- a/HISTORY.md
+++ b/HISTORY.md
@@ -1,14 +1,18 @@
# History
-## Unreleased
+## 1.0.0 (Unreleased)
[See all unreleased issues and PRs](https://github.com/reclosedev/requests-cache/milestone/5?closed=1)
**Expiration & Headers:**
-* Add support for `Cache-Control: only-if-cached`
* Add support for `Cache-Control: min-fresh`
* Add support for `Cache-Control: max-stale`
+* Add support for `Cache-Control: stale-if-error`
+* Add support for `Cache-Control: only-if-cached`
* Revalidate for `Cache-Control: no-cache` request or response header
* Revalidate for `Cache-Control: max-age=0, must-revalidate` response headers
+
+**Settings:**
+* All settings that affect cache behavior can now be accessed and modified via `CachedSession.settings`
* Add `only_if_cached` option to `CachedSession.request()` and `send()` to return only cached results without sending real requests
* Add `refresh` option to `CachedSession.request()` and `send()` to revalidate with the server before using a cached response
* Add `force_refresh` option to `CachedSession.request()` and `send()` to awlays make and cache a new request regardless of existing cache contents
@@ -44,9 +48,6 @@
* Ignore and redact common authentication params and headers (e.g., for OAuth2) by default
* This is simply a default value for `ignored_parameters`, to avoid accidentally storing credentials in the cache
-**Other features:**
-* All settings that affect cache behavior can now be accessed and modified via `CachedSession.settings`
-
**Dependencies:**
* Replace `appdirs` with `platformdirs`
diff --git a/pyproject.toml b/pyproject.toml
index ffeb857..90aeeb3 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -1,6 +1,6 @@
[tool.poetry]
name = "requests-cache"
-version = "0.10.0"
+version = "1.0.0"
description = "A persistent cache for the requests library"
authors = ["Roman Haritonov"]
maintainers = ["Jordan Cook"]
@@ -12,7 +12,7 @@ repository = "https://github.com/reclosedev/requests-cache"
keywords = ["requests", "python-requests", "cache", "http", "web", "performance",
"sqlite", "redis", "mongodb", "gridfs", "dynamodb"]
classifiers = [
- "Development Status :: 4 - Beta",
+ "Development Status :: 5 - Production/Stable",
"Intended Audience :: Developers",
"Topic :: Software Development :: Libraries :: Python Modules",
"Typing :: Typed",
diff --git a/requests_cache/__init__.py b/requests_cache/__init__.py
index 9fcf09a..e8bafb7 100644
--- a/requests_cache/__init__.py
+++ b/requests_cache/__init__.py
@@ -3,7 +3,7 @@ from logging import getLogger
# Version is defined in pyproject.toml.
# It's copied here to make it easier for client code to check the installed version.
-__version__ = '0.10.0'
+__version__ = '1.0.0'
try:
from .backends import *