summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJordan Cook <jordan.cook@pioneer.com>2021-03-03 09:51:15 -0600
committerJordan Cook <jordan.cook@pioneer.com>2021-03-03 09:54:03 -0600
commitc25514312bafb89fe86663c0112d478714d1f83e (patch)
tree0fa644c396f4339b39aa24c318841e2ac2429182
parent9ae36967367c6bf4789d42b66f59ceb481e1b834 (diff)
downloadrequests-cache-c25514312bafb89fe86663c0112d478714d1f83e.tar.gz
Documentation build improvments:
* Add `.readthedocs.yml` build config * Remove mocks for backend modules (pymongo, redis-py, etc.), and make Readthedocs install them before building * Add Sphinx extensions for: * Google-style docstrings * 'Copy' button for code snippets * Automatic type annotation docs * Links to view source code * Add documentation requirements to setup.py for building docs locally * Remove config for unused Sphinx outputs
-rw-r--r--.readthedocs.yml16
-rw-r--r--docs/conf.py287
-rw-r--r--requests_cache/__init__.py28
-rw-r--r--setup.py13
4 files changed, 78 insertions, 266 deletions
diff --git a/.readthedocs.yml b/.readthedocs.yml
new file mode 100644
index 0000000..15bc7c5
--- /dev/null
+++ b/.readthedocs.yml
@@ -0,0 +1,16 @@
+# Read the Docs configuration file
+version: 2
+
+sphinx:
+ builder: html
+ configuration: docs/conf.py
+
+python:
+ version: 3.7
+ system_packages: True
+ install:
+ - method: pip
+ path: .
+ extra_requirements:
+ - docs
+ - backends
diff --git a/docs/conf.py b/docs/conf.py
index 42a0cfc..14fea4f 100644
--- a/docs/conf.py
+++ b/docs/conf.py
@@ -1,268 +1,49 @@
-# requests-cache documentation build configuration file, created by
-# sphinx-quickstart on Sun Apr 08 20:51:24 2012.
-#
-# This file is execfile()d with the current directory set to its containing dir.
-#
-# Note that not all possible configuration values are present in this
-# autogenerated file.
-#
-# All configuration values have a default; values that are commented out
-# serve to show the default.
-
+# requests-cache documentation build configuration file
import os
import sys
-# If extensions (or modules to document with autodoc) are in another directory,
-# add these directories to sys.path here. If the directory is relative to the
-# documentation root, use os.path.abspath to make it absolute, like shown here.
+# Add project path
sys.path.insert(0, os.path.abspath('..'))
-
-class Mock(object):
- def __init__(self, *args, **kwargs):
- pass
-
- def __call__(self, *args, **kwargs):
- return Mock()
-
- @classmethod
- def __getattr__(self, name):
- if name in ('__file__', '__path__'):
- return os.devnull
- elif name[0] == name[0].upper():
- return type(name, (), {})
- else:
- return Mock()
-
-
-MOCK_MODULES = ['pymongo', 'redis']
-for mod_name in MOCK_MODULES:
- sys.modules[mod_name] = Mock()
-
from requests_cache import __version__
-# -- General configuration -----------------------------------------------------
-
-# If your documentation needs a minimal Sphinx version, state it here.
-# needs_sphinx = '1.0'
-
-# Add any Sphinx extension module names here, as strings. They can be extensions
-# coming with Sphinx (named 'sphinx.ext.*') or your custom ones.
-extensions = ['sphinx.ext.autodoc', 'sphinx.ext.doctest']
-
-# Add any paths that contain templates here, relative to this directory.
-templates_path = ['_templates']
-
-# The suffix of source filenames.
-source_suffix = '.rst'
-
-# The encoding of source files.
-# source_encoding = 'utf-8-sig'
-
-# The master toctree document.
-master_doc = 'index'
-
# General information about the project.
-project = u'requests-cache'
-copyright = u'2012, Roman Haritonov'
-
-# The version info for the project you're documenting, acts as replacement for
-# |version| and |release|, also used in various other places throughout the
-# built documents.
-#
-# The short X.Y version.
-version = __version__
-# The full version, including alpha/beta/rc tags.
-release = __version__
-
-# The language for content autogenerated by Sphinx. Refer to documentation
-# for a list of supported languages.
-# language = None
-
-# There are two options for replacing |today|: either, you set today to some
-# non-false value, then it is used:
-# today = ''
-# Else, today_fmt is used as the format for a strftime call.
-# today_fmt = '%B %d, %Y'
-
-# List of patterns, relative to source directory, that match files and
-# directories to ignore when looking for source files.
-exclude_patterns = ['_build']
-
-# The reST default role (used for this markup: `text`) to use for all documents.
-# default_role = None
-
-# If true, '()' will be appended to :func: etc. cross-reference text.
-# add_function_parentheses = True
-
-# If true, the current module name will be prepended to all description
-# unit titles (such as .. function::).
-# add_module_names = True
-
-# If true, sectionauthor and moduleauthor directives will be shown in the
-# output. They are ignored by default.
-# show_authors = False
-
-# The name of the Pygments (syntax highlighting) style to use.
-pygments_style = 'sphinx'
-
-# A list of ignored prefixes for module index sorting.
-# modindex_common_prefix = []
-
-
-# -- Options for HTML output ---------------------------------------------------
-
-# The theme to use for HTML and HTML Help pages. See the documentation for
-# a list of builtin themes.
-html_theme = 'default'
-
-# Theme options are theme-specific and customize the look and feel of a theme
-# further. For a list of options available for each theme, see the
-# documentation.
-# html_theme_options = {}
-
-# Add any paths that contain custom themes here, relative to this directory.
-# html_theme_path = []
-
-# The name for this set of Sphinx documents. If None, it defaults to
-# "<project> v<release> documentation".
-# html_title = None
-
-# A shorter title for the navigation bar. Default is the same as html_title.
-# html_short_title = None
-
-# The name of an image file (relative to this directory) to place at the top
-# of the sidebar.
-# html_logo = None
-
-# The name of an image file (within the static path) to use as favicon of the
-# docs. This file should be a Windows icon file (.ico) being 16x16 or 32x32
-# pixels large.
-# html_favicon = None
-
-# Add any paths that contain custom static files (such as style sheets) here,
-# relative to this directory. They are copied after the builtin static files,
-# so a file named "default.css" will overwrite the builtin "default.css".
+project = 'requests-cache'
+copyright = '2021, Roman Haritonov'
+needs_sphinx = '3.0'
+master_doc = 'index'
+source_suffix = ['.rst', '.md']
+version = release = __version__
html_static_path = ['_static']
+exclude_patterns = ['_build']
+templates_path = ['_templates']
-# If not '', a 'Last updated on:' timestamp is inserted at every page bottom,
-# using the given strftime format.
-# html_last_updated_fmt = '%b %d, %Y'
-
-# If true, SmartyPants will be used to convert quotes and dashes to
-# typographically correct entities.
-# html_use_smartypants = True
-
-# Custom sidebar templates, maps document names to template names.
-# html_sidebars = {}
-
-# Additional templates that should be rendered to pages, maps page names to
-# template names.
-# html_additional_pages = {}
-
-# If false, no module index is generated.
-# html_domain_indices = True
-
-# If false, no index is generated.
-# html_use_index = True
-
-# If true, the index is split into individual pages for each letter.
-# html_split_index = False
-
-# If true, links to the reST sources are added to the pages.
-# html_show_sourcelink = True
-
-# If true, "Created using Sphinx" is shown in the HTML footer. Default is True.
-# html_show_sphinx = True
-
-# If true, "(C) Copyright ..." is shown in the HTML footer. Default is True.
-# html_show_copyright = True
-
-# If true, an OpenSearch description file will be output, and all pages will
-# contain a <link> tag referring to it. The value of this option must be the
-# base URL from which the finished HTML is served.
-# html_use_opensearch = ''
-
-# This is the file name suffix for HTML files (e.g. ".xhtml").
-# html_file_suffix = None
-
-# Output file base name for HTML help builder.
-htmlhelp_basename = 'requests-cachedoc'
-
-
-# -- Options for LaTeX output --------------------------------------------------
-
-latex_elements = {
- # The paper size ('letterpaper' or 'a4paper').
- #'papersize': 'letterpaper',
- # The font size ('10pt', '11pt' or '12pt').
- #'pointsize': '10pt',
- # Additional stuff for the LaTeX preamble.
- #'preamble': '',
-}
-
-# Grouping the document tree into LaTeX files. List of tuples
-# (source start file, target name, title, author, documentclass [howto/manual]).
-latex_documents = [
- ('index', 'requests-cache.tex', u'requests-cache Documentation', u'Roman Haritonov', 'manual'),
-]
-
-# The name of an image file (relative to this directory) to place at the top of
-# the title page.
-# latex_logo = None
-
-# For "manual" documents, if this is true, then toplevel headings are parts,
-# not chapters.
-# latex_use_parts = False
-
-# If true, show page references after internal links.
-# latex_show_pagerefs = False
-
-# If true, show URL addresses after external links.
-# latex_show_urls = False
-
-# Documents to append as an appendix to all manuals.
-# latex_appendices = []
-
-# If false, no module index is generated.
-# latex_domain_indices = True
-
-
-# -- Options for manual page output --------------------------------------------
-
-# One entry per manual page. List of tuples
-# (source start file, name, description, authors, manual section).
-man_pages = [('index', 'requests-cache', u'requests-cache Documentation', [u'Roman Haritonov'], 1)]
-
-# If true, show URL addresses after external links.
-# man_show_urls = False
-
-
-# -- Options for Texinfo output ------------------------------------------------
-
-# Grouping the document tree into Texinfo files. List of tuples
-# (source start file, target name, title, author,
-# dir menu entry, description, category)
-texinfo_documents = [
- (
- 'index',
- 'requests-cache',
- u'requests-cache Documentation',
- u'Roman Haritonov',
- 'requests-cache',
- 'One line description of project.',
- 'Miscellaneous',
- ),
+# Sphinx extension modules
+extensions = [
+ 'sphinx.ext.autodoc',
+ 'sphinx.ext.intersphinx',
+ 'sphinx.ext.napoleon',
+ 'sphinx.ext.viewcode',
+ 'sphinx_autodoc_typehints',
+ 'sphinx_copybutton',
+ # 'sphinxcontrib.apidoc',
+ # 'm2r2',
]
-# Documents to append as an appendix to all manuals.
-# texinfo_appendices = []
+# Enable automatic links to other projects' Sphinx docs
+intersphinx_mapping = {
+ 'requests': ('https://requests.readthedocs.io/en/master/', None),
+}
-# If false, no module index is generated.
-# texinfo_domain_indices = True
+# Enable Google-style docstrings
+napoleon_google_docstring = True
+napoleon_include_private_with_doc = False
+napoleon_include_special_with_doc = False
-# How to display URL addresses: 'footnote', 'no', or 'inline'.
-# texinfo_show_urls = 'footnote'
+# Strip prompt text when copying code blocks with copy button
+copybutton_prompt_text = r'>>> |\.\.\. |\$ '
+copybutton_prompt_is_regexp = True
-autoclass_content = 'both'
-autodoc_member_order = 'bysource'
+# HTML theme settings
+pygments_style = 'sphinx'
+html_theme = 'sphinx_rtd_theme'
diff --git a/requests_cache/__init__.py b/requests_cache/__init__.py
index 1a3dfed..3a8bbe0 100644
--- a/requests_cache/__init__.py
+++ b/requests_cache/__init__.py
@@ -22,15 +22,19 @@
:license: BSD, see LICENSE for more details.
"""
__docformat__ = 'restructuredtext'
-__version__ = '0.5.2'
-
-from .core import (
- CachedSession,
- clear,
- disabled,
- enabled,
- get_cache,
- install_cache,
- remove_expired_responses,
- uninstall_cache,
-)
+__version__ = '0.6.0'
+
+# Quietly ignore importerror, if setup.py is invoked outside a virtualenv
+try:
+ from .core import (
+ CachedSession,
+ clear,
+ disabled,
+ enabled,
+ get_cache,
+ install_cache,
+ remove_expired_responses,
+ uninstall_cache,
+ )
+except ImportError:
+ pass
diff --git a/setup.py b/setup.py
index 7ab0288..1bd613e 100644
--- a/setup.py
+++ b/setup.py
@@ -2,11 +2,22 @@
from itertools import chain
from setuptools import find_packages, setup
+from requests_cache import __version__
+
extras_require = {
# Packages used for CI jobs
'build': ['coveralls', 'twine', 'wheel'],
# Packages for all supported backends
'backends': ['boto3', 'pymongo', 'redis'],
+ # Packages used for documentation builds
+ 'docs': [
+ 'm2r2',
+ 'Sphinx~=3.5.1',
+ 'sphinx-autodoc-typehints',
+ 'sphinx-copybutton',
+ 'sphinx-rtd-theme',
+ 'sphinxcontrib-apidoc',
+ ],
# Packages used for testing both locally and in CI jobs
'test': [
'black==20.8b1',
@@ -23,7 +34,7 @@ extras_require['dev'] = list(chain.from_iterable(extras_require.values()))
setup(
name='requests-cache',
packages=find_packages(),
- version='0.6.0',
+ version=__version__,
author='Roman Haritonov',
author_email='reclosedev@gmail.com',
url='https://github.com/reclosedev/requests-cache',