summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJordan Cook <jordan.cook@pioneer.com>2021-10-04 15:30:34 -0500
committerJordan Cook <jordan.cook@pioneer.com>2021-10-04 15:30:34 -0500
commite9f425d4631c9da8b49f598d4a82e6f6b729dd73 (patch)
tree1497b7ee689f987bebf99c53b4c6b7c94659b7b6
parent17d6ced9211cb7b9325152d694911a153c62d38c (diff)
downloadrequests-cache-e9f425d4631c9da8b49f598d4a82e6f6b729dd73.tar.gz
Add explicit 'coverage' dependency for python 3.10
-rw-r--r--poetry.lock2
-rw-r--r--pyproject.toml3
2 files changed, 3 insertions, 2 deletions
diff --git a/poetry.lock b/poetry.lock
index 09bb12f..0f7fab1 100644
--- a/poetry.lock
+++ b/poetry.lock
@@ -1203,7 +1203,7 @@ yaml = ["pyyaml"]
[metadata]
lock-version = "1.1"
python-versions = "^3.7"
-content-hash = "e52db294780e9f4f12c301973a04b98e6e1f464f65174630a2a7115b381aff8e"
+content-hash = "5181311d03a2daf46444ada83ec0bec45ec3bf404aecc713951271d1450ec1e9"
[metadata.files]
alabaster = [
diff --git a/pyproject.toml b/pyproject.toml
index 40a03eb..06d279d 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -84,10 +84,11 @@ docs = ["furo", "linkify-it-py", "myst-parser", "sphinx", "sphinx-autodoc-ty
[tool.poetry.dev-dependencies]
# For unit + integration tests
+coverage = "^6.0"
psutil = "^5.0"
pytest = "^6.2"
pytest-clarity = "^1.0.1"
-pytest-cov = ">=2.11"
+pytest-cov = ">=3.0"
pytest-rerunfailures = "^10.1"
pytest-xdist = ">=2.2"
requests-mock = "^1.8"