summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJordan Cook <jordan.cook@pioneer.com>2021-08-12 13:10:20 -0500
committerJordan Cook <jordan.cook@pioneer.com>2021-08-12 15:28:10 -0500
commitf61edc315580094605747012e04029cb9aa36427 (patch)
tree89a6ff48e04fead5f18ae1d0d3083eaee090e7ec
parent34deed3f223f80ecc63627ea7a86c7fd1593960c (diff)
downloadrequests-cache-f61edc315580094605747012e04029cb9aa36427.tar.gz
Update changelog, contributors, and bump version
-rw-r--r--.all-contributorsrc9
-rw-r--r--CONTRIBUTORS.md1
-rw-r--r--HISTORY.md5
-rw-r--r--pyproject.toml2
-rw-r--r--requests_cache/__init__.py2
5 files changed, 17 insertions, 2 deletions
diff --git a/.all-contributorsrc b/.all-contributorsrc
index 4d4b82b..dea892f 100644
--- a/.all-contributorsrc
+++ b/.all-contributorsrc
@@ -632,6 +632,15 @@
"bug",
"ideas"
]
+ },
+ {
+ "login": "denis-bz",
+ "name": "denis-bz",
+ "avatar_url": "https://avatars.githubusercontent.com/u/1280390?v=4",
+ "profile": "https://stackoverflow.com/users/86643/denis",
+ "contributions": [
+ "bug"
+ ]
}
],
"contributorsPerLine": 7,
diff --git a/CONTRIBUTORS.md b/CONTRIBUTORS.md
index ccf4b6d..7f613ef 100644
--- a/CONTRIBUTORS.md
+++ b/CONTRIBUTORS.md
@@ -82,6 +82,7 @@ contributions that have helped to improve requests-cache:
</tr>
<tr>
<td align="center"><a href="https://github.com/craigls"><img src="https://avatars.githubusercontent.com/u/972350?v=4?s=100" width="100px;" alt=""/><br /><sub><b>craig</b></sub></a><br /><a href="https://github.com/reclosedev/requests-cache/commits?author=craigls" title="Code">💻</a> <a href="https://github.com/reclosedev/requests-cache/issues?q=author%3Acraigls" title="Bug reports">🐛</a></td>
+ <td align="center"><a href="https://stackoverflow.com/users/86643/denis"><img src="https://avatars.githubusercontent.com/u/1280390?v=4?s=100" width="100px;" alt=""/><br /><sub><b>denis-bz</b></sub></a><br /><a href="https://github.com/reclosedev/requests-cache/issues?q=author%3Adenis-bz" title="Bug reports">🐛</a></td>
<td align="center"><a href="https://github.com/gorogoroumaru"><img src="https://avatars.githubusercontent.com/u/30716350?v=4?s=100" width="100px;" alt=""/><br /><sub><b>gorogoroumaru</b></sub></a><br /><a href="https://github.com/reclosedev/requests-cache/commits?author=gorogoroumaru" title="Code">💻</a></td>
<td align="center"><a href="https://github.com/harvey251"><img src="https://avatars.githubusercontent.com/u/33844174?v=4?s=100" width="100px;" alt=""/><br /><sub><b>harvey251</b></sub></a><br /><a href="https://github.com/reclosedev/requests-cache/issues?q=author%3Aharvey251" title="Bug reports">🐛</a></td>
<td align="center"><a href="https://github.com/mbarkhau"><img src="https://avatars.githubusercontent.com/u/446561?v=4?s=100" width="100px;" alt=""/><br /><sub><b>mbarkhau</b></sub></a><br /><a href="https://github.com/reclosedev/requests-cache/commits?author=mbarkhau" title="Code">💻</a> <a href="https://github.com/reclosedev/requests-cache/commits?author=mbarkhau" title="Tests">⚠️</a> <a href="#infra-mbarkhau" title="Infrastructure (Hosting, Build-Tools, etc)">🚇</a> <a href="https://github.com/reclosedev/requests-cache/issues?q=author%3Ambarkhau" title="Bug reports">🐛</a></td>
diff --git a/HISTORY.md b/HISTORY.md
index 271b8f6..e4ca35a 100644
--- a/HISTORY.md
+++ b/HISTORY.md
@@ -1,5 +1,10 @@
# History
+### 0.7.4 (2021-08-TBD)
+* Fix an issue with httpdate strings from `Expires` headers not getting converted to UTC
+* Fix a packaging issue with extra files added to top-level wheel directory
+* Fix some issues with parallelizing tests using pytest-xdist
+
### 0.7.3 (2021-08-10)
* SQLite backend: Update `DbCache.clear()` to succeed even if the database is corrupted
* SQLite backend: update `DbDict.bulk_delete()` to split the operation into multiple statements to support
diff --git a/pyproject.toml b/pyproject.toml
index 11191c0..dec0534 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -1,6 +1,6 @@
[tool.poetry]
name = "requests-cache"
-version = "0.7.3"
+version = "0.7.4"
description = "A transparent, persistent cache for the requests library"
authors = ["Roman Haritonov", "Jordan Cook"]
license = "BSD License"
diff --git a/requests_cache/__init__.py b/requests_cache/__init__.py
index eb9c8fc..7214a42 100644
--- a/requests_cache/__init__.py
+++ b/requests_cache/__init__.py
@@ -5,7 +5,7 @@ logger = getLogger(__name__)
# Version is defined in pyproject.toml.
# It's copied here to make it easier for client code to check the installed version.
-__version__ = '0.7.3'
+__version__ = '0.7.4'
def get_placeholder_class(original_exception: Exception = None):