summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorJordan Cook <jordan.cook@pioneer.com>2021-08-07 20:14:26 -0500
committerJordan Cook <jordan.cook@pioneer.com>2021-08-08 18:21:24 -0500
commit0239c0372ea5ad44807a8a47598d0b4dacff276b (patch)
tree8059ba308186ee173ddc6a2ece2e88e996b264d4 /pyproject.toml
parent5455bddcaeec4a274e15cfa194b382aa6793d060 (diff)
downloadrequests-cache-0239c0372ea5ad44807a8a47598d0b4dacff276b.tar.gz
Use nox to replace docs/Makefile, runtests.sh, and other local dev tasks
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml7
1 files changed, 4 insertions, 3 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 48c0785..086518a 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -67,9 +67,12 @@ flake8 = "^3.9"
flake8-comprehensions = "*"
flake8-polyfill = "*"
mypy = "^0.910"
+nox = {version = "^2021.6.12", python = "^3.6.2"}
+nox-poetry = {version = "^0.8.6", python = "^3.6.2"}
pre-commit = {version = "^2.12", python = "^3.6.2"}
psutil = "^5.0"
pytest = "^6.2"
+pytest-clarity = "^1.0.1"
pytest-cov = ">=2.11"
pytest-order = "1.0"
pytest-xdist = ">=2.2"
@@ -77,12 +80,12 @@ radon = "^5.0"
requests-mock = "^1.8"
responses = "0.10.15"
rich = ">=10.0"
+sphinx-autobuild = "^2021.3.14"
timeout-decorator = "^0.5"
types-pyyaml = ">=5.4.3"
types-redis = ">=3.5.4"
types-requests = ">=0.1.8"
types-ujson = ">=0.1.1"
-myst-parser = "^0.15.1"
[build-system]
requires = ["poetry-core>=1.0.0"]
@@ -115,5 +118,3 @@ skip = [
'tests/compat/',
]
known_first_party = ['tests']
-# Things that are common enough they may as well be grouped with stdlib imports
-extra_standard_library = ['pytest', 'setuptools']