summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorJordan Cook <jordan.cook@pioneer.com>2022-06-29 18:26:48 -0500
committerJordan Cook <jordan.cook.git@proton.me>2022-07-05 19:02:01 -0500
commit229f61225e0cde4be64242e713ae34b80572afb8 (patch)
tree8254103c0385cabff0de54597bdb0f00bae34068 /pyproject.toml
parentf5bf4716f4d184b92c72a06619461ebea78817ac (diff)
downloadrequests-cache-229f61225e0cde4be64242e713ae34b80572afb8.tar.gz
Add retries for MongoDB ServerSelectionTimeoutError on GitHub Actions runners
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml3
1 files changed, 2 insertions, 1 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 791b60e..3bbdea6 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -45,7 +45,7 @@ redis = {optional=true, version=">=3"}
bson = {optional=true, version=">=0.5"}
itsdangerous = {optional=true, version="^2.0"}
pyyaml = {optional=true, version=">=5.4"}
-ujson = {optional=true, version=">=4.0"}
+ujson = {optional=true, version=">=5.4"}
# Dependencies for building documentation;
# defined here because readthedocs doesn't (yet?) support poetry.dev-dependencies
@@ -95,6 +95,7 @@ pytest-rerunfailures = "^10.1"
pytest-xdist = ">=2.2"
requests-mock = "^1.9"
responses = "0.19.0"
+tenacity = "^8.0"
timeout-decorator = "^0.5"
# Tools for linting, type checking, etc. are managed with pre-commit