summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorJordan Cook <jordan.cook@pioneer.com>2022-03-12 16:08:18 +0000
committerJordan Cook <jordan.cook@pioneer.com>2022-03-14 11:05:00 -0500
commit2869a6442b94fe8a6ffdf33abbf4cf010783f802 (patch)
tree0c7180490bbc981581d843390a61b76bb6d1c729 /pyproject.toml
parent2ed99885616f4244a227a3c6567348a18bc3abfc (diff)
downloadrequests-cache-2869a6442b94fe8a6ffdf33abbf4cf010783f802.tar.gz
Swap out appdirs for platformdirs
* platformdirs is a more actively maintained fork of appdirs. * Also relax requirements a bit for attrs and urllib (minimum instead of caret constraint) Dependabot update: Bump responses from 0.16.0 to 0.19.0 Bumps [responses](https://github.com/getsentry/responses) from 0.16.0 to 0.19.0. - [Release notes](https://github.com/getsentry/responses/releases) - [Changelog](https://github.com/getsentry/responses/blob/master/CHANGES) - [Commits](https://github.com/getsentry/responses/compare/0.16.0...0.19.0) --- updated-dependencies: - dependency-name: responses dependency-type: direct:development update-type: version-update:semver-minor ... Signed-off-by: dependabot[bot] <support@github.com>
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml8
1 files changed, 4 insertions, 4 deletions
diff --git a/pyproject.toml b/pyproject.toml
index d5030b0..aab6f60 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -30,10 +30,10 @@ python = "^3.7"
# Required dependencies
requests = "^2.22" # Needs no introduction
-urllib3 = "^1.25.5" # Use a slightly newer version than required by requests (for bugfixes)
-appdirs = "^1.4.4" # For options that use platform-specific user cache dirs
-attrs = "^21.2" # For response data models
+urllib3 = ">=1.25.5" # Use a slightly newer version than required by requests (for bugfixes)
+attrs = ">=21.2" # For response data models
cattrs = "^1.8" # For response serialization
+platformdirs = "^2.5" # For options that use platform-specific user cache dirs
url-normalize = "^1.4" # For improved request matching
# Optional backend dependencies
@@ -92,7 +92,7 @@ pytest-cov = ">=3.0"
pytest-rerunfailures = "^10.1"
pytest-xdist = ">=2.2"
requests-mock = "^1.8"
-responses = "0.16.0"
+responses = "0.19.0"
timeout-decorator = "^0.5"
# Tools for linting, type checking, etc. are managed with pre-commit