summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorJordan Cook <jordan.cook@pioneer.com>2021-08-10 17:39:07 -0500
committerJordan Cook <jordan.cook@pioneer.com>2021-08-14 21:58:30 -0500
commit34a7cbeca84d0e7939ffd44bf9e6d6bcd029b94e (patch)
tree65bcb2bd3faa352c4cd5f4e3f57a17ef056519ba /pyproject.toml
parentf3104d8897f85ac44b61e82e24f447543bdbd1fa (diff)
downloadrequests-cache-34a7cbeca84d0e7939ffd44bf9e6d6bcd029b94e.tar.gz
Update user guide and Readme
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml9
1 files changed, 7 insertions, 2 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 2ee4635..271baff 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -8,12 +8,17 @@ readme = "README.md"
homepage = "https://github.com/reclosedev/requests-cache"
repository = "https://github.com/reclosedev/requests-cache"
keywords = ["requests", "cache", "http", "persistence", "sqlite", "redis", "mongodb", "gridfs", "dynamodb"]
+classifiers = [
+ "Development Status :: 4 - Beta",
+ "Intended Audience :: Developers",
+ "Typing :: Typed",
+]
include = [
{ path = "*.md", format = "sdist" },
{ path = "*.yml", format = "sdist" },
{ path = "docs", format = "sdist" },
{ path = "examples", format = "sdist" },
- { path = "tests", format = "sdist" }
+ { path = "tests", format = "sdist" },
]
[tool.poetry.urls]
@@ -41,7 +46,7 @@ redis = { version = "^3.0", optional = true }
# Documentation dependencies needed for Readthedocs builds (rtd doesn't support poetry.dev-dependencies)
# [tool.poetry.dev-dependencies]
-furo = {version = ">=2021.6.24-beta.37", optional = true}
+furo = {version = ">=2021.8.11-beta.42", optional = true}
myst-parser = {version = "^0.15.1", optional = true}
Sphinx = { version = "4.1.2", optional = true }
sphinx-autodoc-typehints = { version = "^1.11", optional = true }