summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorJordan Cook <jordan.cook@pioneer.com>2022-03-19 21:50:54 -0500
committerJordan Cook <jordan.cook@pioneer.com>2022-04-01 13:48:25 -0500
commit550fca5c604fa9635b19bb4ba10d444e36b30d05 (patch)
tree9a6882a7765db1e4201614d171bd3814ef39b39b /pyproject.toml
parent5a9a18c7bd1d14812fe6308992a193d4a1479a1e (diff)
downloadrequests-cache-550fca5c604fa9635b19bb4ba10d444e36b30d05.tar.gz
Update docs, doc dependencies, changelog, and contributors
Also: Restrict redis-py to <4.2, which breaks parameter forwarding on python 3.7 and 3.8
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml20
1 files changed, 10 insertions, 10 deletions
diff --git a/pyproject.toml b/pyproject.toml
index aab6f60..aacaad6 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -40,7 +40,7 @@ url-normalize = "^1.4" # For improved request matching
boto3 = {optional=true, version="^1.15"}
botocore = {optional=true, version="^1.18"}
pymongo = {optional=true, version=">=3,<5"}
-redis = {optional=true, version=">=3,<5"}
+redis = {optional=true, version=">=3,<4.2"}
# Optional serialization dependencies
bson = {optional=true, version=">=0.5"}
@@ -48,17 +48,17 @@ itsdangerous = {optional=true, version="^2.0"}
pyyaml = {optional=true, version=">=5.4"}
ujson = {optional=true, version=">=4.0"}
-# All the bells and whistles for building documentation;
+# Dependencies for building documentation;
# defined here because readthedocs doesn't (yet?) support poetry.dev-dependencies
-furo = {optional=true, version=">=2021.9.8"}
-linkify-it-py = {optional=true, version="^1.0.1"}
-myst-parser = {optional=true, version="^0.15.1"}
-sphinx = {optional=true, version="4.3.0"}
-sphinx-autodoc-typehints = {optional=true, version="^1.11"}
-sphinx-automodapi = {optional=true, version=">=0.13,<0.15"}
-sphinx-copybutton = {optional=true, version=">=0.3,<0.5"}
+furo = {optional=true, version="^2022.3.4"}
+linkify-it-py = {optional=true, version="^1.0"}
+myst-parser = {optional=true, version=">=0.17"}
+sphinx = {optional=true, version="^4.5.0"}
+sphinx-autodoc-typehints = {optional=true, version="^1.17"}
+sphinx-automodapi = {optional=true, version=">=0.14"}
+sphinx-copybutton = {optional=true, version=">=0.5"}
sphinx-inline-tabs = {optional=true, version=">=2022.1.2b11", python=">=3.8"}
-sphinx-notfound-page = {optional=true, version="*"}
+sphinx-notfound-page = {optional=true, version=">=0.8"}
sphinx-panels = {optional=true, version="^0.6"}
sphinxcontrib-apidoc = {optional=true, version="^0.3"}