summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorJordan Cook <jordan.cook.git@proton.me>2023-02-18 15:57:00 -0600
committerJordan Cook <jordan.cook.git@proton.me>2023-03-01 17:35:24 -0600
commit691b831a338e051c8e21df4ec5137d1d317511a6 (patch)
tree0e3dd3db86ed5b935b0a98d62c5e41a6b5862cbb /pyproject.toml
parentd4ba370d7b3ebd5e178a053d35fbd7d9bdba2873 (diff)
downloadrequests-cache-691b831a338e051c8e21df4ec5137d1d317511a6.tar.gz
Update dependencies
Bump rrainn/dynamodb-action from 2.0.1 to 3.0.0 Bumps [rrainn/dynamodb-action](https://github.com/rrainn/dynamodb-action) from 2.0.1 to 3.0.0. - [Release notes](https://github.com/rrainn/dynamodb-action/releases) - [Commits](https://github.com/rrainn/dynamodb-action/compare/v2.0.1...v3.0.0) --- updated-dependencies: - dependency-name: rrainn/dynamodb-action dependency-type: direct:production update-type: version-update:semver-major ... Signed-off-by: dependabot[bot] <support@github.com> Bump pytest from 7.1.3 to 7.2.0 Bumps [pytest](https://github.com/pytest-dev/pytest) from 7.1.3 to 7.2.0. - [Release notes](https://github.com/pytest-dev/pytest/releases) - [Changelog](https://github.com/pytest-dev/pytest/blob/main/CHANGELOG.rst) - [Commits](https://github.com/pytest-dev/pytest/compare/7.1.3...7.2.0) --- updated-dependencies: - dependency-name: pytest dependency-type: direct:development update-type: version-update:semver-minor ... Signed-off-by: dependabot[bot] <support@github.com> Bump pytest-xdist from 2.5.0 to 3.0.2 Bumps [pytest-xdist](https://github.com/pytest-dev/pytest-xdist) from 2.5.0 to 3.0.2. - [Release notes](https://github.com/pytest-dev/pytest-xdist/releases) - [Changelog](https://github.com/pytest-dev/pytest-xdist/blob/master/CHANGELOG.rst) - [Commits](https://github.com/pytest-dev/pytest-xdist/compare/v2.5.0...v3.0.2) --- updated-dependencies: - dependency-name: pytest-xdist dependency-type: direct:development update-type: version-update:semver-major ... Signed-off-by: dependabot[bot] <support@github.com> Bump sphinx-autodoc-typehints from 1.19.5 to 1.20.1 Bumps [sphinx-autodoc-typehints](https://github.com/tox-dev/sphinx-autodoc-typehints) from 1.19.5 to 1.20.1. - [Release notes](https://github.com/tox-dev/sphinx-autodoc-typehints/releases) - [Changelog](https://github.com/tox-dev/sphinx-autodoc-typehints/blob/main/CHANGELOG.md) - [Commits](https://github.com/tox-dev/sphinx-autodoc-typehints/compare/1.19.5...1.20.1) --- updated-dependencies: - dependency-name: sphinx-autodoc-typehints dependency-type: direct:production update-type: version-update:semver-minor ... Signed-off-by: dependabot[bot] <support@github.com> Bump ujson from 5.6.0 to 5.7.0 Bumps [ujson](https://github.com/ultrajson/ultrajson) from 5.6.0 to 5.7.0. - [Release notes](https://github.com/ultrajson/ultrajson/releases) - [Commits](https://github.com/ultrajson/ultrajson/compare/5.6.0...5.7.0) --- updated-dependencies: - dependency-name: ujson dependency-type: direct:production update-type: version-update:semver-minor ... Signed-off-by: dependabot[bot] <support@github.com> Bump coverage from 6.5.0 to 7.0.5 Bumps [coverage](https://github.com/nedbat/coveragepy) from 6.5.0 to 7.0.5. - [Release notes](https://github.com/nedbat/coveragepy/releases) - [Changelog](https://github.com/nedbat/coveragepy/blob/master/CHANGES.rst) - [Commits](https://github.com/nedbat/coveragepy/compare/6.5.0...7.0.5) --- updated-dependencies: - dependency-name: coverage dependency-type: direct:development update-type: version-update:semver-major ... Signed-off-by: dependabot[bot] <support@github.com>
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml6
1 files changed, 3 insertions, 3 deletions
diff --git a/pyproject.toml b/pyproject.toml
index e56557c..ed0b4de 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -53,7 +53,7 @@ ujson = {optional=true, version=">=5.4"}
# Dependencies for building documentation;
# defined here because readthedocs doesn't (yet?) support poetry.dev-dependencies
-furo = {optional=true, version="^2022.6"}
+furo = {optional=true, version="^2022.12.7"}
linkify-it-py = {optional=true, version=">=2.0"}
myst-parser = {optional=true, version=">=0.17"}
sphinx = {optional=true, version="^5.0.2"}
@@ -87,9 +87,9 @@ docs = ["furo", "linkify-it-py", "myst-parser", "sphinx", "sphinx-autodoc-ty
[tool.poetry.dev-dependencies]
# For unit + integration tests
-coverage = "^6.5"
+coverage = "^7.1"
psutil = "^5.0"
-pytest = "^7.1"
+pytest = "^7.2"
pytest-clarity = "^1.0.1"
pytest-cov = ">=3.0"
pytest-rerunfailures = "^10.1"