summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorJordan Cook <jordan.cook@pioneer.com>2021-05-26 22:17:29 -0500
committerJordan Cook <jordan.cook@pioneer.com>2021-06-11 11:13:53 -0500
commit6b566dccc6e90e497f6443ca8fb960c05a18a47a (patch)
treec3f5d03d9a826d7ae62c196a5247ac9a73ae8077 /pyproject.toml
parent68bdfa960e8f3a630fe4f53529de4d3ae3bf8216 (diff)
downloadrequests-cache-6b566dccc6e90e497f6443ca8fb960c05a18a47a.tar.gz
Add relevant package extras to install optional dependencies
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml9
1 files changed, 7 insertions, 2 deletions
diff --git a/pyproject.toml b/pyproject.toml
index d3246bf..beacf4e 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -27,8 +27,9 @@ requests = "^2.17"
url-normalize = "^1.4"
# Optional serialization dependencies
+bson = {version = ">=0.5", optional = true}
cattrs = {version = "^1.7", python = "^3.7", optional = true}
-ujson = {version = "^4.0.2", optional = true}
+ujson = {version = ">=4.0", optional = true}
# Optional backend dependencies
boto3 = { version = "^1.15", optional = true }
@@ -44,8 +45,12 @@ sphinx-rtd-theme = { version = "0.5.2", optional = true }
sphinxcontrib-apidoc = { version = "^0.3", optional = true }
[tool.poetry.extras]
-backends = ["boto3", "pymongo", "redis"]
+all = ["boto3", "cattrs", "pymongo", "redis", "ujson"]
+bson = ["cattrs", "bson"] # BSON comes with pymongo, and can also be used as a standalone codec
json = ["cattrs", "ujson"]
+dynamodb = ["boto3"]
+mongodb = ["cattrs", "pymongo"]
+redis = ["redis"]
docs = ["docutils", "m2r2", "Sphinx", "sphinx-autodoc-typehints", "sphinx-copybutton",
"sphinx-material", "sphinx-rtd-theme", "sphinxcontrib-apidoc"]