summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authordependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>2021-11-20 16:11:30 +0000
committerJordan Cook <jordan.cook@pioneer.com>2021-11-20 10:51:14 -0600
commit82c790ac05535129a26c4587e95e31e4b0215764 (patch)
treee831eb6b15e47cbfb2d77d289fedf9fc99018a53 /pyproject.toml
parent06108e027cb15c4103339a1cfe99095416caf1d4 (diff)
downloadrequests-cache-82c790ac05535129a26c4587e95e31e4b0215764.tar.gz
Squash dependabot updates
Bump redis from 3.5.3 to 4.0.1 Bumps [redis](https://github.com/redis/redis-py) from 3.5.3 to 4.0.1. - [Release notes](https://github.com/redis/redis-py/releases) - [Changelog](https://github.com/redis/redis-py/blob/master/CHANGES) - [Commits](https://github.com/redis/redis-py/compare/3.5.3...v4.0.1) --- updated-dependencies: - dependency-name: redis dependency-type: direct:production update-type: version-update:semver-major ... Signed-off-by: dependabot[bot] <support@github.com> Bump supercharge/mongodb-github-action from 1.6.0 to 1.7.0 Bumps [supercharge/mongodb-github-action](https://github.com/supercharge/mongodb-github-action) from 1.6.0 to 1.7.0. - [Release notes](https://github.com/supercharge/mongodb-github-action/releases) - [Changelog](https://github.com/supercharge/mongodb-github-action/blob/main/CHANGELOG.md) - [Commits](https://github.com/supercharge/mongodb-github-action/compare/1.6.0...1.7.0) --- updated-dependencies: - dependency-name: supercharge/mongodb-github-action dependency-type: direct:production update-type: version-update:semver-minor ... Signed-off-by: dependabot[bot] <support@github.com> Bump nox-poetry from 0.8.6 to 0.9.0 Bumps [nox-poetry](https://github.com/cjolowicz/nox-poetry) from 0.8.6 to 0.9.0. - [Release notes](https://github.com/cjolowicz/nox-poetry/releases) - [Commits](https://github.com/cjolowicz/nox-poetry/compare/v0.8.6...v0.9.0) --- updated-dependencies: - dependency-name: nox-poetry dependency-type: direct:development update-type: version-update:semver-minor ... Signed-off-by: dependabot[bot] <support@github.com> Bump rich from 10.13.0 to 10.14.0 Bumps [rich](https://github.com/willmcgugan/rich) from 10.13.0 to 10.14.0. - [Release notes](https://github.com/willmcgugan/rich/releases) - [Changelog](https://github.com/willmcgugan/rich/blob/master/CHANGELOG.md) - [Commits](https://github.com/willmcgugan/rich/compare/v10.13.0...v10.14.0) --- updated-dependencies: - dependency-name: rich dependency-type: direct:development update-type: version-update:semver-minor ... Signed-off-by: dependabot[bot] <support@github.com> Bump responses from 0.15.0 to 0.16.0 Bumps [responses](https://github.com/getsentry/responses) from 0.15.0 to 0.16.0. - [Release notes](https://github.com/getsentry/responses/releases) - [Changelog](https://github.com/getsentry/responses/blob/master/CHANGES) - [Commits](https://github.com/getsentry/responses/compare/0.15.0...0.16.0) --- updated-dependencies: - dependency-name: responses dependency-type: direct:development update-type: version-update:semver-minor ... Signed-off-by: dependabot[bot] <support@github.com>
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml6
1 files changed, 3 insertions, 3 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 640c2f5..a17d2fc 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -40,7 +40,7 @@ url-normalize = "^1.4" # For reducing duplicate cache items
boto3 = {optional=true, version="^1.15"}
botocore = {optional=true, version="^1.18"}
pymongo = {optional=true, version="^3.0"}
-redis = {optional=true, version="^3.0"}
+redis = {optional=true, version=">=3,<5"}
# Optional serialization dependencies
bson = {optional=true, version=">=0.5"}
@@ -92,7 +92,7 @@ pytest-cov = ">=3.0"
pytest-rerunfailures = "^10.1"
pytest-xdist = ">=2.2"
requests-mock = "^1.8"
-responses = "0.15"
+responses = "0.16.0"
timeout-decorator = "^0.5"
# Tools for linting, type checking, etc. are managed with pre-commit
@@ -100,7 +100,7 @@ pre-commit = "^2.15"
# For convenience in local development
nox = "^2021.10.1"
-nox-poetry = "^0.8.6"
+nox-poetry = "^0.9.0"
rich = ">=10.0"
sphinx-autobuild = "^2021.3.14"