summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorJordan Cook <jordan.cook@pioneer.com>2022-04-19 15:15:07 -0500
committerJordan Cook <jordan.cook@pioneer.com>2022-04-19 15:21:26 -0500
commita0ac951a90b050a5d48158a9a33cabbc362f70db (patch)
treeed1be90a08d1905915faa2ab749e523109559eab /pyproject.toml
parent899d706db01ffdbf51351f0917879a15354def6a (diff)
downloadrequests-cache-a0ac951a90b050a5d48158a9a33cabbc362f70db.tar.gz
Run pytest --verbose in CI
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml17
1 files changed, 6 insertions, 11 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 833b5cb..ffeb857 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -33,21 +33,16 @@ requests = "^2.22" # Needs no introduction
urllib3 = ">=1.25.5" # Use a slightly newer version than required by requests (for bugfixes)
attrs = ">=21.2" # For response data models
cattrs = ">=22.0" # For response serialization
-platformdirs = "^2.5" # For options that use platform-specific user cache dirs
-url-normalize = "^1.4" # For improved request matching
+platformdirs = "^2.5" # For features that use platform-specific system directories
+url-normalize = "^1.4" # For more accurate request matching
# Optional backend dependencies
boto3 = {optional=true, version="^1.15"}
botocore = {optional=true, version="^1.18"}
-pymongo = [
- {optional=true, version=">=3,<4.1", python="<3.9"},
- {optional=true, version=">=3", python=">=3.9"},
- ]
-redis = [
- {optional=true, version=">=3,<4.2", python="<3.9"},
- {optional=true, version=">=3", python=">=3.9"},
- ]
-
+pymongo = [{optional=true, version=">=3,<4.1", python="<3.9"},
+ {optional=true, version=">=3", python=">=3.9"}]
+redis = [{optional=true, version=">=3,<4.2", python="<3.9"},
+ {optional=true, version=">=3", python=">=3.9"}]
# Optional serialization dependencies
bson = {optional=true, version=">=0.5"}