summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorJordan Cook <jordan.cook.git@proton.me>2023-03-24 20:58:33 -0500
committerJordan Cook <jordan.cook.git@proton.me>2023-04-02 21:42:25 -0500
commitb5d7d1546d953157ca7eb70838c6cb6f6f7651e3 (patch)
tree11ebbe68b4a7e29b8e6ee35381531ef8e185d3f3 /pyproject.toml
parent8e4de3c35ebb8028d24dd1a874ec3e3348ed0b6a (diff)
downloadrequests-cache-b5d7d1546d953157ca7eb70838c6cb6f6f7651e3.tar.gz
Use time-machine instead of sleep for timing-based tests
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml3
1 files changed, 2 insertions, 1 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 9c647b5..d4edfda 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -53,7 +53,7 @@ ujson = {optional=true, version=">=5.4"}
# Dependencies for building documentation;
# defined here because readthedocs doesn't (yet?) support poetry.dev-dependencies
-furo = {optional=true, version="^2022.12.7"}
+furo = {optional=true, version="^2023.3"}
linkify-it-py = {optional=true, version="^2.0"}
myst-parser = {optional=true, version="^1.0"}
sphinx = {optional=true, version="^5.0.2"}
@@ -98,6 +98,7 @@ requests-mock = "^1.9"
responses = "0.19.0"
tenacity = "^8.0"
timeout-decorator = "^0.5"
+time-machine = {version = "^2.9", markers = "implementation_name != 'pypy'"}
# Tools for linting, type checking, etc. are managed with pre-commit
pre-commit = "^2.19"