summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorJordan Cook <jordan.cook@pioneer.com>2022-06-17 15:28:07 -0500
committerJordan Cook <jordan.cook@pioneer.com>2022-06-17 16:02:13 -0500
commitbe9ab4157ff58f6b547e594cb427f3a818f32f51 (patch)
tree3f5ddaba9621cb72b38ac9d8aed61c7338a0e4fb /pyproject.toml
parent53134ef0e99d713fed62515dfb7bcfaac5f63f9d (diff)
downloadrequests-cache-be9ab4157ff58f6b547e594cb427f3a818f32f51.tar.gz
Sphinx + extension updates:
* Update to Sphinx 5 * Add sphinxext-opengraph * Replace sphinx-panels with sphinx-design (its intended successor)
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml11
1 files changed, 6 insertions, 5 deletions
diff --git a/pyproject.toml b/pyproject.toml
index c62f8c6..6fc7a75 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -49,17 +49,18 @@ ujson = {optional=true, version=">=4.0"}
# Dependencies for building documentation;
# defined here because readthedocs doesn't (yet?) support poetry.dev-dependencies
-furo = {optional=true, version="^2022.4"}
+furo = {optional=true, version="^2022.6"}
linkify-it-py = {optional=true, version="^2.0"}
myst-parser = {optional=true, version=">=0.17"}
-sphinx = {optional=true, version="^4.5.0"}
+sphinx = {optional=true, version="^5.0.2"}
sphinx-autodoc-typehints = {optional=true, version="^1.18"}
sphinx-automodapi = {optional=true, version=">=0.14"}
sphinx-copybutton = {optional=true, version=">=0.5"}
+sphinx-design = {optional=true, version=">=0.2"}
sphinx-inline-tabs = {optional=true, version=">=2022.1.2b11", python=">=3.8"}
sphinx-notfound-page = {optional=true, version=">=0.8"}
-sphinx-panels = {optional=true, version="^0.6"}
sphinxcontrib-apidoc = {optional=true, version="^0.3"}
+sphinxext-opengraph = {optional=true, version = ">=0.6"}
# Temporary fix until cattrs 22.2.0 is released
exceptiongroup = {version = "^1.0.0-rc.3", python = "^3.10.0"}
@@ -81,8 +82,8 @@ all = ["boto3", "botocore", "itsdangerous", "pymongo", "pyyaml", "redis", "
# Documentation
docs = ["furo", "linkify-it-py", "myst-parser", "sphinx", "sphinx-autodoc-typehints",
- "sphinx-automodapi", "sphinx-copybutton", "sphinx-inline-tabs", "sphinx-panels",
- "sphinx-notfound-page", "sphinxcontrib-apidoc"]
+ "sphinx-automodapi", "sphinx-copybutton", "sphinx-design", "sphinx-inline-tabs",
+ "sphinx-notfound-page", "sphinxcontrib-apidoc", "sphinxext-opengraph"]
[tool.poetry.dev-dependencies]
# For unit + integration tests