summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorJordan Cook <jordan.cook@pioneer.com>2022-04-22 14:19:04 -0500
committerJordan Cook <jordan.cook@pioneer.com>2022-04-22 14:19:04 -0500
commitd7d8e3d797cb03152244fd575d15caa9176dbd0a (patch)
tree8f75cf9877e2554eb741ee3bc01c9f59b586a92f /pyproject.toml
parent7a5311cf7328c679073757c1e4e6c3958d220400 (diff)
downloadrequests-cache-d7d8e3d797cb03152244fd575d15caa9176dbd0a.tar.gz
Temporary fix for missing 'exceptiongroup' dependency in cattrs 22.1 for python 3.10
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml6
1 files changed, 4 insertions, 2 deletions
diff --git a/pyproject.toml b/pyproject.toml
index ef755c0..722f159 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -32,7 +32,7 @@ python = "^3.7"
requests = "^2.22" # Needs no introduction
urllib3 = ">=1.25.5" # Use a slightly newer version than required by requests (for bugfixes)
attrs = ">=21.2" # For response data models
-cattrs = ">=22.0" # For response serialization
+cattrs = ">=22.1" # For response serialization
platformdirs = "^2.5" # For features that use platform-specific system directories
url-normalize = "^1.4" # For more accurate request matching
@@ -62,6 +62,9 @@ sphinx-notfound-page = {optional=true, version=">=0.8"}
sphinx-panels = {optional=true, version="^0.6"}
sphinxcontrib-apidoc = {optional=true, version="^0.3"}
+# Temporary fix until cattrs 22.2.0 is released
+exceptiongroup = {version = "^1.0.0-rc.3", python = "^3.10.0"}
+
[tool.poetry.extras]
# Package extras for optional backend dependencies
dynamodb = ["boto3", "botocore"]
@@ -85,7 +88,6 @@ docs = ["furo", "linkify-it-py", "myst-parser", "sphinx", "sphinx-autodoc-ty
[tool.poetry.dev-dependencies]
# For unit + integration tests
coverage = "^6.3"
-exceptiongroup = "*"
psutil = "^5.0"
pytest = "^7.1"
pytest-clarity = "^1.0.1"