summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorJordan Cook <jordan.cook@pioneer.com>2021-11-13 12:44:41 -0600
committerJordan Cook <jordan.cook@pioneer.com>2021-11-13 12:44:41 -0600
commitda847a2fc0dbf40fbb8596a74450f84b3c2db114 (patch)
treec807cb82afba990fcfb02fdf26c5a75ee511bd99 /pyproject.toml
parent0199f062968148b8f6560f861a73f12e9348cc0d (diff)
downloadrequests-cache-da847a2fc0dbf40fbb8596a74450f84b3c2db114.tar.gz
Bump dev dependencies and pre-commit hooks
Bump sphinx-notfound-page from 0.7.1 to 0.8 Bumps [sphinx-notfound-page](https://github.com/readthedocs/sphinx-notfound-page) from 0.7.1 to 0.8. - [Release notes](https://github.com/readthedocs/sphinx-notfound-page/releases) - [Changelog](https://github.com/readthedocs/sphinx-notfound-page/blob/master/CHANGELOG.rst) - [Commits](https://github.com/readthedocs/sphinx-notfound-page/compare/0.7.1...0.8) --- updated-dependencies: - dependency-name: sphinx-notfound-page dependency-type: direct:production update-type: version-update:semver-minor ... Signed-off-by: dependabot[bot] <support@github.com> Bump rich from 10.12.0 to 10.13.0 Bumps [rich](https://github.com/willmcgugan/rich) from 10.12.0 to 10.13.0. - [Release notes](https://github.com/willmcgugan/rich/releases) - [Changelog](https://github.com/willmcgugan/rich/blob/master/CHANGELOG.md) - [Commits](https://github.com/willmcgugan/rich/compare/v10.12.0...v10.13.0) --- updated-dependencies: - dependency-name: rich dependency-type: direct:development update-type: version-update:semver-minor ... Signed-off-by: dependabot[bot] <support@github.com> Bump furo from 2021.10.9 to 2021.11.12.1 Bumps [furo](https://github.com/pradyunsg/furo) from 2021.10.9 to 2021.11.12.1. - [Release notes](https://github.com/pradyunsg/furo/releases) - [Changelog](https://github.com/pradyunsg/furo/blob/main/docs/changelog.md) - [Commits](https://github.com/pradyunsg/furo/compare/2021.10.09...2021.11.12.1) --- updated-dependencies: - dependency-name: furo dependency-type: direct:production update-type: version-update:semver-minor ... Signed-off-by: dependabot[bot] <support@github.com> Bump sphinx from 4.2.0 to 4.3.0 Bumps [sphinx](https://github.com/sphinx-doc/sphinx) from 4.2.0 to 4.3.0. - [Release notes](https://github.com/sphinx-doc/sphinx/releases) - [Changelog](https://github.com/sphinx-doc/sphinx/blob/4.x/CHANGES) - [Commits](https://github.com/sphinx-doc/sphinx/compare/v4.2.0...v4.3.0) --- updated-dependencies: - dependency-name: sphinx dependency-type: direct:production update-type: version-update:semver-minor ... Signed-off-by: dependabot[bot] <support@github.com>
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml6
1 files changed, 3 insertions, 3 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 1761209..640c2f5 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -53,7 +53,7 @@ ujson = {optional=true, version=">=4.0"}
furo = {optional=true, version=">=2021.9.8"}
linkify-it-py = {optional=true, version="^1.0.1"}
myst-parser = {optional=true, version="^0.15.1"}
-sphinx = {optional=true, version="4.2.0"}
+sphinx = {optional=true, version="4.3.0"}
sphinx-autodoc-typehints = {optional=true, version="^1.11"}
sphinx-automodapi = {optional=true, version="^0.13"}
sphinx-copybutton = {optional=true, version=">=0.3,<0.5"}
@@ -84,7 +84,7 @@ docs = ["furo", "linkify-it-py", "myst-parser", "sphinx", "sphinx-autodoc-ty
[tool.poetry.dev-dependencies]
# For unit + integration tests
-coverage = "^6.0"
+coverage = "^6.1"
psutil = "^5.0"
pytest = "^6.2"
pytest-clarity = "^1.0.1"
@@ -92,7 +92,7 @@ pytest-cov = ">=3.0"
pytest-rerunfailures = "^10.1"
pytest-xdist = ">=2.2"
requests-mock = "^1.8"
-responses = "0.14"
+responses = "0.15"
timeout-decorator = "^0.5"
# Tools for linting, type checking, etc. are managed with pre-commit