summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--HISTORY.md5
-rw-r--r--file::memory:?cache=sharedbin0 -> 16384 bytes
-rw-r--r--noxfile.py4
-rw-r--r--poetry.lock12
-rw-r--r--pyproject.toml26
5 files changed, 27 insertions, 20 deletions
diff --git a/HISTORY.md b/HISTORY.md
index e1b3590..c0bae25 100644
--- a/HISTORY.md
+++ b/HISTORY.md
@@ -118,6 +118,11 @@ If you encounter a problem not listed here after updating to 1.0, please create
* Internal utility module changes:
* The `cache_control` module (added in `0.7`) has been split up into multiple modules in a new `policy` subpackage
+### 0.9.6 (2022-08-24)
+* Remove potentially problematic row count from `BaseCache.__str__()`
+* Remove upper version constraints for all non-dev dependencies
+* Make dependency specification consistent between PyPI and Conda-Forge packages
+
### 0.9.5 (2022-06-29)
* Backport bugfixes from 1.0
diff --git a/file::memory:?cache=shared b/file::memory:?cache=shared
new file mode 100644
index 0000000..a58f947
--- /dev/null
+++ b/file::memory:?cache=shared
Binary files differ
diff --git a/noxfile.py b/noxfile.py
index e852294..b25854c 100644
--- a/noxfile.py
+++ b/noxfile.py
@@ -44,7 +44,9 @@ def test(session):
@session(python=False, name='test-current')
def test_current(session):
"""Run tests using the current virtualenv"""
- test(session)
+ test_paths = session.posargs or [UNIT_TESTS, INTEGRATION_TESTS]
+ cmd = f'pytest -rs {XDIST_ARGS}'
+ session.run(*cmd.split(' '), *test_paths)
@session(python=False)
diff --git a/poetry.lock b/poetry.lock
index 91fab7f..7c79818 100644
--- a/poetry.lock
+++ b/poetry.lock
@@ -81,14 +81,14 @@ lxml = ["lxml"]
[[package]]
name = "boto3"
-version = "1.24.57"
+version = "1.24.59"
description = "The AWS SDK for Python"
category = "dev"
optional = true
python-versions = ">= 3.7"
[package.dependencies]
-botocore = ">=1.27.57,<1.28.0"
+botocore = ">=1.27.59,<1.28.0"
jmespath = ">=0.7.1,<2.0.0"
s3transfer = ">=0.6.0,<0.7.0"
@@ -97,7 +97,7 @@ crt = ["botocore[crt] (>=1.21.0,<2.0a0)"]
[[package]]
name = "botocore"
-version = "1.27.57"
+version = "1.27.59"
description = "Low-level, data-driven core of boto 3."
category = "dev"
optional = true
@@ -868,7 +868,7 @@ crt = ["botocore[crt] (>=1.20.29,<2.0a.0)"]
[[package]]
name = "setuptools"
-version = "65.2.0"
+version = "65.3.0"
description = "Easily download, build, install, upgrade, and uninstall Python packages"
category = "dev"
optional = false
@@ -1291,8 +1291,8 @@ yaml = ["pyyaml"]
[metadata]
lock-version = "1.1"
-python-versions = "^3.7"
-content-hash = "3574d9e8a65d4f894d86af69b663b97fca316cd490e123cf27b38ba2217958e4"
+python-versions = "^3.7" # requests requires python >=3.7, <4.0
+content-hash = "ea39161c795ec7ea80f5a3f51caedba1bb995f379c31eb4b994295d2d5052c1f"
[metadata.files]
alabaster = []
diff --git a/pyproject.toml b/pyproject.toml
index 732059b..e2377f6 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -25,45 +25,45 @@ include = [
]
[tool.poetry.dependencies]
-python = "^3.7"
+python = "^3.7" # requests requires python >=3.7, <4.0
# Required dependencies
-requests = "^2.22" # Needs no introduction
+requests = ">=2.22" # Needs no introduction
urllib3 = ">=1.25.5" # Use a slightly newer version than required by requests (for bugfixes)
attrs = ">=21.2" # For response data models
cattrs = ">=22.1" # For response serialization
-platformdirs = "^2.5" # For features that use platform-specific system directories
-url-normalize = "^1.4" # For more accurate request matching
+platformdirs = ">=2.5" # For features that use platform-specific system directories
+url-normalize = ">=1.4" # For more accurate request matching
+
+# Temporary workaround until cattrs 22.2.0 is released
+exceptiongroup = {version=">=1.0.0-rc.8", python="<3.11"}
# Optional backend dependencies
-boto3 = {optional=true, version="^1.15"}
-botocore = {optional=true, version="^1.18"}
+boto3 = {optional=true, version=">=1.15"}
+botocore = {optional=true, version=">=1.18"}
pymongo = {optional=true, version=">=3"}
redis = {optional=true, version=">=3"}
# Optional serialization dependencies
bson = {optional=true, version=">=0.5"}
-itsdangerous = {optional=true, version="^2.0"}
+itsdangerous = {optional=true, version=">=2.0"}
pyyaml = {optional=true, version=">=5.4"}
ujson = {optional=true, version=">=5.4"}
# Dependencies for building documentation;
# defined here because readthedocs doesn't (yet?) support poetry.dev-dependencies
furo = {optional=true, version="^2022.6"}
-linkify-it-py = {optional=true, version="^2.0"}
+linkify-it-py = {optional=true, version=">=2.0"}
myst-parser = {optional=true, version=">=0.17"}
sphinx = {optional=true, version="^5.0.2"}
-sphinx-autodoc-typehints = {optional=true, version="^1.19"}
+sphinx-autodoc-typehints = {optional=true, version=">=1.19"}
sphinx-automodapi = {optional=true, version=">=0.14"}
sphinx-copybutton = {optional=true, version=">=0.5"}
sphinx-design = {optional=true, version=">=0.2"}
sphinx-notfound-page = {optional=true, version=">=0.8"}
-sphinxcontrib-apidoc = {optional=true, version="^0.3"}
+sphinxcontrib-apidoc = {optional=true, version=">=0.3"}
sphinxext-opengraph = {optional=true, version=">=0.6"}
-# Temporary fix until cattrs 22.2.0 is released
-exceptiongroup = {version = "^1.0.0-rc.3", python = "^3.10.0"}
-
[tool.poetry.extras]
# Package extras for optional backend dependencies
dynamodb = ["boto3", "botocore"]