summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--docs/conf.py1
-rw-r--r--docs/user_guide/backends.md8
-rw-r--r--docs/user_guide/files.md23
-rw-r--r--docs/user_guide/installation.md10
-rw-r--r--poetry.lock37
-rw-r--r--pyproject.toml5
6 files changed, 40 insertions, 44 deletions
diff --git a/docs/conf.py b/docs/conf.py
index a5dfadb..224e65e 100644
--- a/docs/conf.py
+++ b/docs/conf.py
@@ -51,7 +51,6 @@ extensions = [
'sphinx_automodapi.smart_resolver',
'sphinx_copybutton',
'sphinx_design',
- 'sphinx_inline_tabs',
'sphinxcontrib.apidoc',
'sphinxext.opengraph',
'myst_parser',
diff --git a/docs/user_guide/backends.md b/docs/user_guide/backends.md
index 8238665..8eb06a5 100644
--- a/docs/user_guide/backends.md
+++ b/docs/user_guide/backends.md
@@ -75,14 +75,16 @@ If you just want to quickly try out all of the available backends for comparison
[docker-compose](https://docs.docker.com/compose/) config is included for all supported services.
First, [install docker](https://docs.docker.com/get-docker/) if you haven't already. Then, run:
-:::{tab} Bash (Linux/macOS)
+::::{tab-set}
+
+:::{tab-item} Bash (Linux/macOS)
```bash
pip install -U requests-cache[all] docker-compose
curl https://raw.githubusercontent.com/requests-cache/requests-cache/main/docker-compose.yml -O docker-compose.yml
docker-compose up -d
```
:::
-:::{tab} Powershell (Windows)
+:::{tab-item} Powershell (Windows)
```ps1
pip install -U requests-cache[all] docker-compose
Invoke-WebRequest -Uri https://raw.githubusercontent.com/requests-cache/requests-cache/main/docker-compose.yml -Outfile docker-compose.yml
@@ -90,6 +92,8 @@ docker-compose up -d
```
:::
+::::
+
(exporting)=
## Exporting To A Different Backend
If you have cached data that you want to copy or migrate to a different backend, you can do this
diff --git a/docs/user_guide/files.md b/docs/user_guide/files.md
index c47783e..94ced46 100644
--- a/docs/user_guide/files.md
+++ b/docs/user_guide/files.md
@@ -38,21 +38,25 @@ If you don't know exactly where you want to put your cache files, your system's
or **cache directory** is a good choice. Some options are available as shortcuts for these locations.
Use the default temp directory with the `use_temp` option:
-:::{tab} Linux
+::::{tab-set}
+:::{tab-item} Linux
+:sync: linux
```python
>>> session = CachedSession('http_cache', backend='sqlite', use_temp=True)
>>> print(session.cache.db_path)
'/tmp/http_cache.sqlite'
```
:::
-:::{tab} macOS
+:::{tab-item} macOS
+:sync: macos
```python
>>> session = CachedSession('http_cache', backend='sqlite', use_temp=True)
>>> print(session.cache.db_path)
'/var/folders/xx/http_cache.sqlite'
```
:::
-:::{tab} Windows
+:::{tab-item} Windows
+:sync: windows
```python
>>> session = CachedSession('http_cache', backend='sqlite', use_temp=True)
>>> print(session.cache.db_path)
@@ -60,28 +64,35 @@ Use the default temp directory with the `use_temp` option:
```
:::
+::::
+
Or use the default cache directory with the `use_cache_dir` option:
-:::{tab} Linux
+::::{tab-set}
+:::{tab-item} Linux
+:sync: linux
```python
>>> session = CachedSession('http_cache', backend='filesystem', use_cache_dir=True)
>>> print(session.cache.cache_dir)
'/home/user/.cache/http_cache/'
```
:::
-:::{tab} macOS
+:::{tab-item} macOS
+:sync: macos
```python
>>> session = CachedSession('http_cache', backend='filesystem', use_cache_dir=True)
>>> print(session.cache.cache_dir)
'/Users/user/Library/Caches/http_cache/'
```
:::
-:::{tab} Windows
+:::{tab-item} Windows
+:sync: windows
```python
>>> session = CachedSession('http_cache', backend='filesystem', use_cache_dir=True)
>>> print(session.cache.cache_dir)
'C:\\Users\\user\\AppData\\Local\\http_cache\\'
```
:::
+::::
```{note}
If the cache name is an absolute path, the `use_temp` and `use_cache_dir` options will be ignored.
diff --git a/docs/user_guide/installation.md b/docs/user_guide/installation.md
index 65ab45d..8abff9b 100644
--- a/docs/user_guide/installation.md
+++ b/docs/user_guide/installation.md
@@ -1,27 +1,29 @@
# {fas}`download` Installation
Installation instructions:
-:::{tab} Pip
+::::{tab-set}
+:::{tab-item} Pip
Install the latest stable version from [PyPI](https://pypi.org/project/requests-cache/):
```
pip install requests-cache
```
:::
-:::{tab} Conda
+:::{tab-item} Conda
Or install from [conda-forge](https://anaconda.org/conda-forge/requests-cache), if you prefer:
```
conda install -c conda-forge requests-cache
```
:::
-:::{tab} Pre-release
+:::{tab-item} Pre-release
If you would like to use the latest development (pre-release) version:
```
pip install --pre requests-cache
```
:::
-:::{tab} Local development
+:::{tab-item} Local development
See {ref}`contributing` for setup steps for local development
:::
+::::
(requirements)=
## Requirements
diff --git a/poetry.lock b/poetry.lock
index 063a858..8904b34 100644
--- a/poetry.lock
+++ b/poetry.lock
@@ -81,14 +81,14 @@ lxml = ["lxml"]
[[package]]
name = "boto3"
-version = "1.24.11"
+version = "1.24.12"
description = "The AWS SDK for Python"
category = "main"
optional = true
python-versions = ">= 3.7"
[package.dependencies]
-botocore = ">=1.27.11,<1.28.0"
+botocore = ">=1.27.12,<1.28.0"
jmespath = ">=0.7.1,<2.0.0"
s3transfer = ">=0.6.0,<0.7.0"
@@ -97,7 +97,7 @@ crt = ["botocore[crt] (>=1.21.0,<2.0a0)"]
[[package]]
name = "botocore"
-version = "1.27.11"
+version = "1.27.12"
description = "Low-level, data-driven core of boto 3."
category = "main"
optional = true
@@ -1024,21 +1024,6 @@ theme_rtd = ["sphinx-rtd-theme (>=1.0,<2.0)"]
theme_sbt = ["sphinx-book-theme (>=0.3.0,<0.4.0)"]
[[package]]
-name = "sphinx-inline-tabs"
-version = "2022.1.2b11"
-description = "Add inline tabbed content to your Sphinx documentation."
-category = "main"
-optional = true
-python-versions = ">=3.8"
-
-[package.dependencies]
-sphinx = ">=3"
-
-[package.extras]
-doc = ["myst-parser", "furo"]
-test = ["pytest", "pytest-cov", "pytest-xdist"]
-
-[[package]]
name = "sphinx-notfound-page"
version = "0.8"
description = "Sphinx extension to build a 404 page with absolute URLs"
@@ -1273,7 +1258,7 @@ testing = ["pytest (>=6)", "pytest-checkdocs (>=2.4)", "pytest-flake8", "pytest-
[extras]
all = ["boto3", "botocore", "itsdangerous", "pymongo", "pyyaml", "redis", "ujson"]
bson = ["bson"]
-docs = ["furo", "linkify-it-py", "myst-parser", "sphinx", "sphinx-autodoc-typehints", "sphinx-automodapi", "sphinx-copybutton", "sphinx-design", "sphinx-inline-tabs", "sphinx-notfound-page", "sphinxcontrib-apidoc", "sphinxext-opengraph"]
+docs = ["furo", "linkify-it-py", "myst-parser", "sphinx", "sphinx-autodoc-typehints", "sphinx-automodapi", "sphinx-copybutton", "sphinx-design", "sphinx-notfound-page", "sphinxcontrib-apidoc", "sphinxext-opengraph"]
dynamodb = ["boto3", "botocore"]
json = ["ujson"]
mongodb = ["pymongo"]
@@ -1284,7 +1269,7 @@ yaml = ["pyyaml"]
[metadata]
lock-version = "1.1"
python-versions = "^3.7"
-content-hash = "9f1a385d623df09563dec18464c5c1509f0b7dad719aa30947de59c804ece065"
+content-hash = "c9ef76333cfb9fb1e8d44ece7049a674d47b17efc84c1f8173b21d1cb54ab4ad"
[metadata.files]
alabaster = [
@@ -1316,12 +1301,12 @@ beautifulsoup4 = [
{file = "beautifulsoup4-4.11.1.tar.gz", hash = "sha256:ad9aa55b65ef2808eb405f46cf74df7fcb7044d5cbc26487f96eb2ef2e436693"},
]
boto3 = [
- {file = "boto3-1.24.11-py3-none-any.whl", hash = "sha256:19d6fb2b5e51f10e7b5d551a111cf9c64b9a5144b2838493ac41be0706e590cf"},
- {file = "boto3-1.24.11.tar.gz", hash = "sha256:79fc9699006af26de4413105e458af5f1626ba32d1f00fa0b3e8b94c2b16e2dc"},
+ {file = "boto3-1.24.12-py3-none-any.whl", hash = "sha256:0b9757575b8003928defc5fb6e816936fa1bdb1384d0edec6622bb9fb104e96c"},
+ {file = "boto3-1.24.12.tar.gz", hash = "sha256:f39b91a4c3614db8e44912ee82426fb4b16d5df2cd66883f3aff6f76d7f5d310"},
]
botocore = [
- {file = "botocore-1.27.11-py3-none-any.whl", hash = "sha256:8efab7f85156705cbe532aeb17b065b67ba32addc3270d9000964b98c07bb20a"},
- {file = "botocore-1.27.11.tar.gz", hash = "sha256:92f099a36df832d7f151682e1efa8e1d47d23a5cedde8692adcaa6420bcb18aa"},
+ {file = "botocore-1.27.12-py3-none-any.whl", hash = "sha256:b8ac156e55267da6e728ea0b806bfcd97adf882801cffe7849c4b88ce4780326"},
+ {file = "botocore-1.27.12.tar.gz", hash = "sha256:17d3ec9f684d21e06b64d9cb224934557bcd95031e2ecb551bf16271e8722fec"},
]
bson = [
{file = "bson-0.5.10.tar.gz", hash = "sha256:d6511b2ab051139a9123c184de1a04227262173ad593429d21e443d6462d6590"},
@@ -1823,10 +1808,6 @@ sphinx-design = [
{file = "sphinx_design-0.2.0-py3-none-any.whl", hash = "sha256:5c7117cb4b566bd769dcb4314a64d72257ae89724b4917a8f2ef55459e1d861b"},
{file = "sphinx_design-0.2.0.tar.gz", hash = "sha256:b148a5258061a46ee826d57ea0729260f29b4e9131d2a681545e0d4f3c0f19ee"},
]
-sphinx-inline-tabs = [
- {file = "sphinx_inline_tabs-2022.1.2b11-py3-none-any.whl", hash = "sha256:bb4e807769ef52301a186d0678da719120b978a1af4fd62a1e9453684e962dbc"},
- {file = "sphinx_inline_tabs-2022.1.2b11.tar.gz", hash = "sha256:afb9142772ec05ccb07f05d8181b518188fc55631b26ee803c694e812b3fdd73"},
-]
sphinx-notfound-page = [
{file = "sphinx-notfound-page-0.8.tar.gz", hash = "sha256:39bf5b99e1fbf6164631ecac2b58038f08e0ab9278c563076aadd1cf04b6bb7a"},
{file = "sphinx_notfound_page-0.8-py3-none-any.whl", hash = "sha256:1901e01df9931922e87ef1f967042322b06a65790132cbd393861261e023b974"},
diff --git a/pyproject.toml b/pyproject.toml
index 6fc7a75..31bd104 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -57,7 +57,6 @@ sphinx-autodoc-typehints = {optional=true, version="^1.18"}
sphinx-automodapi = {optional=true, version=">=0.14"}
sphinx-copybutton = {optional=true, version=">=0.5"}
sphinx-design = {optional=true, version=">=0.2"}
-sphinx-inline-tabs = {optional=true, version=">=2022.1.2b11", python=">=3.8"}
sphinx-notfound-page = {optional=true, version=">=0.8"}
sphinxcontrib-apidoc = {optional=true, version="^0.3"}
sphinxext-opengraph = {optional=true, version = ">=0.6"}
@@ -82,8 +81,8 @@ all = ["boto3", "botocore", "itsdangerous", "pymongo", "pyyaml", "redis", "
# Documentation
docs = ["furo", "linkify-it-py", "myst-parser", "sphinx", "sphinx-autodoc-typehints",
- "sphinx-automodapi", "sphinx-copybutton", "sphinx-design", "sphinx-inline-tabs",
- "sphinx-notfound-page", "sphinxcontrib-apidoc", "sphinxext-opengraph"]
+ "sphinx-automodapi", "sphinx-copybutton", "sphinx-design", "sphinx-notfound-page",
+ "sphinxcontrib-apidoc", "sphinxext-opengraph"]
[tool.poetry.dev-dependencies]
# For unit + integration tests