summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml22
1 files changed, 16 insertions, 6 deletions
diff --git a/pyproject.toml b/pyproject.toml
index aacaad6..a39fd4b 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -39,8 +39,15 @@ url-normalize = "^1.4" # For improved request matching
# Optional backend dependencies
boto3 = {optional=true, version="^1.15"}
botocore = {optional=true, version="^1.18"}
-pymongo = {optional=true, version=">=3,<5"}
-redis = {optional=true, version=">=3,<4.2"}
+pymongo = [
+ {optional=true, version=">=3,<4.1", python="<3.9"},
+ {optional=true, version=">=3", python=">=3.9"},
+ ]
+redis = [
+ {optional=true, version=">=3,<4.2", python="<3.9"},
+ {optional=true, version=">=3", python=">=3.9"},
+ ]
+
# Optional serialization dependencies
bson = {optional=true, version=">=0.5"}
@@ -86,24 +93,27 @@ docs = ["furo", "linkify-it-py", "myst-parser", "sphinx", "sphinx-autodoc-ty
# For unit + integration tests
coverage = "^6.3"
psutil = "^5.0"
-pytest = "^6.2"
+pytest = "^7.1"
pytest-clarity = "^1.0.1"
pytest-cov = ">=3.0"
pytest-rerunfailures = "^10.1"
pytest-xdist = ">=2.2"
-requests-mock = "^1.8"
+requests-mock = "^1.9"
responses = "0.19.0"
timeout-decorator = "^0.5"
# Tools for linting, type checking, etc. are managed with pre-commit
-pre-commit = "^2.15"
+pre-commit = "^2.18"
# For convenience in local development
-nox = "^2021.10.1"
+nox = "^2022.1.7"
nox-poetry = "^0.9.0"
rich = ">=10.0"
sphinx-autobuild = "^2021.3.14"
+# Workaround for missing dependency on python 3.7
+zipp = {version = ">=3.8", python = "<3.8"}
+
[build-system]
requires = ["poetry-core>=1.0.0"]
build-backend = "poetry.core.masonry.api"