summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRay Holder <ray@blacklocus.com>2013-01-21 02:14:31 -0600
committerRay Holder <ray@blacklocus.com>2013-01-21 02:14:31 -0600
commit4c30bdb48f4e0afb830d8284bdfd42cb20d58d49 (patch)
tree31f9b3ad87f66b2d4207debb10c8c0a0b200ddb0
parenta6e0b2e702df5bb7f479ebd7e0ca3ced88e483b8 (diff)
downloadretrying-4c30bdb48f4e0afb830d8284bdfd42cb20d58d49.tar.gz
add test suite, clean up packaging
-rw-r--r--__init__.py1
-rw-r--r--setup.py6
-rw-r--r--test_retrying.py (renamed from test.py)6
3 files changed, 5 insertions, 8 deletions
diff --git a/__init__.py b/__init__.py
deleted file mode 100644
index 30e1e35..0000000
--- a/__init__.py
+++ /dev/null
@@ -1 +0,0 @@
-__author__ = 'rholder' \ No newline at end of file
diff --git a/setup.py b/setup.py
index e5f6aa5..f57f795 100644
--- a/setup.py
+++ b/setup.py
@@ -19,12 +19,14 @@ if sys.argv[-1] == 'publish':
settings.update(
name='retrying',
version='1.0.0',
- description='Retry any arbitrary function conditionally via a decorator.',
- long_description=open('README.rst').read(),
+ description='Retrying',
+ long_description=open('README.rst').read() + '\n\n' +
+ open('HISTORY.rst').read(),
author='Ray Holder',
url='https://github.com/rholder/retrying',
keywords="context manager decorator decorators retry retrying exception exponential backoff",
py_modules= ['retrying'],
+ test_suite="test_retrying",
classifiers=(
'Intended Audience :: Developers',
'Natural Language :: English',
diff --git a/test.py b/test_retrying.py
index 36b2327..f6dc3f9 100644
--- a/test.py
+++ b/test_retrying.py
@@ -108,8 +108,6 @@ class TestWaitConditions(unittest.TestCase):
self.assertEqual(r.wait(7, 0), 50000)
self.assertEqual(r.wait(50, 0), 50000)
-
-
class NoneReturnUntilAfterCount:
"""
This class holds counter state for invoking a method several times in a row.
@@ -157,7 +155,7 @@ class NoNameErrorAfterCount:
def go(self):
"""
- Raise an NameError until after count threshold has been crossed, then return True.
+ Raise a NameError until after count threshold has been crossed, then return True.
"""
if self.counter < self.count:
self.counter += 1
@@ -226,7 +224,5 @@ class TestDecoratorWrapper(unittest.TestCase):
self.assertTrue(re.last_attempt.has_exception)
self.assertTrue(isinstance(re.last_attempt.value, IOError))
- #TODO YOU ARE HERE, CONTINUE TESTING
-
if __name__ == '__main__':
unittest.main() \ No newline at end of file