summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephen Finucane <stephen@that.guru>2019-06-11 15:02:30 +0100
committerStephen Finucane <stephen@that.guru>2019-06-11 15:05:25 +0100
commit0250968ee81d36de7dabbe19d76a418a202ca163 (patch)
treec849971f4ea93742a432d5dca1e34fb1375783f0
parent9cd647a12f38de5082f4c052c2f355858b65f724 (diff)
downloadroutes-0250968ee81d36de7dabbe19d76a418a202ca163.tar.gz
Remove support for Python 2.6, 3.3, 3.4
These are all EOL [1]. We should not claim to support them. Users wishing to use routes with an older version of Python should use an older version of routes. [1] https://devguide.python.org/devcycle/#end-of-life-branches Signed-off-by: Stephen Finucane <stephen@that.guru>
-rw-r--r--.travis.yml17
-rw-r--r--routes/route.py3
-rw-r--r--setup.py4
-rw-r--r--tox.ini2
4 files changed, 8 insertions, 18 deletions
diff --git a/.travis.yml b/.travis.yml
index a38f7f3..f9a351f 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -1,21 +1,18 @@
language: python
python:
-- '2.6'
-- '2.7'
-- '3.3'
-- '3.4'
-- '3.5'
-- '3.6'
-- nightly
-- pypy
-- pypy3
+ - '2.7'
+ - '3.5'
+ - '3.6'
+ - nightly
+ - pypy
+ - pypy3
matrix:
allow_failures:
- python: nightly
install: pip install tox-travis
script: tox
after_success:
-- codecov
+ - codecov
deploy:
provider: pypi
user: bbangert
diff --git a/routes/route.py b/routes/route.py
index 860a911..c649786 100644
--- a/routes/route.py
+++ b/routes/route.py
@@ -1,7 +1,4 @@
import re
-import sys
-if sys.version < '2.4':
- from sets import ImmutableSet as frozenset
import six
from six.moves.urllib import parse as urlparse
diff --git a/setup.py b/setup.py
index b0dd322..92b9ee2 100644
--- a/setup.py
+++ b/setup.py
@@ -43,12 +43,8 @@ setup(name="Routes",
"Programming Language :: Python :: Implementation :: CPython",
'Programming Language :: Python',
"Programming Language :: Python :: 2",
- "Programming Language :: Python :: 2.6",
"Programming Language :: Python :: 2.7",
"Programming Language :: Python :: 3",
- "Programming Language :: Python :: 3.2",
- "Programming Language :: Python :: 3.3",
- "Programming Language :: Python :: 3.4",
"Programming Language :: Python :: 3.5",
"Programming Language :: Python :: 3.6"
],
diff --git a/tox.ini b/tox.ini
index 0988735..f979bbb 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,5 +1,5 @@
[tox]
-envlist = py26,py27,py33,py34,py35,py36,pypy,pypy3
+envlist = py{27,35,36},pypy,pypy3
[testenv]
deps=