summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Bangert <ben@groovie.org>2017-01-01 09:25:04 -0800
committerBen Bangert <ben@groovie.org>2017-01-01 09:25:04 -0800
commit2dcef8079cf09f427eeb0be62374f6c1a52bf59d (patch)
tree987ab5de184f7f97639318188c2f80ef1f288116
parent8b46c8442e8c7ead063dafa8f71ec42f745f177c (diff)
downloadroutes-2dcef8079cf09f427eeb0be62374f6c1a52bf59d.tar.gz
chore: tag 2.4.1 for release
-rw-r--r--.travis.yml29
-rw-r--r--docs/conf.py2
-rw-r--r--setup.py2
3 files changed, 21 insertions, 12 deletions
diff --git a/.travis.yml b/.travis.yml
index 484b853..8f23966 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -1,17 +1,26 @@
language: python
python:
- - "2.6"
- - "2.7"
- - "3.3"
- - "3.4"
- - "3.5"
- - "nightly"
- - "pypy"
- - "pypy3"
+- '2.6'
+- '2.7'
+- '3.3'
+- '3.4'
+- '3.5'
+- nightly
+- pypy
+- pypy3
matrix:
allow_failures:
- - python: "nightly"
+ - python: nightly
install: pip install tox-travis
script: tox
after_success:
- - codecov
+- codecov
+deploy:
+ provider: pypi
+ user: bbangert
+ password:
+ secure: OB4kVoPEymiU06AHjFxA4ORRIhvl46bmstkxB3gBxOLylUUpvMjspXIUX/dPww3PceiklUbot/Tww8ITn00hJYd7qF6vsOyDXMF3XyQ7a5mqDsGTbWYOVqpv/tn4+lvDMNVHRy2cY68BGsUEU/ePLi0oqhdBgct82bYkKrXrav0=
+ on:
+ tags: true
+ distributions: "sdist bdist_wheel"
+ skip_upload_docs: true
diff --git a/docs/conf.py b/docs/conf.py
index cbe24fa..0419479 100644
--- a/docs/conf.py
+++ b/docs/conf.py
@@ -44,7 +44,7 @@ copyright = '2005-2017, Ben Bangert, Mike Orr, and numerous contributers'
# The short X.Y version.
version = '2.4'
# The full version, including alpha/beta/rc tags.
-release = '2.4.0'
+release = '2.4.1'
# There are two options for replacing |today|: either, you set today to some
# non-false value, then it is used:
diff --git a/setup.py b/setup.py
index abbd7a7..4255f6d 100644
--- a/setup.py
+++ b/setup.py
@@ -1,4 +1,4 @@
-__version__ = '2.4.0'
+__version__ = '2.4.1'
import io
import os