summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin Abbi <robin.abbi@downley.net>2020-05-04 17:32:44 +0100
committerRobin Abbi <robin.abbi@downley.net>2020-05-04 17:32:44 +0100
commitbb7694b2ca8ac55a2bb671cc4c91fd55b3b8cc18 (patch)
tree1096e653c9994350ca0c2fbcd1ed13c3661f0373
parent4bb757bc865385c5c4e7912fc8789ea680807359 (diff)
downloadroutes-bb7694b2ca8ac55a2bb671cc4c91fd55b3b8cc18.tar.gz
Specify supersieve version (py2 compatibility)
BeautifulSoup states supersieve > 1.2 which is what gets picked up by distutils. v2.0 is found and installed. Setup then moves on to the next package in test_requires and when checking versions discovers the conditional in BeautifulSoup setup.py that if python major version == 2 then supersieve < v2.0 should be installed. If we need to preserve compatibility with py2 then reluctantly specify a version in our setup.
-rw-r--r--setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index b0dd322..1e85b77 100644
--- a/setup.py
+++ b/setup.py
@@ -60,7 +60,7 @@ setup(name="Routes",
test_suite="nose.collector",
include_package_data=True,
zip_safe=False,
- tests_require=['nose', 'webtest', 'webob', 'coverage'],
+ tests_require=["soupsieve<2.0", 'nose', 'webtest', 'webob', 'coverage'],
install_requires=[
"six",
"repoze.lru>=0.3"